LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Laptop and Netbook
User Name
Password
Linux - Laptop and Netbook Having a problem installing or configuring Linux on your laptop? Need help running Linux on your netbook? This forum is for you. This forum is for any topics relating to Linux and either traditional laptops or netbooks (such as the Asus EEE PC, Everex CloudBook or MSI Wind).

Notices

Reply
 
Search this Thread
Old 11-04-2009, 11:28 AM   #1
David Underhill
LQ Newbie
 
Registered: Nov 2009
Posts: 2

Rep: Reputation: 0
Tried to Install Flash Plugin but says "Authenticating as Root" password required


I am a total newbie to linux. have an Acer Aspire one with Linpus Linux Lite. Have downloaded the flash plugin ver 10 rel i386.rpm but when I open it I get the message "You are attempting to run"system-installation packages" which requires administrative priveleges, but more information is needed in order to do so. Authenticating as "root" Then it asks for a password. I cannot get past this point. Any ideas?
 
Old 11-04-2009, 11:34 AM   #2
ammorais
Member
 
Registered: Nov 2009
Location: Lisbon, Portugal
Distribution: Gentoo, CentOs, Ubuntu, Debian
Posts: 182

Rep: Reputation: 49
If you bought Acer Aspire one with linux pre-installed you must have the root password in the vendor documents.
Check the documents that came with your notebook.
 
Old 11-04-2009, 01:18 PM   #3
fakyhack
LQ Newbie
 
Registered: Feb 2009
Posts: 1

Rep: Reputation: 0
RE:

Quote:
Originally Posted by David Underhill View Post
I am a total newbie to linux. have an Acer Aspire one with Linpus Linux Lite. Have downloaded the flash plugin ver 10 rel i386.rpm but when I open it I get the message "You are attempting to run"system-installation packages" which requires administrative priveleges, but more information is needed in order to do so. Authenticating as "root" Then it asks for a password. I cannot get past this point. Any ideas?
try this dude !!!!

>cd /
>su
>passwd
{change it to a new password }
 
Old 11-04-2009, 01:27 PM   #4
scottro11
Member
 
Registered: Jun 2009
Location: NYC
Posts: 257

Rep: Reputation: 58
Unless Linpus has changed, I don't think it has a root password.
It has one user, named acer or something similar, that has unlimited privilege with sudo and no password necessary--that is, if you run sudo <command>, you don't have to type a password.

Try

sudo rpm -Uvh <package_name>.rpm

This should install it. The U means upgrade if an older version is already installed, v is verbose and h means print a hash as it's installing, the pretty little ####### thingies.
 
Old 11-05-2009, 06:08 AM   #5
David Underhill
LQ Newbie
 
Registered: Nov 2009
Posts: 2

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by scottro11 View Post
Unless Linpus has changed, I don't think it has a root password.
It has one user, named acer or something similar, that has unlimited privilege with sudo and no password necessary--that is, if you run sudo <command>, you don't have to type a password.

Try

sudo rpm -Uvh <package_name>.rpm

This should install it. The U means upgrade if an older version is already installed, v is verbose and h means print a hash as it's installing, the pretty little ####### thingies.
Thanks for the advice. I did a fresh install and now all is well apart from the keyboard is set to Us layout. The " and @ keys are crossed over. I have tried setting the input language to UK in the "Global Setup" but no change. Any ideas?
 
Old 11-05-2009, 06:36 AM   #6
scottro11
Member
 
Registered: Jun 2009
Location: NYC
Posts: 257

Rep: Reputation: 58
It's a command I always forget--I use a US keyboard and !#Crunchbang has a UK one--where do you guys have the pipe key?

setxkbmap gb

is what you want, I think.

Not sure how you'd make it global on Linpus though. Maybe put it in /etc/rc.local?

(That is, at the end of the file type

setxkbmap gb

If there is an rc.local, not even sure--I haven't played with Linpus in over a year.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
"su - root" giving incorrect password but normal root login works. ?? arashi256 Linux - Newbie 10 06-03-2010 04:13 AM
New system won't allow root after installation - using correct password and "root" kn2y Linux - Newbie 6 11-07-2008 08:52 PM
Standard commands give "-bash: open: command not found" even in "su -" and "su root" mibo12 Linux - General 4 11-11-2007 11:18 PM
Firefox (FC5) treats Flash as "unknown plugin" LloydM Linux - Newbie 3 08-06-2006 03:47 AM
I cannot use "java chat". Browser says plugin required "x-java-vm". jdruin Linux - Software 4 04-18-2004 06:44 PM


All times are GMT -5. The time now is 06:18 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration