LinuxQuestions.org
Go Job Hunting at the LQ Job Marketplace
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Laptop and Netbook
User Name
Password
Linux - Laptop and Netbook Having a problem installing or configuring Linux on your laptop? Need help running Linux on your netbook? This forum is for you. This forum is for any topics relating to Linux and either traditional laptops or netbooks (such as the Asus EEE PC, Everex CloudBook or MSI Wind).

Notices

Reply
 
Search this Thread
Old 12-02-2009, 03:41 PM   #1
Pakhomov
LQ Newbie
 
Registered: Jan 2007
Posts: 4

Rep: Reputation: 0
Touchpad and KDE


Hello, All!

I use Slackware64-13 on Asus A8Sr notebook. In this OS all input devices controled by HAL and I don't describe in xorg.conf in "ServerLayout" section:

Quote:
Section "ServerLayout"
Identifier "Simple Layout"
Screen 0 "aticonfig-Screen[0]-0" 0 0
# InputDevice "Mouse1" "CorePointer"
# InputDevice "Keyboard1" "CoreKeyboard"
# InputDevice "Synaptics Mouse" "AlwaysCore"
EndSection
In Window Maker or another window managers touchpad work prefectly.
Quote:
localhost:$ xinput list --short
"Virtual core pointer" id=0 [XPointer]
"Virtual core keyboard" id=1 [XKeyboard]
"Asus Laptop extra buttons" id=3 [XExtensionKeyboard]
"Macintosh mouse button emulation" id=4 [XExtensionPointer]
"SynPS/2 Synaptics TouchPad" id=5 [XExtensionPointer]
"AT Translated Set 2 keyboard" id=6 [XExtensionKeyboard]
"Video Bus" id=7 [XExtensionKeyboard]
And "synclient -m 100" command write out current parameters.

But in KDE not. "synclient -m 100" is quite. But "synclient -l" write out all current settings.

I think that KDE catch events from Synaptics touchpad because while KDE starting touchpad work. When KDE loaded, don't work.
This is in KDE only

Last edited by Pakhomov; 12-02-2009 at 03:44 PM.
 
Old 12-02-2009, 06:31 PM   #2
raju.mopidevi
Senior Member
 
Registered: Jan 2009
Location: vijayawada, India
Distribution: openSUSE 11.2, Ubuntu 9.0.4
Posts: 1,155
Blog Entries: 12

Rep: Reputation: 92
I am also using KDE. In early days after my installation Touchpad not worked properly.
After loading KDE, my touchpad behaved ubnormally. Only upper diagonal part worked as mouse. lower diagonal worked as scroll. Even tapping of touchpad is also not worked.

Then i had modified the file /etc/x11/xorg.conf file in "su" mode.
My present file has mouse setting as follows
Quote:
Section "InputDevice"
Driver "synaptics"
Identifier "Mouse[1]"
Option "AccelFactor" "0.01"
Option "BottomEdge" "650"
Option "CircScrollDelta" "0.1"
Option "CircScrollTrigger" "2"
Option "CircularScrolling" "1"
Option "Device" "/dev/input/mice"
Option "EdgeMotionMaxSpeed" "15"
Option "EdgeMotionMinSpeed" "15"
Option "Emulate3Buttons" "on"
Option "EmulateMidButtonTime" "75"
Option "FingerHigh" "15"
Option "FingerLow" "14"
Option "HorizScrollDelta" "20"
Option "LeftEdge" "120"
Option "MaxSpeed" "0.5"
Option "MaxTapMove" "110"
Option "MaxTapTime" "180"
Option "MinSpeed" "0.2"
Option "Name" "Touchpad"
Option "Protocol" "auto-dev"
Option "RightEdge" "830"
Option "SHMConfig" "on"
Option "TopEdge" "120"
Option "UpDownScrolling" "1"
Option "Vendor" "ALPS"
Option "VertScrollDelta" "20"
Option "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"
Driver "synaptics"
Identifier "Mouse[3]"
Option "AccelFactor" "0.01"
Option "BottomEdge" "650"
Option "CircScrollDelta" "0.1"
Option "CircScrollTrigger" "2"
Option "CircularScrolling" "1"
Option "Device" "/dev/input/mice"
Option "EdgeMotionMaxSpeed" "15"
Option "EdgeMotionMinSpeed" "15"
Option "Emulate3Buttons" "on"
Option "EmulateMidButtonTime" "75"
Option "FingerHigh" "15"
Option "FingerLow" "14"
Option "HorizScrollDelta" "20"
Option "LeftEdge" "120"
Option "MaxSpeed" "0.5"
Option "MaxTapMove" "110"
Option "MaxTapTime" "180"
Option "MinSpeed" "0.2"
Option "Name" "Touchpad"
Option "Protocol" "auto-dev"
Option "RightEdge" "830"
Option "SHMConfig" "on"
Option "TopEdge" "120"
Option "UpDownScrolling" "1"
Option "Vendor" "ALPS"
Option "VertScrollDelta" "20"
Option "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"
Driver "mouse"
Identifier "Mouse[5]"
Option "Buttons" "5"
Option "Device" "/dev/input/mice"
Option "Name" "ImPS/2 Generic Wheel Mouse"
Option "Protocol" "explorerps/2"
Option "Vendor" "Sysp"
Option "ZAxisMapping" "4 5"
EndSection
Now my KDE is enabled touchpad tapping, use of whole touchpad area.

It may be useful for you. Backup your xorg.conf file. Replace your touchpad settings with mine. Restart and check.

Last edited by raju.mopidevi; 12-02-2009 at 06:32 PM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Touchpad disable button permanently disables touchpad until reboot William (Dthdealer) Linux - Hardware 12 08-01-2009 11:51 PM
Need to kill touchpad click. (Synaptics Touchpad / FC4) sarysa Linux - Laptop and Netbook 4 02-19-2007 04:15 PM
Disable touchpad without KDE linuxhippy Slackware 8 10-13-2006 12:26 AM
disable touchpad in kde? kahn Linux - Hardware 1 05-29-2005 09:21 PM
Using Touchpad + USB WLAN means touchpad and keyboard stops responding randomly ultrabeam16 Linux - Laptop and Netbook 0 03-21-2004 03:19 PM


All times are GMT -5. The time now is 08:55 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration