LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Laptop and Netbook (http://www.linuxquestions.org/questions/linux-laptop-and-netbook-25/)
-   -   Touchpad and KDE (http://www.linuxquestions.org/questions/linux-laptop-and-netbook-25/touchpad-and-kde-773032/)

Pakhomov 12-02-2009 02:41 PM

Touchpad and KDE
 
Hello, All!

I use Slackware64-13 on Asus A8Sr notebook. In this OS all input devices controled by HAL and I don't describe in xorg.conf in "ServerLayout" section:

Quote:

Section "ServerLayout"
Identifier "Simple Layout"
Screen 0 "aticonfig-Screen[0]-0" 0 0
# InputDevice "Mouse1" "CorePointer"
# InputDevice "Keyboard1" "CoreKeyboard"
# InputDevice "Synaptics Mouse" "AlwaysCore"
EndSection
In Window Maker or another window managers touchpad work prefectly.
Quote:

localhost:$ xinput list --short
"Virtual core pointer" id=0 [XPointer]
"Virtual core keyboard" id=1 [XKeyboard]
"Asus Laptop extra buttons" id=3 [XExtensionKeyboard]
"Macintosh mouse button emulation" id=4 [XExtensionPointer]
"SynPS/2 Synaptics TouchPad" id=5 [XExtensionPointer]
"AT Translated Set 2 keyboard" id=6 [XExtensionKeyboard]
"Video Bus" id=7 [XExtensionKeyboard]
And "synclient -m 100" command write out current parameters.

But in KDE not. "synclient -m 100" is quite. But "synclient -l" write out all current settings.

I think that KDE catch events from Synaptics touchpad because while KDE starting touchpad work. When KDE loaded, don't work.
This is in KDE only

raju.mopidevi 12-02-2009 05:31 PM

I am also using KDE. In early days after my installation Touchpad not worked properly.
After loading KDE, my touchpad behaved ubnormally. Only upper diagonal part worked as mouse. lower diagonal worked as scroll. Even tapping of touchpad is also not worked.

Then i had modified the file /etc/x11/xorg.conf file in "su" mode.
My present file has mouse setting as follows
Quote:

Section "InputDevice"
Driver "synaptics"
Identifier "Mouse[1]"
Option "AccelFactor" "0.01"
Option "BottomEdge" "650"
Option "CircScrollDelta" "0.1"
Option "CircScrollTrigger" "2"
Option "CircularScrolling" "1"
Option "Device" "/dev/input/mice"
Option "EdgeMotionMaxSpeed" "15"
Option "EdgeMotionMinSpeed" "15"
Option "Emulate3Buttons" "on"
Option "EmulateMidButtonTime" "75"
Option "FingerHigh" "15"
Option "FingerLow" "14"
Option "HorizScrollDelta" "20"
Option "LeftEdge" "120"
Option "MaxSpeed" "0.5"
Option "MaxTapMove" "110"
Option "MaxTapTime" "180"
Option "MinSpeed" "0.2"
Option "Name" "Touchpad"
Option "Protocol" "auto-dev"
Option "RightEdge" "830"
Option "SHMConfig" "on"
Option "TopEdge" "120"
Option "UpDownScrolling" "1"
Option "Vendor" "ALPS"
Option "VertScrollDelta" "20"
Option "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"
Driver "synaptics"
Identifier "Mouse[3]"
Option "AccelFactor" "0.01"
Option "BottomEdge" "650"
Option "CircScrollDelta" "0.1"
Option "CircScrollTrigger" "2"
Option "CircularScrolling" "1"
Option "Device" "/dev/input/mice"
Option "EdgeMotionMaxSpeed" "15"
Option "EdgeMotionMinSpeed" "15"
Option "Emulate3Buttons" "on"
Option "EmulateMidButtonTime" "75"
Option "FingerHigh" "15"
Option "FingerLow" "14"
Option "HorizScrollDelta" "20"
Option "LeftEdge" "120"
Option "MaxSpeed" "0.5"
Option "MaxTapMove" "110"
Option "MaxTapTime" "180"
Option "MinSpeed" "0.2"
Option "Name" "Touchpad"
Option "Protocol" "auto-dev"
Option "RightEdge" "830"
Option "SHMConfig" "on"
Option "TopEdge" "120"
Option "UpDownScrolling" "1"
Option "Vendor" "ALPS"
Option "VertScrollDelta" "20"
Option "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"
Driver "mouse"
Identifier "Mouse[5]"
Option "Buttons" "5"
Option "Device" "/dev/input/mice"
Option "Name" "ImPS/2 Generic Wheel Mouse"
Option "Protocol" "explorerps/2"
Option "Vendor" "Sysp"
Option "ZAxisMapping" "4 5"
EndSection
Now my KDE is enabled touchpad tapping, use of whole touchpad area.

It may be useful for you. Backup your xorg.conf file. Replace your touchpad settings with mine. Restart and check.


All times are GMT -5. The time now is 04:37 PM.