LinuxQuestions.org
LinuxAnswers - the LQ Linux tutorial section.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Laptop and Netbook
User Name
Password
Linux - Laptop and Netbook Having a problem installing or configuring Linux on your laptop? Need help running Linux on your netbook? This forum is for you. This forum is for any topics relating to Linux and either traditional laptops or netbooks (such as the Asus EEE PC, Everex CloudBook or MSI Wind).

Notices

Reply
 
Search this Thread
Old 04-17-2005, 09:36 AM   #1
pingue999
LQ Newbie
 
Registered: Apr 2005
Distribution: debian-sarge
Posts: 8

Rep: Reputation: 0
touchpad acer travelmate 240


I have a acer travelmate 240 running on debian sarge and I want to disable the touchpad because I work with a USB mouse.
I tried several things and also I searched this forum but I couldn't disable it.
Can anyone of you help me because it is sometimes a bit irritating when you are typing and suddenly you type somewhere in the text where you don't want to type.
 
Old 04-21-2005, 09:53 AM   #2
Vookimedlo
Member
 
Registered: Jul 2004
Location: Czech Republic - Roudnice nad Labem
Distribution: Debian
Posts: 253

Rep: Reputation: 33
Many notebooks have this option in BIOS. Try look there.
 
Old 04-25-2005, 07:20 AM   #3
pingue999
LQ Newbie
 
Registered: Apr 2005
Distribution: debian-sarge
Posts: 8

Original Poster
Rep: Reputation: 0
It slipt my mind that it is often in the BIOS.

I have looked there but couldn't find an option to disable the touchpad.
 
Old 04-25-2005, 09:50 AM   #4
pokemaster
Member
 
Registered: Apr 2005
Location: Massachusetts, USA
Distribution: debian,ubuntu,slackware
Posts: 110

Rep: Reputation: 17
I've tried lots of distros (SuSE, Slack, Fedora, Mdk, etc...), but not Debian (Yet.). I understand it's a bit different, but I'm hoping this info will help (it works under Mdk 10.1, Slack 10, and SuSE 9.2)

This is one of many sites that hosts the synaptics touchpad driver: http://web.telia.com/~u89404340/touchpad/

Download, install (./configure, make, make install, etc). You'll then have to edit your xorg.conf file (usually /etc/X11/xorg.conf)
Find the entry for your touchpad, and set the driver value to "synaptics". Add a new option,

Option "SHMConfig" "on"

Then from the console, run

syndaemon -d

This will turn off your touchpad while you're typing, for 2 seconds after your last keystroke. You can change this interval (check the README / man files)

Hope that helps!
 
Old 05-08-2005, 01:59 PM   #5
pingue999
LQ Newbie
 
Registered: Apr 2005
Distribution: debian-sarge
Posts: 8

Original Poster
Rep: Reputation: 0
Sorry for my late replay.

It had not the effect that I expected but thanks anyway.
I'm realy thinking about switch to an other distro on my laptop, someone that runs lighter and uses less battery power.
so I'm not trying anymore to disable my touchpad on debian sarge.

regards pingue999
 
Old 12-21-2006, 03:54 PM   #6
WillemNL
LQ Newbie
 
Registered: Dec 2006
Posts: 1

Rep: Reputation: 0
Is fn + F7 not working to turn of your keyboard? YOu can always try Pardus Linux, if you want a comlete distro. Just turn of the driver otherwise
 
Old 04-15-2007, 12:13 PM   #7
prikulis
LQ Newbie
 
Registered: Apr 2007
Posts: 4

Rep: Reputation: 0
Maybe use both?

Quote:
Originally Posted by pingue999
I have a acer travelmate 240 running on debian sarge and I want to disable the touchpad because I work with a USB mouse.
On the same model and same OS i used ideas from:
http://www.faqs.org/docs/Linux-mini/...ond-Mouse.html

Now both the tocuhpad and the mouse work together.

My settings, i needed to have in /etc/X11/XF86Config-4:
.
.
.
Section "InputDevice"
Identifier "Configured Mouse"
Driver "mouse"
Option "CorePointer"
Option "Device" "/dev/input/mice"
Option "Protocol" "ImPS/2"
Option "Emulate3Buttons" "true"
Option "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"
Identifier "Tacpads"
Driver "mouse"
Option "AlwaysCore"
Option "Device" "/dev/psaux"
Option "Protocol" "PS/2"
Option "Emulate3Buttons" "true"
# Option "ZAxisMapping" "4 5"
EndSection


.
.
.


Section "ServerLayout"
.
.
.
InputDevice "Configured Mouse"
InputDevice "Tacpads" "AlwaysCore"
EndSection
.
.
.

Last edited by prikulis; 04-15-2007 at 12:20 PM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Synaptics Touchpad on Acer Travelmate 4400 crazylincoln Linux - Laptop and Netbook 1 05-28-2009 12:10 AM
Touchpad on Acer TravelMate 240 hand of fate Linux - Laptop and Netbook 1 04-13-2007 10:03 AM
Acer TravelMate 240 jjbuchan Linux - Laptop and Netbook 5 10-21-2006 04:50 AM
no touchpad/keyboard on acer travelmate 4402wlmi in debian-based distros n_ight_vision Linux - Laptop and Netbook 2 11-14-2005 12:21 AM
Scroll Button on Acer TravelMate 240 hand of fate Linux - Laptop and Netbook 1 07-21-2004 01:43 PM


All times are GMT -5. The time now is 04:04 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration