LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Laptop and Netbook
User Name
Password
Linux - Laptop and Netbook Having a problem installing or configuring Linux on your laptop? Need help running Linux on your netbook? This forum is for you. This forum is for any topics relating to Linux and either traditional laptops or netbooks (such as the Asus EEE PC, Everex CloudBook or MSI Wind).

Notices

Reply
 
Search this Thread
Old 08-07-2008, 09:24 PM   #1
skuzye
Member
 
Registered: Jul 2008
Location: São Paulo - Brazil
Distribution: Fedora 17
Posts: 97

Rep: Reputation: 15
Toshiba Phoenix Bios, Setting up wireless


First of all, hello...

I need some help with this issue I'm facing for about two weeks now when trying to set up this network card.

I made some progress but now I'm stuck again and completely lost this time.

I searched google and LQ.org and unfortunatelly I think my problem is not simply setting up the card.

I managed to set up the card and load modules but now I can't connect to my home wireless network and I'm not sure if the card is even activated (I cannot make the led become on by pushing wireless button on laptop).

Is there any way to determine whether or not the card is activated?

Note: although I've seen lots of people arguing about Phoenix bios and Toshiba laptobs, none of the threads I found said anything about wireless, they were talking about hotkeys in general(which some don't work, and that's true for me).

lspci:

Code:
08:0a.0 Ethernet controller: Atheros Communications, Inc. AR5005G 802.11abg NIC (rev 01)
madwifi: last version (0.9.4)

iwconfig:

Code:
ath0      Link encap:Ethernet  HWaddr 00:1A:2A:06:22:1C
          inet addr:192.168.1.9  Bcast:192.168.1.255  Mask:255.255.255.0
          inet6 addr: fe80::21a:2aff:fe06:221c/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:0 (0.0 b)  TX bytes:0 (0.0 b)
and added default gateway to route...


Any help is apreciated

Skuzye

Last edited by skuzye; 08-07-2008 at 09:27 PM. Reason: spell error
 
Old 08-08-2008, 12:55 PM   #2
rob.rice
Member
 
Registered: Apr 2004
Distribution: slack what ever
Posts: 792

Rep: Reputation: 114Reputation: 114
I'm on a toshiba satellite A205-S5000 right now
to get the wifi working I installed madwifi-hal-0.10.5.6-r3835-20080801.tar.gz
you may have the same athorse adepter I have the current release didn't
have the right module for my athorse adepter this is a snap shot release
this is all I know to tell you hope it helps
 
Old 08-10-2008, 07:51 PM   #3
skuzye
Member
 
Registered: Jul 2008
Location: São Paulo - Brazil
Distribution: Fedora 17
Posts: 97

Original Poster
Rep: Reputation: 15
my main problem, and the one I'd like very much to solve is to know whether or not the adapter is working, I mean, getting energy... I don't know if it is being or not supported by my acpi modules...

No acpi module with wifi, wireless or anything like this is loaded and even present to be loaded. So, I'm not really sure if it has anything to do with acpi...

Skuzye
 
Old 08-11-2008, 10:44 AM   #4
rob.rice
Member
 
Registered: Apr 2004
Distribution: slack what ever
Posts: 792

Rep: Reputation: 114Reputation: 114
I get the same out put from mine when I turn the wifi antenna switch off before I boot .
without the IP and gateway addresses
Or madwifi hasn't turned it on so it could still be a problem with madwifi
Did you check the tickets at madwifi's web page .
where did it get the IP address from you should be using dhcp to get the IP address unless your
using it to replace an ethernet cable
 
Old 08-28-2008, 07:40 AM   #5
skuzye
Member
 
Registered: Jul 2008
Location: São Paulo - Brazil
Distribution: Fedora 17
Posts: 97

Original Poster
Rep: Reputation: 15
After almost a month of research I suspect my dsdt is buggy. I'll make some test when I get some spare time and post results.

Note: dsdt is part of ACPI and it's shipped with BIOS. For a possibly solution, recompiling dsdt and hacking the kernel to read it locally instead of getting if from BIOS.

Skuzye
 
Old 09-01-2008, 12:14 PM   #6
rob.rice
Member
 
Registered: Apr 2004
Distribution: slack what ever
Posts: 792

Rep: Reputation: 114Reputation: 114
Quote:
Originally Posted by skuzye View Post
After almost a month of research I suspect my dsdt is buggy. I'll make some test when I get some spare time and post results.

Note: dsdt is part of ACPI and it's shipped with BIOS. For a possibly solution, recompiling dsdt and hacking the kernel to read it locally instead of getting if from BIOS.

Skuzye

Code:
08:0a.0 Ethernet controller: Atheros Communications, Inc. AR5005G 802.11abg NIC (rev 01)
this is wrong the card is not set up right
it should be
Code:
05:00.0 Ethernet controller: Atheros Communications Inc. AR242x 802.11abg Wireless PCI Express Adapter (rev 01)
you need to install the latest release of madwifi or the bug fix I told you about we both have the exact same wireless card BUT mine works WHY I can tack advice and fallow it
I have my doubts about you being able to do the same

where did the IP address come from ?
the default for a wireless router is to use dhcp to give you an IP address

The whole problem could be that you need to use dhcp to get your IP address

what distro are you using ?
so we can tell you how to set up the wireless adepter to use dhcp

to top it all off ALL wifi hot spots use dhcp to give out IP addresses

Last edited by rob.rice; 09-01-2008 at 04:21 PM.
 
Old 09-03-2008, 06:50 AM   #7
skuzye
Member
 
Registered: Jul 2008
Location: São Paulo - Brazil
Distribution: Fedora 17
Posts: 97

Original Poster
Rep: Reputation: 15
I don't know exactly how to setup dhcp for wireless.. for wired it's explained in SlackBook.. by the way, I' using slack 12.1. I was using at that time 12.0 and then I reinstalled it but didn't try working on this issue yet. Before dive in acpi problem i'm gonna try to install the trunk version and see what happens... then set wireless do dhcp...

When you turn on your laptop and then boot linux, does your wireless led light up? how about when you try to use your wireless, does it light up? because mine lights up when I power on the laptop and then light off... never light up again... even pressing Wireless on/off button at laptop, It doesn't even generate any kernel messages..

Thankss a lot

Skuzye
 
Old 09-03-2008, 11:05 AM   #8
rob.rice
Member
 
Registered: Apr 2004
Distribution: slack what ever
Posts: 792

Rep: Reputation: 114Reputation: 114
Quote:
Originally Posted by skuzye View Post
I don't know exactly how to setup dhcp for wireless.. for wired it's explained in SlackBook.. by the way, I' using slack 12.1. I was using at that time 12.0 and then I reinstalled it but didn't try working on this issue yet. Before dive in acpi problem i'm gonna try to install the trunk version and see what happens... then set wireless do dhcp...

When you turn on your laptop and then boot linux, does your wireless led light up? how about when you try to use your wireless, does it light up? because mine lights up when I power on the laptop and then light off... never light up again... even pressing Wireless on/off button at laptop, It doesn't even generate any kernel messages..

Thankss a lot

Skuzye
leave the button turned on
my light comes on at power up and stays on
first off you need to install madwifi and the HAL bug fix I told you about
there is a new version of madwifi out it may have the bug fix main lined in to it

this is how it looks in my /etc/rc.d/rc.inet1.conf file
Code:
## Example config information for wlan0.  Uncomment the lines you need and fill
## in your data.  (You may not need all of these for your wireless network)
IFNAME[4]="ath0"
#IPADDR[4]=""
#NETMASK[4]=""
USE_DHCP[4]="yes"
#DHCP_HOSTNAME[4]="icculus-wireless"
#DHCP_KEEPRESOLV[4]="yes"
#DHCP_KEEPNTP[4]="yes"
#DHCP_KEEPGW[4]="yes"
#DHCP_IPADDR[4]=""
#WLAN_ESSID[4]=DARKSTAR
#WLAN_MODE[4]=Managed
WLAN_RATE[4]="54M auto"
WLAN_CHANNEL[4]="auto"
#WLAN_KEY[4]="D5A31F54ACF0487C2D0B1C10D2"
#WLAN_IWPRIV[4]="set AuthMode=WPAPSK | set EncrypType=TKIP | set WPAPSK=96389dc66eaf7e6efd5b5523ae43c7925ff4df2f8b7099495192d44a774fda16"
#WLAN_WPA[4]="wpa_supplicant"
#WLAN_WPADRIVER[4]="wext"
#WLAN_WPAWAIT[4]=30
as you can see it's just about the exact same as as setting dhcp a wired connection
there are only 2 more settings than an ethernet adepter
WLAN_RATE[4]="54M auto"
WLAN_CHANNEL[4]="auto"
that you need to set

so here is what you need to do
1)install madwifi from source
1b)install the HAL bug fix
(1&1b could be done with the newest release of madwifi)
2)edit your /etc/rc.d/rc.inet1.conf
for more advice goto the slackware sub forum here and look for
"wifi where do I go from here" thread
what I have given you so far will get it working with out encryption
I can get away with out it because of my odd location
I do not advise you to do the same
 
Old 09-03-2008, 11:08 AM   #9
rob.rice
Member
 
Registered: Apr 2004
Distribution: slack what ever
Posts: 792

Rep: Reputation: 114Reputation: 114
Quote:
Originally Posted by skuzye View Post
I don't know exactly how to setup dhcp for wireless.. for wired it's explained in SlackBook.. by the way, I' using slack 12.1. I was using at that time 12.0 and then I reinstalled it but didn't try working on this issue yet. Before dive in acpi problem i'm gonna try to install the trunk version and see what happens... then set wireless do dhcp...

When you turn on your laptop and then boot linux, does your wireless led light up? how about when you try to use your wireless, does it light up? because mine lights up when I power on the laptop and then light off... never light up again... even pressing Wireless on/off button at laptop, It doesn't even generate any kernel messages..

Thankss a lot

Skuzye
leave the button turned on
my light comes on at power up and stays on
first off you need to install madwifi and the HAL bug fix I told you about
there is a new version of madwifi out it may have the bug fix main lined in to it

this is how it looks in my /etc/rc.d/rc.inet1.conf file
Code:
## Example config information for wlan0.  Uncomment the lines you need and fill
## in your data.  (You may not need all of these for your wireless network)
IFNAME[4]="ath0"
#IPADDR[4]=""
#NETMASK[4]=""
USE_DHCP[4]="yes"
#DHCP_HOSTNAME[4]="icculus-wireless"
#DHCP_KEEPRESOLV[4]="yes"
#DHCP_KEEPNTP[4]="yes"
#DHCP_KEEPGW[4]="yes"
#DHCP_IPADDR[4]=""
#WLAN_ESSID[4]=DARKSTAR
#WLAN_MODE[4]=Managed
WLAN_RATE[4]="54M auto"
WLAN_CHANNEL[4]="auto"
#WLAN_KEY[4]="D5A31F54ACF0487C2D0B1C10D2"
#WLAN_IWPRIV[4]="set AuthMode=WPAPSK | set EncrypType=TKIP | set WPAPSK=96389dc66eaf7e6efd5b5523ae43c7925ff4df2f8b7099495192d44a774fda16"
#WLAN_WPA[4]="wpa_supplicant"
#WLAN_WPADRIVER[4]="wext"
#WLAN_WPAWAIT[4]=30
as you can see it's just about the exact same as as setting dhcp a wired connection
there are only 2 more settings than an ethernet adepter
WLAN_RATE[4]="54M auto"
WLAN_CHANNEL[4]="auto"
that you need to set

so here is what you need to do
1)install madwifi from source
1b)install the HAL bug fix
(1&1b could be done with the newest release of madwifi)
2)edit your /etc/rc.d/rc.inet1.conf
for more advice goto the slackware sub forum here and look for
"wifi where do I go from here" thread
what I have given you so far will get it working with out encryption
I can get away with out it because of my odd location
I do not advise you to do the same
 
Old 09-03-2008, 11:24 AM   #10
rob.rice
Member
 
Registered: Apr 2004
Distribution: slack what ever
Posts: 792

Rep: Reputation: 114Reputation: 114
Quote:
Originally Posted by skuzye View Post
I don't know exactly how to setup dhcp for wireless.. for wired it's explained in SlackBook.. by the way, I' using slack 12.1. I was using at that time 12.0 and then I reinstalled it but didn't try working on this issue yet. Before dive in acpi problem i'm gonna try to install the trunk version and see what happens... then set wireless do dhcp...

When you turn on your laptop and then boot linux, does your wireless led light up? how about when you try to use your wireless, does it light up? because mine lights up when I power on the laptop and then light off... never light up again... even pressing Wireless on/off button at laptop, It doesn't even generate any kernel messages..

Thankss a lot

Skuzye
leave the button turned on
my light comes on at power up and stays on
first off you need to install madwifi and the HAL bug fix I told you about
there is a new version of madwifi out it may have the bug fix main lined in to it

this is how it looks in my /etc/rc.d/rc.inet1.conf file
Code:
## Example config information for wlan0.  Uncomment the lines you need and fill
## in your data.  (You may not need all of these for your wireless network)
IFNAME[4]="ath0"
#IPADDR[4]=""
#NETMASK[4]=""
USE_DHCP[4]="yes"
#DHCP_HOSTNAME[4]="icculus-wireless"
#DHCP_KEEPRESOLV[4]="yes"
#DHCP_KEEPNTP[4]="yes"
#DHCP_KEEPGW[4]="yes"
#DHCP_IPADDR[4]=""
#WLAN_ESSID[4]=DARKSTAR
#WLAN_MODE[4]=Managed
WLAN_RATE[4]="54M auto"
WLAN_CHANNEL[4]="auto"
#WLAN_KEY[4]="D5A31F54ACF0487C2D0B1C10D2"
#WLAN_IWPRIV[4]="set AuthMode=WPAPSK | set EncrypType=TKIP | set WPAPSK=96389dc66eaf7e6efd5b5523ae43c7925ff4df2f8b7099495192d44a774fda16"
#WLAN_WPA[4]="wpa_supplicant"
#WLAN_WPADRIVER[4]="wext"
#WLAN_WPAWAIT[4]=30
as you can see it's just about the exact same as as setting dhcp a wired connection
there are only 2 more settings than an ethernet adepter
WLAN_RATE[4]="54M auto"
WLAN_CHANNEL[4]="auto"
that you need to set

so here is what you need to do
1)install madwifi from source
1b)install the HAL bug fix
(1&1b could be done with the newest release of madwifi)
2)edit your /etc/rc.d/rc.inet1.conf
for more advice goto the slackware sub forum here and look for
"wifi where do I go from here" thread
what I have given you so far will get it working with out encryption
(as long as the wireless router is setup to work with out encryption )
I can get away with out encryption because of my odd location
I do not advise you to do the same
(I have not setup encryption so I'm not going to try to tell you how to setup encryption )

Last edited by rob.rice; 09-03-2008 at 11:31 AM.
 
Old 09-03-2008, 11:53 AM   #11
rob.rice
Member
 
Registered: Apr 2004
Distribution: slack what ever
Posts: 792

Rep: Reputation: 114Reputation: 114
here is the thread to look at for more and better (than I can give)advice
http://www.linuxquestions.org/questi...light=rob.rice
 
Old 10-20-2008, 08:36 AM   #12
skuzye
Member
 
Registered: Jul 2008
Location: São Paulo - Brazil
Distribution: Fedora 17
Posts: 97

Original Poster
Rep: Reputation: 15
ok, after a loonggg time... I found out that the problem is NOT the acpi...

The wireless card is controlled by software to be turned on/off and omnidriver could be a possible solution... Although... my notebook model is not officially suported and the only way to get it working would be testing it with the experimental options...

Cya, thanks everybody

Skuzye
 
Old 01-21-2009, 06:28 AM   #13
skuzye
Member
 
Registered: Jul 2008
Location: São Paulo - Brazil
Distribution: Fedora 17
Posts: 97

Original Poster
Rep: Reputation: 15
Well, I'm not really sure whether I should revive this or start a new one but since it's the same subject and this one has no solution yet, I'm reviving this.

I updated my slackware to current and updated the kernel with the stock 2.6.27.7-smp kernel. I was messing up and pressed the wireless button (I don't know why) and with dmesg it generated kernel messages!

This is awesome, maybe if I could link this keys with some function to power on wireless network.

I also noted that modules for my current wireless card are now loading automatically (no need to download madwifi).

Here are some quotes:

lsmod | grep ath5k
Quote:
ath5k 101248 0
mac80211 158108 1 ath5k
led_class 7684 1 ath5k
cfg80211 27144 2 ath5k,mac80211
dmesg extract
Quote:
atkbd.c: Unknown key pressed (translated set 2, code 0x6d on isa0060/serio0).
atkbd.c: Use 'setkeycodes 6d <keycode>' to make it known.
atkbd.c: Unknown key released (translated set 2, code 0x6d on isa0060/serio0).
atkbd.c: Use 'setkeycodes 6d <keycode>' to make it known.
and lspci -v extract
Quote:
08:0a.0 Ethernet controller: Atheros Communications Inc. AR2413 802.11bg NIC (rev 01)
Subsystem: Accton Technology Corporation Unknown device 4413
Flags: bus master, medium devsel, latency 168, IRQ 19
Memory at d0200000 (32-bit, non-prefetchable) [size=64K]
Capabilities: [44] Power Management version 2
Kernel driver in use: ath5k_pci
Kernel modules: ath5k
Any pointer would be very very appreciated.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Booting from cd in Phoenix bios linmix Linux - Hardware 8 11-16-2011 05:12 AM
Toshiba laptop with Phoenix BIOS : Battery Life Appalling hell_rider Linux - Laptop and Netbook 2 04-09-2008 01:22 PM
IRDA, FIR Mode on Toshiba (No Bios setting) Laptop The_Outlander Linux - Hardware 0 11-07-2006 04:49 PM
Can't disable PNP with Phoenix BIOS mixedmemes Linux - Networking 2 08-26-2004 06:52 PM
Windows/Phoenix Bios integration scott_R General 7 10-07-2003 10:37 PM


All times are GMT -5. The time now is 01:07 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration