LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Laptop and Netbook (http://www.linuxquestions.org/questions/linux-laptop-and-netbook-25/)
-   -   Toshiba laptop in dual boot restarts after shutting down Xubuntu (http://www.linuxquestions.org/questions/linux-laptop-and-netbook-25/toshiba-laptop-in-dual-boot-restarts-after-shutting-down-xubuntu-4175431165/)

Yann 10-08-2012 12:25 PM

Toshiba laptop in dual boot restarts after shutting down Xubuntu
 
Hello,
I bought me a Toshiba Satellite C870-15J with Windows 7 installed.
Made a dual boot with Xubuntu 12.04.
When I shut down Xubuntu, the system seems to turn itself completely off, but after some seconds I hear a click, and the system reboots itself.
The same when I shut down via the terminal with "sudo shutdown -h now".
In the power manager I changed the value for the onn-off button to shut off, but still the same problem.
I also entered the bios and made sure every Wake-on-LAN-like-function is disabled.
When I use the "Windows-side" and shut off, it stays off, which is why I think it can't be a hardware problem.
Can anybody help me? It is a new laptop and it's rather annoying it won't work as it should...
Thanks,
Yann

mdlinuxwolf 10-09-2012 07:36 AM

Cli
 
Quote:

Originally Posted by Yann (Post 4800459)
Hello,
I bought me a Toshiba Satellite C870-15J with Windows 7 installed.
Made a dual boot with Xubuntu 12.04.
When I shut down Xubuntu, the system seems to turn itself completely off, but after some seconds I hear a click, and the system reboots itself.
The same when I shut down via the terminal with "sudo shutdown -h now".
In the power manager I changed the value for the onn-off button to shut off, but still the same problem.
I also entered the bios and made sure every Wake-on-LAN-like-function is disabled.
When I use the "Windows-side" and shut off, it stays off, which is why I think it can't be a hardware problem.
Can anybody help me? It is a new laptop and it's rather annoying it won't work as it should...
Thanks,
Yann


Try using the halt command instead of shutdown. You might have to be root to use it. If it works, change its permissions so all users are allowed to use halt. The usage is:

halt now

JaseP 10-09-2012 08:21 AM

Toshiba laptops (some of them, at least) also have a BIOS function to turn on when the laptop lid is lifted. You might be experiencing this behavior, or have a defective laptop lid switch in the machine (sticky?!).

Try changing this behavior in the BIOS, and see if it helps...

mdlinuxwolf 10-09-2012 09:56 AM

Restart
 
Did he try to say that it would always restart or just when the laptop is open? Usually, you tell the O/S to shutdown and close the top when you're done using it.

Yann 10-09-2012 10:59 AM

Thanks for the advice, but still the same problem.
When I use "halt now", the system doesn't really shut down bur freezes on the xubuntu screen; I then have to shut down completely using the on-off button.
In the BIOS I disabled the power-on-lifted-lid-function, but still the same problem.
For the moment, the only solution is waiting till the system has turned off and reboots again, and then hitting the on-off button to turn it off for good.
But I don't think this is regular behaviour, so if someone knows the solution, I would be very grateful...

JaseP 10-09-2012 03:23 PM

If shutdown does not occur properly with sudo shutdown -h now,... and there's nothing wrong with the settings in the BIOS,... there's possibly something wring with the run states.

Use the following;
sudo teleinit 0

And report what happens.

For reference here are the Debian/Ubuntu default run states;

0 System Halt
1 Single user
2 Full multi-user mode (Default)
3-5 Same as 2
6 System Reboot

So it's possible that something (or someone) altered the init states confusing runlevel 0 with runlevel 6...

Yann 10-09-2012 04:15 PM

The answer my terminal gives is:
sudo: teleinit: command not found
So what now?

JaseP 10-09-2012 05:20 PM

Try;

sudo init 0

The old calls are supposed to be supported...

By the way, do it from a real terminal, not just a window, for now,... [Alt]+[Ctrl]+[F1], for example.

mdlinuxwolf 10-09-2012 10:21 PM

That's weird. Still, use halt. This will keep it from rebooting, which means you'll just have to hit the power switch.

If the telenit 0 command works, put it into a text file. Name the file something like Scram or go-away (not halt or shutdown)

Using dolphin as root, save this to /bin. Make it executable. Grant permissions to everyone and put it into the everyone (or all users) group. Do this by right clicking it and choosing properties & permissions.

After this, go to your desktop and make a new icon with the path to the binary you just created. Repeat this for all your user accounts and root if you log in graphically as root once in a while. (Usually, not a good idea unless your modifying your computer or operating system.)

Yann 10-10-2012 09:55 AM

I used "sudo init 0" from a "real" terminal: the system shuts down... and restarts after some seconds...
By the way, I just discovered that the laptop doesn't restart when on accu, so the problem exists only when powered by cable.
Hence the solution can be to "pull out the plug" before shutting down, but I still don't think this is normal behaviour...

JaseP 10-10-2012 11:11 AM

It's not software then,... Something in the BIOS,... or faulty ACPI... There's no software that can turn a machine back on if it's truly off,... sleeping, yes, but not truly off...

Look for a setting for something like booting after power loss,... and change it to the "stay off" setting...

mdlinuxwolf 10-10-2012 01:06 PM

Then just do that
 
Quote:

Originally Posted by Yann (Post 4802226)
I used "sudo init 0" from a "real" terminal: the system shuts down... and restarts after some seconds...
By the way, I just discovered that the laptop doesn't restart when on accu, so the problem exists only when powered by cable.
Hence the solution can be to "pull out the plug" before shutting down, but I still don't think this is normal behaviour...

Well, make an icon with that script & unplug the laptop. It's a long shot, but you can also see if there is a newer bios and reflash it. Of course, the laptop should definately be plugged in for that!!

The best thing to do is accept the quirk and unplug it. After its totally off, you can probably plug it in again.

Yann 10-10-2012 03:09 PM

Found no setting for booting after power loss, all the possible reboot-seetings are already disabled.
Reflashing the bios is a new concept for me, so before I dare considering it I will first look around a bit to learn how to do it. Meanwhile, I think I shall follow Mdlinuxwolf's advice and accept the laptop with it's quirks.
Thank you both for your time & advice!
Yann

mdlinuxwolf 10-10-2012 04:56 PM

Usually you go to the manufacturer's website, download the bios, put it on a USB or a CD.

After that, boot off of the USB or CD and follow the directions.

If you dual boot with M$, there might even be a helpful wizard. There is always some risk reflashing bios. Don't interrupt it once it starts to reflash.

For my laptop, I usually suspend to RAM anyway.

In the days of yore, you would boot off of a floppy with the newer bios.

JaseP 10-11-2012 12:19 PM

Quote:

Originally Posted by Yann (Post 4802455)
Found no setting for booting after power loss, all the possible reboot-seetings are already disabled.
Reflashing the bios is a new concept for me, so before I dare considering it I will first look around a bit to learn how to do it. Meanwhile, I think I shall follow Mdlinuxwolf's advice and accept the laptop with it's quirks.
Thank you both for your time & advice!
Yann

Look in the "Advanced Chipset Features" section of the BIOS. Many times quirky things are hidden there. If not,... the "Power Management" section sometimes has some nested menus...


All times are GMT -5. The time now is 11:23 PM.