Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back > Forums > Linux Forums > Linux - Laptop and Netbook
User Name
Linux - Laptop and Netbook Having a problem installing or configuring Linux on your laptop? Need help running Linux on your netbook? This forum is for you. This forum is for any topics relating to Linux and either traditional laptops or netbooks (such as the Asus EEE PC, Everex CloudBook or MSI Wind).


  Search this Thread
Old 07-22-2010, 01:12 PM   #1
Senior Member
Registered: Mar 2002
Location: Los Angeles, CA
Distribution: Debian, Ubuntu
Posts: 1,334

Rep: Reputation: 51
Tilde / back-tick key not giving me a tilde or back-tic. Ubuntu 10.04 on Macbook Pro

I'm guessing this is a simple one, but I can't seem to find how to get my backtick/tilde key doing what it's supposed to. Currently, I get these chars with that key:

My keyboard is set to US Macintosh. This is a Macbook Pro 5,1. I'm running Ubuntu 10.04.

Old 07-22-2010, 08:11 PM   #2
LQ Guru
Registered: Oct 2003
Posts: 5,066

Rep: Reputation: Disabled

consider these links pls

I don't use Ubuntu but

get you to kb layout hopefully....change USA (Macintosh)" to "USA
Old 08-19-2015, 03:09 PM   #3
LQ Newbie
Registered: Aug 2015
Posts: 1

Rep: Reputation: Disabled
I had the same issue. When I set my keyboard to US however, it changed from to < ! (instead of ` ~ as is displayed on the key).

To correct the issue, I set my keyboard to English (UK, Macintosh).
Old 09-01-2015, 10:14 PM   #4
LQ Newbie
Registered: Sep 2015
Distribution: Debian
Posts: 1

Rep: Reputation: Disabled
Hi Brian,

sudo nano /etc/rc.local
Add this line:
echo 0 > /sys/module/hid_apple/parameters/iso_layout
Source: askubuntu (dot) com (slash) questions (slash) 530325 (slash) tilde-key-on-mac-air-with-ubuntu

Hope this helps!


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] Using tilde and spaces youarefunny Linux - General 5 05-27-2010 11:38 AM
Tilde? What's the key combination to get it ? DOTT.EVARISTI Linux - Software 8 07-06-2007 07:07 AM
Lost my tilde key ( ~ ) nakko Debian 5 09-12-2006 10:27 AM
tilde in X nva Linux - General 2 06-30-2003 12:12 PM
Filenames with tilde rovoreed Programming 2 08-08-2001 05:53 PM

All times are GMT -5. The time now is 11:07 AM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration