LinuxQuestions.org
LinuxAnswers - the LQ Linux tutorial section.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Laptop and Netbook
User Name
Password
Linux - Laptop and Netbook Having a problem installing or configuring Linux on your laptop? Need help running Linux on your netbook? This forum is for you. This forum is for any topics relating to Linux and either traditional laptops or netbooks (such as the Asus EEE PC, Everex CloudBook or MSI Wind).

Notices



Reply
 
Search this Thread
Old 03-07-2010, 11:11 AM   #1
vsaggu
LQ Newbie
 
Registered: Feb 2010
Posts: 8

Rep: Reputation: 0
techno tech usb ethernet lan not working


I have a installed Centos 5.4 with yum update done on my packard bell laptop. Bought a new USB ethernet (techno tech) for eth1. but failed to connect. I have tried alot searching on the net but did not found any solution. Please any 1 out there from Linux world help me out. You help will be really appreciated.
 
Old 03-25-2010, 06:16 PM   #2
michaelk
Moderator
 
Registered: Aug 2002
Posts: 12,172

Rep: Reputation: 784Reputation: 784Reputation: 784Reputation: 784Reputation: 784Reputation: 784Reputation: 784
Knowing the chipset and device ID might provide some clues. Post the output of the lsusb command.
 
Old 03-26-2010, 10:56 AM   #3
vsaggu
LQ Newbie
 
Registered: Feb 2010
Posts: 8

Original Poster
Rep: Reputation: 0
I have connected my USB ethernet and ran the command lsusb i get this..

Code:
[root@localhost ~]# lsusb
Bus 001 Device 001: ID 0000:0000  
Bus 001 Device 002: ID 148f:2573 Ralink Technology, Corp. RT2501USB Wireless Adapter
Bus 002 Device 001: ID 0000:0000  
[root@localhost ~]#
Is there anything else i need to do ?

When i insert the USB ethernet in USB port and connect a LAN wire from switch to it. There i get a red light on the USB ethernet.

Is there no auto plug and detect utility ?


Running ifconfig show the below....

Code:
[root@dhcppc1 ~]# ifconfig
eth0      Link encap:Ethernet  HWaddr 00:40:D0:98:CB:AB  
          inet addr:192.168.1.3  Bcast:192.168.1.255  Mask:255.255.255.0
          inet6 addr: fe80::240:d0ff:fe98:cbab/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:2561 errors:0 dropped:0 overruns:0 frame:0
          TX packets:2257 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:2083384 (1.9 MiB)  TX bytes:398097 (388.7 KiB)
          Interrupt:217 Base address:0x4000 

lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:1456 errors:0 dropped:0 overruns:0 frame:0
          TX packets:1456 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:2336404 (2.2 MiB)  TX bytes:2336404 (2.2 MiB)

Last edited by vsaggu; 03-27-2010 at 05:57 AM.
 
Old 03-27-2010, 02:00 AM   #4
abid ch
LQ Newbie
 
Registered: Mar 2010
Posts: 2

Rep: Reputation: 0
when you uselinux there no need to install drivers to support linux automatially catch drivers..you can use
ifconfig... then you 'ld check your status id.
you should check your eth0 setting & change this for active state
best regards
abid ch
 
Old 03-27-2010, 05:54 AM   #5
vsaggu
LQ Newbie
 
Registered: Feb 2010
Posts: 8

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by abid ch View Post
when you uselinux there no need to install drivers to support linux automatially catch drivers..you can use
ifconfig... then you 'ld check your status id.
you should check your eth0 setting & change this for active state
best regards
abid ch
My eth0 is the default lan on laptop which is working fine. but how to add the USB ethernet as eth1 ?
 
Old 03-27-2010, 05:55 AM   #6
vsaggu
LQ Newbie
 
Registered: Feb 2010
Posts: 8

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by abid ch View Post
when you uselinux there no need to install drivers to support linux automatially catch drivers..you can use
ifconfig... then you 'ld check your status id.
you should check your eth0 setting & change this for active state
best regards
abid ch

My eth0 is the default lan on laptop which is working fine. but how to add the USB ethernet as eth1 ?
 
Old 03-27-2010, 09:51 AM   #7
michaelk
Moderator
 
Registered: Aug 2002
Posts: 12,172

Rep: Reputation: 784Reputation: 784Reputation: 784Reputation: 784Reputation: 784Reputation: 784Reputation: 784
Here is some specific for CentOS.
http://wiki.centos.org/HowTos/Laptops/Wireless
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Ethernet LAN, Sound and Wireless LAN not working dongarry Linux - Newbie 1 11-03-2009 04:31 PM
Setup USB Ethernet/LAN External Adaptor jowens Linux - Hardware 6 01-06-2009 02:47 AM
New Audio Linux User Seeks Geeky Tech Head For Long Nights of SEXY Techno Babble dahouse LinuxQuestions.org Member Intro 2 04-08-2007 02:19 PM
Gigabit LAN ethernet adapter not working ParticleHunter Linux From Scratch 1 07-31-2005 11:29 AM
Is a usb (1.1) port lan faster than 10/100 ethernet card? Bensoft Kill MS Linux - Hardware 2 09-20-2003 11:22 PM


All times are GMT -5. The time now is 06:00 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration