LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Laptop and Netbook
User Name
Password
Linux - Laptop and Netbook Having a problem installing or configuring Linux on your laptop? Need help running Linux on your netbook? This forum is for you. This forum is for any topics relating to Linux and either traditional laptops or netbooks (such as the Asus EEE PC, Everex CloudBook or MSI Wind).

Notices

Reply
 
Search this Thread
Old 09-03-2004, 03:04 PM   #1
peevee
LQ Newbie
 
Registered: Sep 2003
Location: india
Distribution: redhat
Posts: 18

Rep: Reputation: 0
Tap not working in touchpad in fedora core 2


I am using fedora core 2 on my compaq pessario 2514 laptop.
In it , the tap is not recognized as click in the synaptic touchpad.
i found a link for drivers to make tap as click, but those drivers dont work for kernel 2.6
so anyone can suggest me a solution for it?
 
Old 09-03-2004, 03:19 PM   #2
Vookimedlo
Member
 
Registered: Jul 2004
Location: Czech Republic - Roudnice nad Labem
Distribution: Debian
Posts: 253

Rep: Reputation: 33
I'm just using this one: http://w1.894.telia.com/~u89404340/touchpad/
and everything is OK
 
Old 09-04-2004, 11:53 AM   #3
peevee
LQ Newbie
 
Registered: Sep 2003
Location: india
Distribution: redhat
Posts: 18

Original Poster
Rep: Reputation: 0
i tried that one,
it says that we need to modify the drivers for kernel 2.6
but i could understand where and how to modify that.
can any one tell me
 
Old 09-06-2004, 04:02 AM   #4
Vookimedlo
Member
 
Registered: Jul 2004
Location: Czech Republic - Roudnice nad Labem
Distribution: Debian
Posts: 253

Rep: Reputation: 33
So, you're using Fedora 2. You haven't to patch or recompile your kernel if you have one from the fedora team.
Just do as root: modprobe evdev, and than simply install Synaptics TouchPad driver. Change your /etc/X11/Xorg.conf to values you want. Then restart your X Server and enjoy your touchpad.

Don't forget to place your modprobe evdev command into /etc/rc.d/rc.local file.

PS: if your touch-pad has middle button, you need kernel at least 2.6.6 for proper work.
 
Old 09-30-2004, 07:28 AM   #5
lucaing80
LQ Newbie
 
Registered: Sep 2004
Posts: 1

Rep: Reputation: 0
Problems with Fedora Core 2

I'm quite a Linux newbie.
I've tried what you suggested, but there's no "evdev" module in my distribution (Fedora Core 2 upgraded with Kernel 2.6.7.1 provided as RPM by RedHat/Fedora).
It seems to be precompiled within the kernel, but the driver still doesn't work. X gives an error message regarding missing external symbols when loading synaptics.o.
Thanks a lot.

Luca
 
Old 09-30-2004, 11:17 AM   #6
halo14
Senior Member
 
Registered: Apr 2004
Location: Surprise, AZ
Distribution: Debian | CentOS | Arch
Posts: 1,103

Rep: Reputation: 45
kernel 2.6 sucks with the touchpad drivers... I have gone back to 2.4 and it works fine.. I suggest you do the same.. It's not worth the hassle... I haven't noticed much differences between the two kernels other than my touchpad doesn't work properly! lol..
 
Old 10-01-2004, 02:06 PM   #7
JaseP
Senior Member
 
Registered: Jun 2002
Location: Eastern PA, USA
Distribution: K/Ubuntu 10.04/12.04, Scientific Linux 6.3, Android-x86, Maemo
Posts: 1,658

Rep: Reputation: 138Reputation: 138
You need to change your "mouse" setting in Fedora's hardware setup (I don't know what the app is called as I'm a SuSE user) for a Synaptics Touchpad.

By default with most 2.6 kernel distros, touchpads configure as regular "mice". I had the same problem with SuSE 9.1 Pro.
 
Old 10-01-2004, 02:33 PM   #8
dino9832
LQ Newbie
 
Registered: Oct 2004
Location: San Antonio, Texas
Posts: 6

Rep: Reputation: 0
Here is the "Silver Bullet" for this one.
You need to pass the line:
Quote:
psmouse.proto=imps
to the kernel on bootup.
There is a file which I believe is
Quote:
/boot/grub/grub.conf
containing a line that looks like
Quote:
kernel /boot/vmlinuz ro root=/dev/mapper/
Just add the psmouse line to the end of the kernel /boot line and reboot the computer.
No tap from the mouse pad was driving me nuts. After the above addition to my kernel line it worked fine.
 
Old 10-10-2004, 07:44 AM   #9
peevee
LQ Newbie
 
Registered: Sep 2003
Location: india
Distribution: redhat
Posts: 18

Original Poster
Rep: Reputation: 0
Its really a silver bullet

Man it works ,
and the solution is really made simple.
I was running behind drivers and various sites for drivers...
but adding this small argument

psmouse.proto=imps
fixed the problem of tap in synaptic touch pad.
in grub gave the solution,
thankq you very much.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
my touchpad is not working - fedora core 4 lakshmansrikanth Linux - Laptop and Netbook 4 11-04-2005 09:18 PM
stop synaptics touchpad tap click easily Frank Leone Linux - Newbie 6 10-30-2005 05:44 PM
Touchpad won't tap-click Detour Linux - Laptop and Netbook 3 11-08-2004 08:57 PM
Make touchpad tap register as click drigz Linux - Software 8 10-15-2004 12:22 PM
touchpad on fedora core 2(test3) anandj Linux - Laptop and Netbook 20 06-11-2004 12:48 AM


All times are GMT -5. The time now is 10:55 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration