LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Laptop and Netbook
User Name
Password
Linux - Laptop and Netbook Having a problem installing or configuring Linux on your laptop? Need help running Linux on your netbook? This forum is for you. This forum is for any topics relating to Linux and either traditional laptops or netbooks (such as the Asus EEE PC, Everex CloudBook or MSI Wind).

Notices



Reply
 
Search this Thread
Old 02-17-2013, 02:19 PM   #1
cylent77
LQ Newbie
 
Registered: Jan 2007
Posts: 13

Rep: Reputation: 0
synaptics touchpad madly unstable


i am literally sooooo sick of this problem i am just spending so much time trying to get it right.

I have just recently bought a thinkpad x220 laptop which sadly has a synaptics touchpad. yes it also has the little red dot in between the keys.

The touchpad is the most awful thing in Linux.. almost any distro shows the same results.

the actual cursor is very jumpy. if you were to put your finger on the touchpad it would keep "moving" .. not far but its not stable in its location. jumpy, jittery, call it whatever but its just soooo painful to use.

This same behavior happens with my old HP DV7 laptop which sadly also has the same touchpad.

this has nothing to do with sensitivity although it seems it may because I've followed lots of guides to tweak sensitivity and none has worked. if you were to put your finger on the touchpad it would not be "stable" like would be in windows.

if anyone knows of a way to fix this issue i would love any assistance.

Last edited by cylent77; 02-18-2013 at 03:34 PM.
 
Old 02-17-2013, 06:26 PM   #2
jlinkels
Senior Member
 
Registered: Oct 2003
Location: Bonaire
Distribution: Debian Wheezy/Jessie/Sid, Linux Mint DE
Posts: 4,244

Rep: Reputation: 546Reputation: 546Reputation: 546Reputation: 546Reputation: 546Reputation: 546
I am not sure as to which touchpad you have exactly in the HP, but I have seen this behaviour on touchpads emulating twofinger actions which were not really supported.

Check if you have an /etc/X11/xorg.conf (or anywhere else for that matter) and see if these lines are present:
Code:
 Option          "EmulateTwoFingerMinZ"  "35"
        Option          "EmulateTwoFingerMinW"  "8"
If so, comment them out by putting a '#' in column 0

Check /var/log/Xorg.0.log to see which xorg.conf is used from where, if any. It is mentioned near the top of the file. Check this log file also for any signs of emulating the twofinger actions.

You might also check this page: http://wiki.debian.org/SynapticsTouchpad

jlinkels
 
1 members found this post helpful.
Old 02-18-2013, 07:25 AM   #3
cylent77
LQ Newbie
 
Registered: Jan 2007
Posts: 13

Original Poster
Rep: Reputation: 0
Thanks for the reply.

I have upped a video to show the problem even further.

Please pay close attention to the end of the video where I have my finger stable on the touchpad but on the screen the cursor is not.

See video here: http://youtu.be/jA1etfBqqhI
 
Old 02-18-2013, 08:26 AM   #4
Knightron
Senior Member
 
Registered: Jan 2011
Location: Planet Earth
Distribution: Slackware.
Posts: 1,344
Blog Entries: 7

Rep: Reputation: 159Reputation: 159
Hey mate, i own the x220 too, i love the little mini beast. I never noticed this issue before because in my opinion, the touchpad on the x220 is truly terrible, so i disable it. I've just rebooted my computer and enabled it again just to see if i have the same issue. I only get that shakiness when i go to the very top right where it begins to curve down; i have not tested this in windows. Unfortunately i don't know how to fix it, but just thought i'd provide you with that info. I watched you video, and do do you realize it's flipped 90 degrees? Also what desktop environment is that?
 
Old 02-18-2013, 11:43 AM   #5
cylent77
LQ Newbie
 
Registered: Jan 2007
Posts: 13

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by Knightron View Post
Hey mate, i own the x220 too, i love the little mini beast. I never noticed this issue before because in my opinion, the touchpad on the x220 is truly terrible, so i disable it. I've just rebooted my computer and enabled it again just to see if i have the same issue. I only get that shakiness when i go to the very top right where it begins to curve down; i have not tested this in windows. Unfortunately i don't know how to fix it, but just thought i'd provide you with that info. I watched you video, and do do you realize it's flipped 90 degrees? Also what desktop environment is that?
Yes its flipped cause i was recording this with my phone vertically (90 degrees). shouldn't matter cause all i want you to see is the cursor behaving erratic.

I have not tried jlinkels's solution yet... to disable the EmulateTwoFingerMinZ and the EmulateTwoFingerMinW. I will later and report.

In reference to disabling the touchpad and using the other "red dot pointy mouse" ... its somewhat hard to control when you're not used to it like i am.

Still though there has to be a solution to this.
 
Old 02-18-2013, 03:34 PM   #6
cylent77
LQ Newbie
 
Registered: Jan 2007
Posts: 13

Original Poster
Rep: Reputation: 0
problem resolved. i hope.

since i am using ubuntu which uses the new Xorg which doesnt have the /etc/X11/xorg.conf file i had to force the creation of it. that byitself was somewhat fun.
Code:
CTRL-ALT-F1
sudo invoke-rc.d gdm stop
sudo Xorg -configure
cp xorg.conf.new /etc/X11/xorg.conf
sudo invoke-rc.d gdm start
make sure those two options in the first post arent in the file and voila. the mouse is 95% more stable now.

In the end ... yes those options i believe are to blame.

When Xorg creates the config on the fly i am not sure where its putting the conf file to modify but by having xorg.conf in /etc/X11 that forces it to use what i have.



started up laptop again. problem still exists.

what a nightmare.

Last edited by cylent77; 02-19-2013 at 01:13 AM.
 
Old 02-25-2013, 03:36 AM   #7
cylent77
LQ Newbie
 
Registered: Jan 2007
Posts: 13

Original Poster
Rep: Reputation: 0
My recent discovery is as follows:

The problem DOES indeed exist on a fresh install of ANY windows version. Once the synaptics drivers get install though the mouse stabilizes.

Windows aside and back to Linux.

I install an Arch based distro, Manjaro, and the mouse appears to be 100% stable. No issues what-so-ever. I was very happy with it. However I really dont want to install arch ... the Manjaro distro leaves a lot to be desired.

I then switched over to Fedora 18. Mouse also stable. Still though not 100% i want to deal with RPMs. Just the though of RPM hell gives me the creeps.

So the issue remains -- Any ubuntu based distro causes the issue.

Could it be an option in the compiled kernel for ubuntu?
 
Old 02-25-2013, 11:30 PM   #8
EDDY1
LQ Addict
 
Registered: Mar 2010
Location: Oakland,Ca
Distribution: wins7, Debian wheezy
Posts: 6,247

Rep: Reputation: 579Reputation: 579Reputation: 579Reputation: 579Reputation: 579Reputation: 579
Have you tried Debian?
Even though Ubuntu is Debian based Ubuntu is on a different path so is not much like Debian at all.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Synaptics touchpad not recognised by synaptics driver (12.1) bogzab Slackware 13 03-22-2009 10:23 PM
Synaptics Touchpad LinuxUser101 Linux - Laptop and Netbook 2 04-14-2008 10:45 PM
Need to kill touchpad click. (Synaptics Touchpad / FC4) sarysa Linux - Laptop and Netbook 4 02-19-2007 04:15 PM
Synaptics touchpad beatupbilly Linux - Hardware 6 11-28-2004 12:43 PM
synaptics touchpad d_lake Linux - Hardware 5 02-09-2003 12:01 AM


All times are GMT -5. The time now is 06:45 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration