LinuxQuestions.org
LinuxAnswers - the LQ Linux tutorial section.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Laptop and Netbook
User Name
Password
Linux - Laptop and Netbook Having a problem installing or configuring Linux on your laptop? Need help running Linux on your netbook? This forum is for you. This forum is for any topics relating to Linux and either traditional laptops or netbooks (such as the Asus EEE PC, Everex CloudBook or MSI Wind).

Notices

Reply
 
Search this Thread
Old 10-15-2004, 02:30 AM   #1
cedar
Member
 
Registered: Feb 2004
Location: Colorado Springs, CO
Distribution: Ubuntu, Fedora, PCLinux, MEPIS, still miss Libranet
Posts: 162

Rep: Reputation: 30
synaptic touchpad problem


I have installed the synaptics touchpad driver via apt. My intent is to get the touchpad to work if the mouse is unplugged after booting. Right now, if the mouse is connected at boot and it gets unplugged later the touchpad doesn't take over. Well, that's not entirely accurate, it gets very erratic when I touch it. If the mouse is not connected at boot, the touchpad is good.
This is my XF86Config-4 (pertinent parts anyway):
********************************************************
Section "InputDevice"
Identifier "Mouse"
Driver "mouse"
Option "CorePointer"
Option "Device" "/dev/psaux"
Option "Protocol" "ImPS/2"
Option "Emulate3Buttons" "true"
Option "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"
Identifier "Synaptic Pad"
Driver "synaptics"
Option "SendCoreEvents" "Yes"
Option "Device" "/dev/psaux"
Option "Protocol" "ImPS/2"
Option "LeftEdge" "1900"
Option "RightEdge" "5400"
Option "TopEdge" "1900"
Option "BottomEdge" "4000"
Option "FingerLow" "25"
Option "FingerHigh" "30"
Option "MaxTapTime" "180"
Option "MaxTapMove" "220"
Option "VertScrollDelta" "100"
Option "MinSpeed" "0.02"
Option "MaxSpeed" "0.18"
Option "AccelFactor" "0.0010"
Option "SHMConfig" "on"
Option "Buttons" "7"
Option "ZAxisMapping" "4 5"
EndSection

Section "ServerLayout"
Identifier "Default Layout"
Screen "Default Screen"
InputDevice "Default Keyboard"
InputDevice "Mouse"
InputDevice "Synaptic Pad"
EndSection
********************************************************

Note: This is using either kernel 2.4.26 or 2.6.8
 
Old 10-15-2004, 10:21 AM   #2
dtor
Member
 
Registered: Jun 2004
Location: Indiana, US
Distribution: Used to be RedHat 8
Posts: 43

Rep: Reputation: 15
Unless you see mention of an "active multiplexing controller" in your dmesg switch to using an external USB mouse - it is the most reliable way to have Synaptics and other mouse work together (hardware limitation).

Or, if you do not care about touchpad scrolling (and maybe scroll wheel on the mouse), you may try using psmouse.proto=imps or psmouse.proto=bare options on boot or put proto=imps or proto=bare in modprobe.conf (if psmouse is a module).
 
Old 10-16-2004, 03:31 AM   #3
lucastic
Member
 
Registered: Aug 2003
Location: Oz
Distribution: Gentoo - Debian
Posts: 202

Rep: Reputation: 30
I dont know whether or not you are using a usb mouse or not, but as the last post said, usb is alot easier to get working with xorg.

Here is my /etc/X11/xorg.conf synaptics and usb mouse sections:

Section "InputDevice"
Identifier "Synaptics Mouse"
Driver "synaptics"
Option "Device" "/dev/psaux"
Option "Protocol" "auto-dev"
Option "LeftEdge" "1700"
Option "RightEdge" "5300"
Option "TopEdge" "1700"
Option "BottomEdge" "4200"
Option "FingerLow" "25"
Option "FingerHigh" "30"
Option "MaxTapTime" "180"
Option "MaxTapMove" "220"
Option "VertScrollDelta" "100"
Option "MinSpeed" "0.06"
Option "MaxSpeed" "0.12"
Option "AccelFactor" "0.0010"
Option "SHMConfig" "on"
Option "UpDownScrolling" "0"
Option "RTCornerButton" "0"
Option "BTCornerButton" "0"
# Option "Repeater" "/dev/ps2mouse"
EndSection

Section "InputDevice"
Identifier "Mouse2"
Driver "mouse"
Option "Protocol" "Auto"
Option "Device" "/dev/mouse"
EndSection

Section "ServerLayout"

#other stuff

InputDevice "Synaptics Mouse" "CorePointer"
InputDevice "Mouse2" "SendCoreEvents"

EndSection


This will make the usb mouse work whenever it is plugged in.

What I want to know is how to turn the touchpad off mid X session (using acpi buttons mapped to a simple script), because it gets annoying sometimes when you are trying to use the keyboard alot.

Hope this helps

Lucas
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Synaptic touchpad tapping issue Ayukawa Linux - Laptop and Netbook 0 02-18-2005 08:48 AM
Synaptic Alps touchpad help okplayer02 Linux - Laptop and Netbook 1 12-30-2004 10:01 AM
scroller and NON Synaptic touchpad mel82 Linux - Hardware 4 09-17-2004 08:41 PM
disable synaptic touchpad ljpete Linux - Newbie 1 01-31-2004 05:42 AM
disable synaptic touchpad ljpete Linux - Distributions 0 01-30-2004 09:59 PM


All times are GMT -5. The time now is 10:47 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration