LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Laptop and Netbook (http://www.linuxquestions.org/questions/linux-laptop-and-netbook-25/)
-   -   synaptic touchpad problem (http://www.linuxquestions.org/questions/linux-laptop-and-netbook-25/synaptic-touchpad-problem-242862/)

cedar 10-15-2004 02:30 AM

synaptic touchpad problem
 
I have installed the synaptics touchpad driver via apt. My intent is to get the touchpad to work if the mouse is unplugged after booting. Right now, if the mouse is connected at boot and it gets unplugged later the touchpad doesn't take over. Well, that's not entirely accurate, it gets very erratic when I touch it. If the mouse is not connected at boot, the touchpad is good.
This is my XF86Config-4 (pertinent parts anyway):
********************************************************
Section "InputDevice"
Identifier "Mouse"
Driver "mouse"
Option "CorePointer"
Option "Device" "/dev/psaux"
Option "Protocol" "ImPS/2"
Option "Emulate3Buttons" "true"
Option "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"
Identifier "Synaptic Pad"
Driver "synaptics"
Option "SendCoreEvents" "Yes"
Option "Device" "/dev/psaux"
Option "Protocol" "ImPS/2"
Option "LeftEdge" "1900"
Option "RightEdge" "5400"
Option "TopEdge" "1900"
Option "BottomEdge" "4000"
Option "FingerLow" "25"
Option "FingerHigh" "30"
Option "MaxTapTime" "180"
Option "MaxTapMove" "220"
Option "VertScrollDelta" "100"
Option "MinSpeed" "0.02"
Option "MaxSpeed" "0.18"
Option "AccelFactor" "0.0010"
Option "SHMConfig" "on"
Option "Buttons" "7"
Option "ZAxisMapping" "4 5"
EndSection

Section "ServerLayout"
Identifier "Default Layout"
Screen "Default Screen"
InputDevice "Default Keyboard"
InputDevice "Mouse"
InputDevice "Synaptic Pad"
EndSection
********************************************************

Note: This is using either kernel 2.4.26 or 2.6.8

dtor 10-15-2004 10:21 AM

Unless you see mention of an "active multiplexing controller" in your dmesg switch to using an external USB mouse - it is the most reliable way to have Synaptics and other mouse work together (hardware limitation).

Or, if you do not care about touchpad scrolling (and maybe scroll wheel on the mouse), you may try using psmouse.proto=imps or psmouse.proto=bare options on boot or put proto=imps or proto=bare in modprobe.conf (if psmouse is a module).

lucastic 10-16-2004 03:31 AM

I dont know whether or not you are using a usb mouse or not, but as the last post said, usb is alot easier to get working with xorg.

Here is my /etc/X11/xorg.conf synaptics and usb mouse sections:

Section "InputDevice"
Identifier "Synaptics Mouse"
Driver "synaptics"
Option "Device" "/dev/psaux"
Option "Protocol" "auto-dev"
Option "LeftEdge" "1700"
Option "RightEdge" "5300"
Option "TopEdge" "1700"
Option "BottomEdge" "4200"
Option "FingerLow" "25"
Option "FingerHigh" "30"
Option "MaxTapTime" "180"
Option "MaxTapMove" "220"
Option "VertScrollDelta" "100"
Option "MinSpeed" "0.06"
Option "MaxSpeed" "0.12"
Option "AccelFactor" "0.0010"
Option "SHMConfig" "on"
Option "UpDownScrolling" "0"
Option "RTCornerButton" "0"
Option "BTCornerButton" "0"
# Option "Repeater" "/dev/ps2mouse"
EndSection

Section "InputDevice"
Identifier "Mouse2"
Driver "mouse"
Option "Protocol" "Auto"
Option "Device" "/dev/mouse"
EndSection

Section "ServerLayout"

#other stuff

InputDevice "Synaptics Mouse" "CorePointer"
InputDevice "Mouse2" "SendCoreEvents"

EndSection


This will make the usb mouse work whenever it is plugged in.

What I want to know is how to turn the touchpad off mid X session (using acpi buttons mapped to a simple script), because it gets annoying sometimes when you are trying to use the keyboard alot.

Hope this helps

Lucas


All times are GMT -5. The time now is 11:30 PM.