LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Laptop and Netbook (http://www.linuxquestions.org/questions/linux-laptop-and-netbook-25/)
-   -   Syanptics touchpad not working after recompile of kernel (http://www.linuxquestions.org/questions/linux-laptop-and-netbook-25/syanptics-touchpad-not-working-after-recompile-of-kernel-288332/)

microsoft/linux 02-09-2005 09:02 PM

Syanptics touchpad not working after recompile of kernel
 
I recently recompiled my kernel, and my synaptics touchap stopped working. I'm using debian sarge. I have both the driver from http://w1.894.telia.com/~u89404340/touchpad/index.html and *.deb package of the synaptics driver. Any ideas? I'll have to get my XF86Config-4 posted in a little while, I have to boot into linux to get it. Thanks in advance


EDIT: I'm sorry I wan't clear, and through my unclarity I was misleading, my touchpad works. But what I'm trying to do is get tapping a scrolling working. Sorry again. I know I know:tisk:

Bruce Hill 02-09-2005 09:05 PM

Look in your old kernel config file, and see what
support for the mouse is different than in your
new kernel config file...

microsoft/linux 02-09-2005 09:59 PM

I don't think I have that config file. Any other ideas? not to blow you off though Chinaman

Bruce Hill 02-09-2005 10:13 PM

Quote:

Originally posted by microsoft/linux
I don't think I have that config file. Any other ideas? not to blow you off though Chinaman
What did you do with your original config file?
Did you rm it? If not, it's still in your system,
you just might not know where to look for it.
I'm using Slackware, and Debian does some
things in a peculiar way, so your config files
may not be in the same place. Here they are ->
Code:

mingdao@james:~/titus$ ls -alc /usr/src/linux-2.4.26/
total 260
drwxr-xr-x  15 root root  584 2004-09-18 16:18 ./
drwxr-xr-x  6 root root  192 2004-09-21 18:38 ../
-rw-r--r--  1 root root 41017 2004-09-18 16:12 .config
<snip>
mingdao@james:~/titus$ ls -alc /usr/src/linux-2.6.7/
total 12078
drwxrwxr-x  19  500  500    1248 2004-11-08 10:37 ./
drwxr-xr-x  6 root root    192 2004-09-21 18:38 ../
-rw-r--r--  1 root root    433 2004-11-08 10:36 ..tmp_kallsyms1.o.cmd
-rw-r--r--  1 root root    433 2004-11-08 10:36 ..tmp_kallsyms2.o.cmd
-rw-r--r--  1 root root    579 2004-11-08 10:36 ..tmp_vmlinux1.cmd
-rw-r--r--  1 root root    595 2004-11-08 10:36 ..tmp_vmlinux2.cmd
-rw-r--r--  1 root root  25500 2004-11-08 10:33 .config
<snip>

And of course, you should be able to browse the CD
you used to install Debian with the original kernel and
check the config file from there...

Another idea is to check your old XF86Config-4 file
against your new one. I think that touchpad is basically
just a PS/2 mouse configuration...except maybe for it's
extra functions...

Another idea is to work the Google <Linux> search engine
for some synaptics touch pad information. ;-)

microsoft/linux 02-10-2005 07:06 PM

please not the edit above, I'll get my XF86Config. Sorry again for the confusion.

microsoft/linux 02-14-2005 02:43 PM


NOTE: Again, in my first post I was confusing. I meant to say that the tapping and scrolling don't work after my kernel recompile. Sorry1


here's the part of my XF86Config relating to my mouse
Quote:

Section "InputDevice"
Identifier "Configured Mouse"
Driver "mouse"
Option "CorePointer"
Option "Device" "/dev/psaux"
Option "Protocol" "GlidePointPS/2"
Option "Emulate3Buttons" "true"
Option "ZAxisMapping" "4 5"
EndSection
Section "InputDevice"
Identifier "Generic Mouse"
Driver "mouse"
Option "SendCoreEvents" "true"
Option "Device" "/dev/input/mice"
Option "Protocol" "ImPS/2"
Option "Emulate3Buttons" "true"
Option "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"
Identifier "Synaptics Touchpad"
Driver "synaptics"
Option "SendCoreEvents" "true"
Option "ZAxisMapping" "4 5"
Option "Device" "/dev/psaux"
Option "Protocol" "auto"

Bruce Hill 02-14-2005 08:06 PM

Quote:

Originally posted by microsoft/linux
please not the edit above, I'll get my XF86Config. Sorry again for the confusion.
I think you meant to say "note" rather than "not" --
there is a difference.

You should put the edit that's in bold in your first post
in the post with your "XF86Config relating to my mouse"
just above this post.

You were confusing, because you said your mouse
stopped working after you recompiled your kernel,
which would not change your XF86Config file...

microsoft/linux 02-15-2005 02:04 PM

does anyone know? I could really use it. Thanks in advance.

Bruce Hill 02-15-2005 09:29 PM

Quote:

Originally posted by microsoft/linux
does anyone know? I could really use it. Thanks in advance.
You said you got a driver from
http://w1.894.telia.com/~u89404340/touchpad/index.html
Did you read that entire file and check
everything that is says to check? I don't
think anyone could give you much more
thorough help and directions than that...

Please also tells us the make and model
of your laptop, and post the output of
# lspci (as root)
$ lsmod (as user)

microsoft/linux 02-16-2005 07:45 AM

it's a compaq presario 2104US. I'll get the lspci/lsmod for you I have to boot into linux to do that. Thanks again.

Bruce Hill 02-16-2005 08:10 AM

You said you got a driver from
http://w1.894.telia.com/~u89404340/touchpad/index.html
Did you read that entire file and check
everything that is says to check?

microsoft/linux 02-16-2005 08:39 AM

yes, is there a way to get "evdev" without recompiling the kernel? I don't really want to recompile but I will if I have to. Thanks again

mlmurray 02-16-2005 08:30 PM

If you go back into your config and add support for evdev as a module, then run (as root) make, then make modules_install, that'll probably fix it. It will happen pretty fast because only the changes in the config are re compiled. In this case, it should just compile the new module. Then, when you run make modules_install, it should put everything back in the right places and you should be set - no need to copy the new kernel image to /boot or anything (it shouldn't have changed).

microsoft/linux 02-18-2005 10:23 AM

recompiled my kernel for evdev and ndiswrapper support and now it works. Thanks for you help


All times are GMT -5. The time now is 06:33 PM.