LinuxQuestions.org
LinuxAnswers - the LQ Linux tutorial section.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Laptop and Netbook
User Name
Password
Linux - Laptop and Netbook Having a problem installing or configuring Linux on your laptop? Need help running Linux on your netbook? This forum is for you. This forum is for any topics relating to Linux and either traditional laptops or netbooks (such as the Asus EEE PC, Everex CloudBook or MSI Wind).

Notices

Reply
 
Search this Thread
Old 06-04-2003, 03:56 AM   #1
unitcoed
LQ Newbie
 
Registered: Jun 2003
Distribution: RedHat 9, Slackware Live, Slackware 9
Posts: 16

Rep: Reputation: 0
switching between laptop touch pad and USB mouse


hi!
The situtation is: when at home I use a USB mouse, and when out and about I use my laptop's touch pad. But the problem is whenever i want to switch between the two, I need to restart the computer , to get the different settings to work.

is there anyway to make both devices work simultaniously; so that I dont have to keep restarting linux!?!

Details:

Red Hat 9.0
Toshiba Satellite 3000 PIII 1ghz

thanks in advance!!
-kris
 
Old 06-04-2003, 10:31 AM   #2
moses
Senior Member
 
Registered: Sep 2002
Location: Arizona, US, Earth
Distribution: Slackware, (Non-Linux: Solaris 7,8,9; OSX; BeOS)
Posts: 1,152

Rep: Reputation: 46
Define both mice in your XF86Config in a manner similar to this:
Code:
Section "InputDevice"
        Identifier      "Touchpad"
        Driver          "mouse"
        Option          "CorePointer"
        Option          "Device"                "/dev/psaux"
        Option          "Protocol"              "ImPS/2"
        Option          "Emulate3Buttons"       "true"
        Option          "ZAxisMapping"          "4 5"
EndSection

Section "InputDevice"
        Identifier      "USB Mouse"
        Driver          "mouse"
        Option          "SendCoreEvents"        "true"
        Option          "Device"                "/dev/input/mice"
        Option          "Protocol"              "ImPS/2"
        Option          "Emulate3Buttons"       "true"
        Option          "ZAxisMapping"          "4 5"
EndSection

Section "ServerLayout"
        Identifier      "Default Layout"
        Screen          "Screen1"
        InputDevice     "Generic Keyboard"
        InputDevice     "Touchpad"
        InputDevice     "USB Mouse"
EndSection
This will send/receive events to/from both devices.

Last edited by moses; 06-04-2003 at 10:34 AM.
 
Old 06-04-2003, 08:24 PM   #3
unitcoed
LQ Newbie
 
Registered: Jun 2003
Distribution: RedHat 9, Slackware Live, Slackware 9
Posts: 16

Original Poster
Rep: Reputation: 0
thanks that was really helpful. Now Linux wont start up

-Kris

PS: is there any way I can edit XF86Config in the terminal (since the GUI won't load)

Last edited by unitcoed; 06-04-2003 at 08:28 PM.
 
Old 06-05-2003, 12:57 AM   #4
moses
Senior Member
 
Registered: Sep 2002
Location: Arizona, US, Earth
Distribution: Slackware, (Non-Linux: Solaris 7,8,9; OSX; BeOS)
Posts: 1,152

Rep: Reputation: 46
Linux not starting and the X server or window manager not starting are two very different things, which is your problem? I can't imagine that your editing of XF86Config would have anything to do with Linux not starting.
I'm assuming you mean X won't start. You can edit XF86Config with many editors. I prefer vi, but some other options are emacs and pico.
You can also find out what the problem is by looking at the file:
/var/log/XFree86.0.log, the error will usually be at the end of the file, which you can see with the command:
Code:
tail -40 /var/log/XFree86.0.log
I'm sure the problem has to do with X not finding one or both of the pointing devices, but it's best to worry about that after we see the error message. If you post the error message, we can get both devices working. . .
 
Old 06-05-2003, 06:33 AM   #5
laurentbon
Member
 
Registered: Mar 2003
Distribution: Slack 9.1 + Dropline Gnome
Posts: 160

Rep: Reputation: 30
If you are in runlevel 4 (the one where the X server starts automatically) an you XF86Config file is buggy, you might find yourself in that situation where you reboot and the x server starts with an error and that freezes the computer.

To repair your system, boot ut from the slack cd up to the prompt. At the prompt, you need to mount the partition hosting your slack distro.
To do that type:

# mkdir /homepart
# mount /dev/hdax /homepart

(/dev/hdax needs to be replaced by your partition device)

From there, all the files are accessible from /homepart.
Therefore, if you have a back up of your XF86Config file prior to the change that broke it, restore it:

# cd /homepart/etc/X11/
# cp XF86Config-backup XF86Config

(assuming XF86Config-backup is yout backup file)

Ar a rule of thumb, before modifying your XFree86config file, always make sure to change the runlevel to 3 (x not automatically started) in case something goes wrong. You can do that quickly by typing:

# telinit 3

Obviously, you can still start the Xserver by doing:

# startx

But if the xserver fails starting, it will shutdown and you will have the command line to keep on debugging.

THe other thing that might be helpful is to remember that doing a telinit won't change the default runlevel at next reboot. If you want to change that, you need to change the inittab in /etc.

Hope it helps..
 
Old 06-05-2003, 06:59 AM   #6
unitcoed
LQ Newbie
 
Registered: Jun 2003
Distribution: RedHat 9, Slackware Live, Slackware 9
Posts: 16

Original Poster
Rep: Reputation: 0
sorry for the sarcasm on my last post, I was just a bit irritated.

the problem was that X window didn't load; I got a blank window (not the X window interface) that had two buttons "Yes" and "Cancel" that was followed by another blank window that had two buttons "Yes" and "cancel" and finaly an OK button.

The first time i got this screen, I canceled the first two screens and hit OK. This didn't work, Bringing me to the Terminal. I then typed # startx but that didn't work.

So i restarted my computer, and it did the same thing. (the blank windows) This time I changed the order, hitting the Yes button followed by yes, and this loaded up X window.
(confusing? yes! )

But the great thing is, now both touch-pad and the usb mouse work!!


thank you laurentbon and Moses for your replies!!

Last edited by unitcoed; 06-05-2003 at 07:01 AM.
 
Old 06-05-2003, 09:39 AM   #7
moses
Senior Member
 
Registered: Sep 2002
Location: Arizona, US, Earth
Distribution: Slackware, (Non-Linux: Solaris 7,8,9; OSX; BeOS)
Posts: 1,152

Rep: Reputation: 46
Quote:
Originally posted by laurentbon
If you are in runlevel 4 (the one where the X server starts automatically) an you XF86Config file is buggy, you might find yourself in that situation where you reboot and the x server starts with an error and that freezes the computer.
If the system is set up correctly (like Slackware), one doesn't need to go through all of that to fix X, simply hit Ctrl-Alt-F6 and you can get to a command line. Having a bad XF86Config should not freeze your computer, even if it starts in runlevel 4, since X is generally smart enough to recognize that its config file is bad and doesn't lock up the system.
 
Old 06-05-2003, 09:42 AM   #8
moses
Senior Member
 
Registered: Sep 2002
Location: Arizona, US, Earth
Distribution: Slackware, (Non-Linux: Solaris 7,8,9; OSX; BeOS)
Posts: 1,152

Rep: Reputation: 46
Quote:
Originally posted by unitcoed
the problem was that X window didn't load; I got a blank window (not the X window interface) that had two buttons "Yes" and "Cancel" that was followed by another blank window that had two buttons "Yes" and "cancel" and finaly an OK button.

But the great thing is, now both touch-pad and the usb mouse work!!
I have never seen this behavior before (no one should ever see that behavior, as it's stupid). What window manager are you using?

I'm glad it's working for you. =-}
 
Old 06-05-2003, 11:16 PM   #9
akaBeaVis
Guru
 
Registered: Apr 2003
Location: Maryland
Distribution: Slack 9.1,10 Mandrake 10,10.1, FedCore 2,3, Mepis 2004, Knoppix 3.6,3.7, SuSE 9.1, FreeBSD 5.2
Posts: 1,109

Rep: Reputation: 45
greetings, I have this same situation on my thinkpad. I have a ms wireless wheel mouse and the pointing stick working at the same time in X, if you post your X config file (should be the one ending in "-4") maybe we can fix it up for you.

One thing you've probably already thought of, but I'll verbalize anyway: Never edit your X config without backing it up first, it's so much easier to restore it and begin anew as opposed to trying to remember how it was.


One last thing about my setup: it does not yet survive a suspend/resume, at that point I have to exit X, and restart it, other than that it works nicely
 
Old 06-11-2003, 12:37 PM   #10
Astro
Member
 
Registered: Jan 2003
Location: Ballston Lake, NY
Distribution: Slackware, Debian
Posts: 660

Rep: Reputation: 30
Don't forget at the bottom of the XF86COnfig file to put the devices like this...

InputDevice "touchpad" "CorePointer"
InputDevice "usbmouse" "SendCoreEvents"
InputDevice "Keyboard1" "CoreKeyboard"

THis is my config for slackware, cause if I boot up without a USB mouse plugged in and I had the CorePointer the USB thing it gave an error and I couldn't use the mouse/touchpad at all.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Disblae Touch pad *Clicking* on a laptop wh33t Linux - Hardware 6 06-03-2009 07:07 PM
How can I con figure touch pad mouse? Mal495 Mandriva 1 05-23-2004 03:07 PM
Can't enable touch-pad and usb-mouse at the same time... Beavis_73 Linux - Laptop and Netbook 2 03-01-2004 06:40 PM
Laptop install - use mouse or touch pad? mark_2811 Linux - General 1 02-21-2004 06:06 PM
touch pad...mouse all over the place dynamo|x Linux - Laptop and Netbook 3 06-02-2003 11:10 AM


All times are GMT -5. The time now is 08:02 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration