LinuxQuestions.org
View the Most Wanted LQ Wiki articles.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Laptop and Netbook
User Name
Password
Linux - Laptop and Netbook Having a problem installing or configuring Linux on your laptop? Need help running Linux on your netbook? This forum is for you. This forum is for any topics relating to Linux and either traditional laptops or netbooks (such as the Asus EEE PC, Everex CloudBook or MSI Wind).

Notices



Reply
 
Search this Thread
Old 08-01-2011, 12:05 AM   #1
BarbieQ1
LQ Newbie
 
Registered: Feb 2008
Location: USA
Distribution: Fedora 14
Posts: 11

Rep: Reputation: 0
Question Swapping PgUp and Shift Keys in Fedora 14


I've finally given up on Asus ever offering an Xathros upgrade and having to patch things together, so I installed Fedora 14 (Gnome) on my 700-series EEE. It is running great (after a surprisingly horrid experience with KDE Fedora 15).

The one thing I haven't figured out is how to swap the PgUp and right Shift keys so that I actually capitalize when I type and don't insert the lowercase letter into the line above. I had this set up with KDE, but it doesn't seem to be so easy in Gnome.

There are two ways to do this as far as I can tell, but I'm a bit stuck on both.

1) The first way, which would probably switch it for all keyboards is to switch the keycodes. I have figured out that the file I want to alter is probably located in:
/usr/share/X11/xkb/keycodes/
I'm guessing that if I swap the numbers for RTSH and PGUP that this would solve it. However, I'm not exactly sure which file within the keycodes I need since my system is using an "unidentified" keyboard. I suspect it will be the 'xfree86', but I am delaying the alteration as I would prefer option 2 below.

2) The second way would be to switch the keys for a given keyboard (US), but not for others. I used two keyboards in my KDE systems. The first was the default with the keys swapped. The second was the keyboard without the swap for the times I use an external keyboard for heavy typing so that the PgUp and Shift keys worked fine.

However, it seems that the right Shift (RTSH) and Page Up (PGUP) keys are not related to the language and are located in other files. (I found RTSH in "Shift", but haven't located PGUP yet.) This would mean it is basically like doing option 1, but with more mess.

So...
If anyone has any suggestions on how I might swap the PgUp and right Shift key for one keyboard (say the USA-US) and not others (say the USA-International or Canada-English), your help would be greatly appreciated!
 
  


Reply

Tags
eee, keyboard


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Remapping shift&ctrl keys kills key repetition nitro2k01 Linux - Desktop 2 02-13-2010 01:56 PM
Home, end, pgup, pgdown keys not working antimatter3009 Linux - Desktop 1 12-29-2006 04:31 AM
Keyboard is swapping keys jamiem Linux - Newbie 7 06-23-2005 09:50 PM
swapping " and @ keys on mac keyboard alcibiades Linux - Newbie 3 04-23-2005 09:03 AM
Shift+keypad keys... asqueella Linux - Newbie 3 04-20-2004 12:42 AM


All times are GMT -5. The time now is 08:58 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration