LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Laptop and Netbook
User Name
Password
Linux - Laptop and Netbook Having a problem installing or configuring Linux on your laptop? Need help running Linux on your netbook? This forum is for you. This forum is for any topics relating to Linux and either traditional laptops or netbooks (such as the Asus EEE PC, Everex CloudBook or MSI Wind).

Notices

Reply
 
Search this Thread
Old 12-07-2005, 10:00 AM   #1
vicere
LQ Newbie
 
Registered: Dec 2005
Posts: 9

Rep: Reputation: 0
Suspend to disk in SuSE 10.0


Hello,

I have an IBM thinkpad R40, I was running SuSE 9.3;
it worked fine, including suspend to disk,
suspend to ram and dual boot.

I have updated to SuSE 10.0; the suspend to disk and
suspend to ram don't work anymore! Better said: I can
suspend, but when I try to resume, the kernel issues
messages related with the integrity of the reiserfs
filesystem, which appears to have been improperly shut down.

Did anybody experience a similar problem? Any hint
besides the obvious "go back to 9.3" ?

Thanks!

Andrea
 
Old 12-07-2005, 12:53 PM   #2
vicere
LQ Newbie
 
Registered: Dec 2005
Posts: 9

Original Poster
Rep: Reputation: 0
P.S. the suspend to ram works actually. It is the suspend to disk
which fails.
 
Old 12-07-2005, 01:08 PM   #3
slantoflight
Member
 
Registered: Aug 2005
Distribution: Smoothwall
Posts: 283
Blog Entries: 3

Rep: Reputation: 35
lol, I have the opposite of your problem actually in Suse 10.

Though I expect its bios related as my bios doesn't support S3 anyway.



Try fsck.
 
Old 12-07-2005, 02:34 PM   #4
biophysics
Member
 
Registered: Jan 2002
Location: Germany
Distribution: Kubuntu
Posts: 444

Rep: Reputation: 30
Look into:
/var/log/suspend2disk.log
/var/log/suspend2ram.log

It might give you some clues. Or post them here.


change in this file: /etc/sysconfig/powersave/sleep
SUSPEND2DISK_SHUTDOWN_MODE="shutdown"
 
Old 12-10-2005, 02:39 PM   #5
vicere
LQ Newbie
 
Registered: Dec 2005
Posts: 9

Original Poster
Rep: Reputation: 0
Thanks for the help

Thanks for the suggestions I have checked, and the
file /etc/sysconfig/powersave already includes the
setting SUSPEND2DISK_SHUTDOWN_MODE="shutdown" .

The file /var/log/suspend2disk.log does not seem to contain
any error or warning, it ends with a reassuring
------------------------------------------------------------------------------
prepare_sleep finished for suspend2disk
------------------------------------------------------------------------------
preparing boot-loader: selecting entry 0, kernel /boot/2.6.13-15-default
time needed for sync: 0.1 seconds, time needed for grub: 53.1 seconds.


Andrea
 
Old 12-10-2005, 08:34 PM   #6
vicere
LQ Newbie
 
Registered: Dec 2005
Posts: 9

Original Poster
Rep: Reputation: 0
Suspend to disk in SuSE 10: SOLVED!

Thanks for suggesting me to look in the logfiles!

I have discovered that the resume= option was not set in the GRUB menu.

Apparently, when updating from SuSE 9.3 to SuSE 10.0, the resume=/dev/something
option was not fixed in the GRUB bootloader configuration.

Anybody experiencing the same problem: look in the
/boot/grub/menu.1st file,
the entry corresponding to the SuSE 10 kernel should
contain a resume=/dev/hda# entry, with # being the number
corresponding to your swap device.

Another hint: if you do not see the grub menu when restarting,
you will have to modify the grub-once function in the
file /usr/lib/powersave/scripts/sleep_helper_functions

Setting it to

grub-once() {
echo -e "savedefault --stage2=/boot/grub/stage2 --default=$1 --once\nquit" | grub --batch
}

worked for me.
 
Old 12-11-2005, 04:58 AM   #7
biophysics
Member
 
Registered: Jan 2002
Location: Germany
Distribution: Kubuntu
Posts: 444

Rep: Reputation: 30
Quote:
Apparently, when updating from SuSE 9.3 to SuSE 10.0, the resume=/dev/something
option was not fixed in the GRUB bootloader configuration.
Could you file a bug regarding this: https://bugzilla.novell.com
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
'Suspend to Disk' in Suse 9.3 really annoying me. Be.Gurmeet.Be Suse/Novell 2 07-12-2005 11:53 AM
A Problem Related to " SUSPEND to DISK " Option in SuSE 9.3 bedi-beparwah Suse/Novell 1 06-28-2005 08:06 AM
Suspend-to-disk in SuSE 9.3 bt05 Suse/Novell 4 05-08-2005 01:55 PM
WOW! Suspend-to-disk works in Suse 9.2! kenlin Linux - Laptop and Netbook 6 01-25-2005 10:08 PM
SuSE 9.1 suspend-to-disk: resume doesn't work mabuse Linux - General 0 10-25-2004 12:40 PM


All times are GMT -5. The time now is 03:02 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration