LinuxQuestions.org
Go Job Hunting at the LQ Job Marketplace
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Laptop and Netbook
User Name
Password
Linux - Laptop and Netbook Having a problem installing or configuring Linux on your laptop? Need help running Linux on your netbook? This forum is for you. This forum is for any topics relating to Linux and either traditional laptops or netbooks (such as the Asus EEE PC, Everex CloudBook or MSI Wind).

Notices

Reply
 
Search this Thread
Old 10-09-2009, 06:55 PM   #1
defensorfedei
LQ Newbie
 
Registered: Oct 2009
Location: Adirondacks, NY
Distribution: Linux Mint 7: Gloria
Posts: 3

Rep: Reputation: 0
Suspend/Hibernation resume problems with ATI graphics card.


Hi all,

I have scoured the web for a few days trying to find a fix for my suspension/hibernation resume problems. Everything I have tried has not yielded any new results. I have tried...

Editing acpi-support files in accordance with many tutorials. Nothing.

Disabling pm-utils and installing uswusp for suspension in accordance with many tutorials. Nothing.

I have tried a few other things that required a complete system restoration. Good times.

I am using an ATI Radeon HD 3650 graphics card on an MSI GX730 laptop with AMD Turion X2 processor (RM-70). I am running Linux Mint 7 64bit. I am also using the proprietary ATI Catalyst 9.6 fglrx driver. Many a source on the internet claims that this is the source of my problems. When my laptop resumes, I either get a black screen with movable mouse cursor, or Mint splash screen with movable cursor.....but that is all. It never gives me the option to log in at resume, it just hangs requiring a hard restart.

Has anyone, who is using the proprietary ATI driver been able to get suspend to resume properly? I know nvidia folks have accomplished this with their proprietary drivers. Has anyone had success with suspension/hibernation using the open-source ATI driver? Can anyone offer up a possible solution or a place to find one? Just wondering what my chances are.

Thanks in advance for any help you can offer.
 
Old 10-10-2009, 01:43 PM   #2
business_kid
Guru
 
Registered: Jan 2006
Location: Ireland
Distribution: Slackware & Android
Posts: 6,268

Rep: Reputation: 540Reputation: 540Reputation: 540Reputation: 540Reputation: 540Reputation: 540
Presuming you are set up, go for hibernate first.
cat /sys/power/state should tell you where you can suspend to

For hibernate, you need resume=<your_swap_partition> e.g. resume=/dev/sda9
sync; echo disk > /sys/power/state should do it. Personally I'm too lazy to chase susspend graphic issues. I have a previous ati chipset (rs690/sb600)
 
Old 10-11-2009, 11:08 AM   #3
defensorfedei
LQ Newbie
 
Registered: Oct 2009
Location: Adirondacks, NY
Distribution: Linux Mint 7: Gloria
Posts: 3

Original Poster
Rep: Reputation: 0
Ok, I am glad to finally get a response. Thanks for that.

I ran cat /sys/power/state which yielded this: standby mem disk

I am not entirely sure what this means since it didn't give me an actually device like /dev/sda4 for example.

I ran nautilus and went to /sys/power and tried opening the "state" and "resume" files to see what was going on. I get an error that no such files exist and they cannot be opened. I am using root privileges to open these files, but the same error. Could this have something to do with my problems?

I also tried tux on ice (suspend2) to try and get it to work. After a good hour of hacking, I got hibernate to work but then it fouled up my system pretty bad. Thank God for Clonezilla!!

Does anyone think that "state" and "resume" file errors are the source of my problem. What should these files say?

Thanks again for any help.
 
Old 10-12-2009, 03:51 AM   #4
business_kid
Guru
 
Registered: Jan 2006
Location: Ireland
Distribution: Slackware & Android
Posts: 6,268

Rep: Reputation: 540Reputation: 540Reputation: 540Reputation: 540Reputation: 540Reputation: 540
You have to recompile the kernel for hibernate with
CONFIG_STD_PM_PARTITION=/your/swap

That may help.
 
Old 10-12-2009, 09:53 AM   #5
defensorfedei
LQ Newbie
 
Registered: Oct 2009
Location: Adirondacks, NY
Distribution: Linux Mint 7: Gloria
Posts: 3

Original Poster
Rep: Reputation: 0
Problem Solved....Well Found!!!!!!

I have found out that my problem is a confirmed bug for debian based systems using Compiz-fusion. As it turns out, it truly had nothing to do with the proprietary ATI catalyst driver. I checked my kernel modules and discovered that I had everything in order for suspend/hibernate to work. All I needed to change was the priority of my swap partition and then disable all desktop effects by going to SYSTEM->PREFERENCES->APPEARANCE->VISUAL EFFECTS. Then just toggle the no effects button. Or it has been suggested that you use Metacity instead. Here is what I did.

Next open a terminal and type the following:

swapon -s

-You should get something like this:

Filename Type Size Used Priority
/dev/sdb8 partition 2048184 0 1 (don't worry if your swap device is a different number......it could be /dev/sda4 or whatever else it may be in your case). If you get any number lower than one (like 0 or a negative value) then you will have to do the following. In my case, the number was -1.

In the terminal type:

sudo gedit /etc/fstab and make your file look like this one, taking note of the bolded addition.

# <file system> <mount point> <type> <options> <dump> <pass>
proc /proc proc defaults 0 0
# /dev/sdb9
UUID=1e603731-5088-4e2f-b239-399b51e437c1 / ext3 relatime,errors=remount-ro,data=writeback 0 1
# /dev/sdb8
UUID=19fcf2e9-ed0d-4d6f-ba27-ad3821d8d533 none swap pri=1 0 0


Then in the terminal type:

sudo swapoff -a to disable swap drive.

sudo swapon -a to re-enable the swap drive.

sudo swapon -s to look at priority level. Where it was a 0 or negative number last time, it should read one now.

Now feel free to try suspend/hibernate and your computer should resume perfectly.

New Fix:

Kudos to the ATI devs for finally getting on top of this one. I downloaded the new ATI fglrx driver from the AMD website. Version 9.9 works perfectly. I can now suspend and resume just fine while leaving compiz enabled. I would still recommend following the instructions in this thread on how to set swap partition priority for hibernation purposes. I also made changes to my acpi-support file just in case. In /etc/default/acpi-support I changed SAVE_VBE_STATE=true to false. It works great. Best of luck

Last edited by defensorfedei; 10-14-2009 at 08:44 AM. Reason: New Fix Available
 
Old 10-13-2009, 03:14 AM   #6
business_kid
Guru
 
Registered: Jan 2006
Location: Ireland
Distribution: Slackware & Android
Posts: 6,268

Rep: Reputation: 540Reputation: 540Reputation: 540Reputation: 540Reputation: 540Reputation: 540
Now edit the original post and put 'solved' in the subject so people will check it for answers
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
ATI Rage 128 and suspend/resume jainraje Linux - General 0 08-05-2007 06:30 PM
Suspend-resume not working with ati or flgrx driver in Etch 1madstork Debian 2 06-11-2007 07:56 PM
Wifi card LED comes on after suspend/resume but not at boot? hollywoodb Linux - Hardware 3 04-18-2007 01:10 PM
Suspend/Resume using OpenSuse 10.0 and ATI (fglrx) jimisola Suse/Novell 0 08-03-2006 04:41 PM
pcmcia card freezes on suspend, and will not resume jdolluc Linux - Hardware 4 01-08-2004 05:16 PM


All times are GMT -5. The time now is 03:05 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration