LinuxQuestions.org
Visit the LQ Articles and Editorials section
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Laptop and Netbook
User Name
Password
Linux - Laptop and Netbook Having a problem installing or configuring Linux on your laptop? Need help running Linux on your netbook? This forum is for you. This forum is for any topics relating to Linux and either traditional laptops or netbooks (such as the Asus EEE PC, Everex CloudBook or MSI Wind).

Notices

Reply
 
Search this Thread
Old 11-07-2004, 05:15 PM   #1
isipe
LQ Newbie
 
Registered: Nov 2004
Posts: 1

Rep: Reputation: 0
Suse Install&ibm hidden partition recovery


I have installed Suse linux 9.1 on an IBM thinkpad R40 that had Win XP Pro preinstalled. Everything is fine (using the LILO), but a major problem is that I cannot access the ibm predesktop area any more. Pressing the Access IBM button just pops up a small blue window asking me whether I want to enter the Bios or boot from a device. It seems like the ibm hidden partition is erased. I should mention that I did not partition the disk before the Linux install, Linux just did this automatically for me during install. Using fdisk from a Shell does not appear any other partition than the Win Xp and the 2 linux (swap and root).
Please if anybody has a solution to this problem I would be very happy to know, because IBM did not ship any recovery cd, I should just use this partition that it seems to be lost..
 
Old 11-08-2004, 10:09 PM   #2
Glas
Member
 
Registered: Aug 2004
Location: Atlanta, GA
Distribution: Slackware, PC-BSD v0.6, FreeBSD v5.3
Posts: 82

Rep: Reputation: 15
I would use fdisk to determine whether or not the partition was removed. If you did a format of the HDD then yes the partition will be gone. Another way you can check is to go into the BIOS and then the security option. From there choose IBM Predesktop Area. Once in there go ahead and disable the partition so that it becomes unhidden from any OS there. If it is there you can then add it to LILO and boot to it. It uses Win98 to boot up into the Predesktop Area. If that does not work then the only way to get the OS back is to call into IBM and order a recovery CD unfortunately.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
can't install suse 9.3 on IBM ThinkPad 600E metallk Linux - Laptop and Netbook 1 09-17-2005 05:59 AM
Fedora IBM A21m Install - Experience & Questions Fattbizkit Fedora 0 03-05-2005 08:47 AM
IBM T22 & suSe Linux 9.2, Low Resoloution VilleViking Linux - Laptop and Netbook 1 11-19-2004 11:13 PM
IBM Recovery Program won't work fcnewbie Linux - Newbie 5 06-25-2004 08:47 PM
ibm t42 partition/slack 10 install AlteZza2k2 Slackware 1 06-25-2004 12:27 PM


All times are GMT -5. The time now is 08:50 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration