LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Laptop and Netbook
User Name
Password
Linux - Laptop and Netbook Having a problem installing or configuring Linux on your laptop? Need help running Linux on your netbook? This forum is for you. This forum is for any topics relating to Linux and either traditional laptops or netbooks (such as the Asus EEE PC, Everex CloudBook or MSI Wind).

Notices

Reply
 
Search this Thread
Old 11-18-2004, 11:12 AM   #1
BillRandolph
LQ Newbie
 
Registered: May 2004
Location: Austin, TX
Distribution: Mandrake 10
Posts: 10

Rep: Reputation: 0
Suse 9.2 runs in slow motion


I just installed Suse 9.2 on my laptop (Alienware Sentia, Celeron 2GHz, 1GHz RAM) in the hopes of getting better mobile support. I've been running Mandrake 10.0, which mostly works, but I thought I'd try Suse.

The install went OK, but when it rebooted into Linux, the text boot screen went painfully slowly. One...character...at...a...time. I had to leave it on all night just to boot!

Once it booted, it seemed to run, but also very slowly.

Anyone else had this problem? Is there a solution?

I had tried the Mandrake 10.1 beta, and it exhibited the same problem on this system. I chalked that up to it just being a beta; but now it looks like something Linux doesn't like in my system.
 
Old 11-18-2004, 11:37 AM   #2
MontrealGuy
LQ Newbie
 
Registered: Nov 2004
Posts: 1

Rep: Reputation: 0
I had similar problems on both a desktop machine (Athlon XP 3000 on GA 7N400Pro 2 board) and laptop (Dell X200). Both seem to improve when adding boot parameters "acpi=on apic" (where I believe the first parameter is actually the default - just making sure). Try simply adding these on the boot screen. If it works, modify /boot/grub/menu.lst .

I also experienced a LOT of problems with a runaway hotplug process that slowed the system down, after the boot process. Might want to check that too.
 
Old 11-18-2004, 12:00 PM   #3
BillRandolph
LQ Newbie
 
Registered: May 2004
Location: Austin, TX
Distribution: Mandrake 10
Posts: 10

Original Poster
Rep: Reputation: 0
Well, I tried this and that doesn't seem to have fixed it. The boot screen runs at normal speed up to this:

VFS: Mounted root (ext2 filesystem)
Starting udev
Creating devices


And then it appears to hang; however, if I give it long enough (like, I don't know, an hour?), it'll come back & resume booting in slow motion.
 
Old 12-06-2004, 03:23 AM   #4
wsaschakiss
LQ Newbie
 
Registered: Dec 2004
Location: Essen, Germany
Distribution: SuSE 9.1 & SuSE 9.2
Posts: 11

Rep: Reputation: 0
I have encountered exactly the same problem on a MaxData Vision 4200X Notebook on an Intel Pentium 4 Processor with Hyperthreadding.

I installed SuSE 9.2 and my computer runs in slow motion from the start it reaches the "Creating devices" entry during startup. I already tried many settings but in the end I guess it has something to do with special kernel modules.

Funnily when you boot SuSE 9.2 from a live CD on the same computer the problem does not occur, and SuSE 9.2 from the live CD uses the same kernel, but probably without optimizations for laptops...

Is there anybody who has the same probelm and could solve it?

Thx, Sascha.....*>

Last edited by wsaschakiss; 12-06-2004 at 07:56 AM.
 
Old 12-06-2004, 10:07 AM   #5
BillRandolph
LQ Newbie
 
Registered: May 2004
Location: Austin, TX
Distribution: Mandrake 10
Posts: 10

Original Poster
Rep: Reputation: 0
Since then, I've also tried Mandrake 10.1, which does the same thing. Mandrake 10.0 runs fine. Also, I've just tried Fedora Core 3, and it seems to exhibit this behavior in the installer. I would suspect that it's something in the kernel; but considering your note that the live CD doesn't do this, I'm not so sure.
 
Old 12-07-2004, 04:09 AM   #6
wsaschakiss
LQ Newbie
 
Registered: Dec 2004
Location: Essen, Germany
Distribution: SuSE 9.1 & SuSE 9.2
Posts: 11

Rep: Reputation: 0
I'm not an expert in these things but as I know SuSE installs an optimized kernel for notebooks. The kernel on the live cd is hence different than the kernel on my notebook.

If we knew which modules are responsible for creating devices, one could probably investigate and find out what's going wrong here.

Has anyone an idea?
 
Old 12-07-2004, 09:25 AM   #7
BillRandolph
LQ Newbie
 
Registered: May 2004
Location: Austin, TX
Distribution: Mandrake 10
Posts: 10

Original Poster
Rep: Reputation: 0
I have strong impression that it's related to udev, the replacement for devfs.

Mandrake 10.0 runs fine on my laptop (except for wireless, suspend, etc); the speed is just fine. However, the newer distros such as Mandrake 10.1, Fedora Core 3, and of course Suse 9.2, utilize udev instead of devfs.

The other reason I have this impression is that, while my Suse install is booting, it runs at full speed right until I see 'starting udev', followed by 'creating devices'; then, it runs very slowly.

I don't know a lot about udev, except that it's supposed to provide your system with better dynamic hardware detection (ie USB plugins, CDROMs, etc).

I may try to reinstall Mandrake 10.1, and select devfs instead of udev, if they still allow installation of it. Does Suse allow you to not install udev? I don't know if their package selection gives you such a fine level of control.
 
Old 12-07-2004, 01:10 PM   #8
wsaschakiss
LQ Newbie
 
Registered: Dec 2004
Location: Essen, Germany
Distribution: SuSE 9.1 & SuSE 9.2
Posts: 11

Rep: Reputation: 0
This is a very good point. I found out that you can compile the kernel with both options using devfs and udev. With the bootoption gentoo=noudev you then can let the kernel use devfs instead of udev. The following website has more information about that device thing http://webpages.charter.net/decibels....html#lilogrub.

Unfortunately I didn't have the time yet to try that out but next thing I'm gonna do is try out if the standard kernel of SuSE has devfs compiled and if not I will have to find out how to compile the kernel (I've never done that yet). And hopefully this will solve the problem.

Thanx for the hint and I will come back with my results :-)

Sascha.....*>
 
Old 12-07-2004, 02:58 PM   #9
BillRandolph
LQ Newbie
 
Registered: May 2004
Location: Austin, TX
Distribution: Mandrake 10
Posts: 10

Original Poster
Rep: Reputation: 0
Well, good news!

I've been working with Suse support on this, and they suggested that, since my laptop has 1 GB of RAM, that may be a problem. It has something to do with the cache size the motherboard supports, combined with the way Linux uses memory. The wrong kind of motherboard cache support can cause Linux to not have access to cache memory, causing it to run very slowly (or something like that).

Anyway, they suggested I enter this on the boot command line (added after the other boot params):

mem=512M

Sure enough, my system is now running very fast!

If your system has a lot of RAM, you should try this; let me know if it works.
 
Old 12-07-2004, 03:01 PM   #10
wsaschakiss
LQ Newbie
 
Registered: Dec 2004
Location: Essen, Germany
Distribution: SuSE 9.1 & SuSE 9.2
Posts: 11

Rep: Reputation: 0
This is really good news. In fact also my laptop has 1 GB of RAM. Funnily that this amount of memory causes such an obscure effect. I will try it tomorrow and let you know if the boot option helped. I'm quite sure it will...

Thx again for your support, Sascha.....*>
 
Old 12-07-2004, 06:24 PM   #11
beatupbilly
Member
 
Registered: Jan 2004
Location: Pinr Lake, GA
Distribution: Slackware, LinuxMint, FreeBSD, Xandros, CentOS, Fedora Core, RedHat, Chakra, etc etc
Posts: 215

Rep: Reputation: 30
my laptop has a usb 2.0 controller that causes the boot to hang at pcmcia. It is not compatable I've been told. Apparently Linux has very poor USB 2.0 support. If you have USB 2.0 on your machine this could be the case. Apparently it is because my card is 1.0, 1.1, 2.0 compatable and Linux doesn't know how to assign the proper resources. Something like that. Just my personal experience.
 
Old 12-08-2004, 03:40 AM   #12
wsaschakiss
LQ Newbie
 
Registered: Dec 2004
Location: Essen, Germany
Distribution: SuSE 9.1 & SuSE 9.2
Posts: 11

Rep: Reputation: 0
That's it! I entered the boot option mem=512M and then the system starts as normally as I would expect it to.

Thank you for your help!
 
Old 12-08-2004, 10:33 AM   #13
BillRandolph
LQ Newbie
 
Registered: May 2004
Location: Austin, TX
Distribution: Mandrake 10
Posts: 10

Original Poster
Rep: Reputation: 0
Another point I've found:

Entering this option will limit the amount of RAM available to Linux to 512MB. You can try a larget number, like

mem=768M

This will give Linux more memory. (Note that if you enter a larger number than you physically have memory for, Linux will crash.)

Also, I used my boot loader configuration to add this option permanently so I don't have to type it in every time.

Onward then!
 
Old 12-09-2004, 05:56 AM   #14
wsaschakiss
LQ Newbie
 
Registered: Dec 2004
Location: Essen, Germany
Distribution: SuSE 9.1 & SuSE 9.2
Posts: 11

Rep: Reputation: 0
Even mem=1008M works on my laptop, whereas mem=1016M causes the cache problem. But with nearly as much memory to use as installed I am also quite satisfied... :-)
 
Old 12-09-2004, 10:52 PM   #15
tvphil
Member
 
Registered: Aug 2004
Location: Evanston, Illinois, USA
Distribution: Xubuntu 11.10 Oneric Ocelot 64 bit
Posts: 58

Rep: Reputation: 16
I had a similar problem when I first installed suse 9.1 personal on my Gateway 500x Desktop. I use a router to supply the highspeed cable modem connection and so I thought I needed to configure NIS for connecting to the net the first time. Second time I installed, I just left the NIS config.box blank and let DHCP do all the work of setting up the network connection. It worked much faster the second time and in the process discovered it was no longer searching for YP Bind that didn't exist. What use to take 9 minutes to boot up, now boots in less than 1 minute. Everything else in the KDE desktop also work much faster as well. With your laptop, you may not need NIS/yp bind either. If so, you can disable it by using YaST and go to System then Runlevel Editor. At the bottom of choices, you will find the control for YP Bind. If it says yes, just change it to no. If for some reason that makes it worse, just go back the the runlevel editor and change it back to yes.

Last edited by tvphil; 12-09-2004 at 10:53 PM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
mplayer fullscreen plays like slow motion but shouldnt? dmx9595 Linux - Software 10 03-31-2007 08:50 AM
Speedtouch USB modem runs slow in SuSE 9.1 rutlandn Linux - Hardware 2 01-04-2005 02:31 PM
slow motion graphics on fedora m2azer Linux - Newbie 1 10-01-2004 12:07 AM
it runs so slow neverender Linux - General 1 01-14-2004 07:43 AM
Convert video to slow motion Wynd Linux - General 2 12-08-2003 02:37 PM


All times are GMT -5. The time now is 04:05 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration