LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Laptop and Netbook
User Name
Password
Linux - Laptop and Netbook Having a problem installing or configuring Linux on your laptop? Need help running Linux on your netbook? This forum is for you. This forum is for any topics relating to Linux and either traditional laptops or netbooks (such as the Asus EEE PC, Everex CloudBook or MSI Wind).

Notices

Reply
 
Search this Thread
Old 10-31-2013, 08:46 PM   #31
Optiker
Member
 
Registered: Nov 2005
Distribution: Mint 14 Nadia
Posts: 189

Original Poster
Rep: Reputation: 21

aus9...
Quote:
Originally Posted by aus9 View Post
alsa-lib confirmed at distrowatch for mint is 1.0.25
I guess I don't know why you are telling me this...do I need to do anything because of it?

Are you suggesting that I change to a different distro? I so, I won't do anything until I return home.

Sounds like this is winding down without a solution. If it hadn't been working fine under Windows Vista, I'd question my hardware.

Thanks!
Optiker
 
Old 11-01-2013, 05:05 AM   #32
aus9
Guru
 
Registered: Oct 2003
Posts: 5,060

Rep: Reputation: Disabled
no it just meant I did not check distro watch to see what version you could get out of mint

no problem with you arriving home, but as sound is important I am suggesting there are lots of newbie friendly distros
with more up to date alsa than mint.

2) we can wind it back up by you agreeing to try pulseaudio if you like?

Code:
sudo apt-get update
sudo apt-get install pulseaudio paman pavucontrol pavumeter paprefs
pavucontrol is a graphical panel that offers ways of selecting different sound devices ---on-the-fly
different sound outputs
 
Old 11-01-2013, 05:36 AM   #33
Shadow_7
Senior Member
 
Registered: Feb 2003
Distribution: debian
Posts: 1,554

Rep: Reputation: 239Reputation: 239Reputation: 239
It looks like you're running kde and are using pulseaudio. You also have a lot of "extras" running that you are probably not using. Samba, ssh, and stuff. Kde has been rummored to have gotten a lot better, but if you're on an older machine with say 0.5GB of ram, you're probably asking too much of it with that setup in my opinion. If you're testing your sound with the browser, you might try starting the browser from the command line and prefix it with padsp.

$ padsp firefox

It's been a while since I've used kde and naming conventions might have changed. But there used to be a Kontrol thing under the start button from system stuff. Kind of like windows control panel (whatever that is). From it you can select which sound configuration to use. You appear to be using pulseaudio, but kde might default to using alsa. Set it to pulseaudio if you find it and it's not that already.

Since you appear to be using pulseaudio, try it's configuration tool. Pulseaudio tends to setup dummy devices and when it gets confused it sets them as the default outputs. Even though it may also list your actual device and it's abilities.

$ pavucontrol
 
Old 11-01-2013, 07:53 AM   #34
Optiker
Member
 
Registered: Nov 2005
Distribution: Mint 14 Nadia
Posts: 189

Original Poster
Rep: Reputation: 21
Good morning aus9...
Quote:
Originally Posted by aus9 View Post
...as sound is important I am suggesting there are lots of newbie friendly distros
with more up to date alsa than mint.
I will DL one of the iso files and burn to try live...will that do? I also have an iso burned at home for the latest (if recall) Ubuntu because having used Kubuntu for a while, I wanted to try Ubuntu and see if it improved anything. I will try that first, then one of the others. I went with Mint because it claims to be newbie friendly, and also because it is currently the most popular distro, so perhaps was getting the most forum attention at the newbie level.
Quote:
Originally Posted by aus9 View Post
2) we can wind it back up by you agreeing to try pulseaudio if you like?
In one of my earlier threads - don't recall if here or elsewhere - I was looking for a way to get more volume as even at full volume (and distortion), sometimes there wasn't enough volume. Somebody suggested pulseaudio, so I don't recall if it was already installed, or if I installed it, but it is now installed. Don't know how it works with all of the rest of what's running, but when I launch it, it helps the volume but I can't recall if I tried it after the no speaker sound problem started or not. I do recall that with the headphones, at least, there was still distortion unless I lowered volume to where it was marginally acceptable.
Quote:
Originally Posted by aus9 View Post
Code:
sudo apt-get update
sudo apt-get install pulseaudio paman pavucontrol pavumeter paprefs
pavucontrol is a graphical panel that offers ways of selecting different sound devices ---on-the-fly
different sound outputs
I have now installed those packages in your list that weren't already installed.

What do I do now - anything other than launch it and play with settings? If it works, does it launch on boot or do I have to manually launch it each time? How does it work with all of the other stuff (alsa, kmix, etc.)?

Am I asking the right questions?

Thanks!
Optiker
 
Old 11-01-2013, 08:11 AM   #35
Optiker
Member
 
Registered: Nov 2005
Distribution: Mint 14 Nadia
Posts: 189

Original Poster
Rep: Reputation: 21
Good morning Shadow...
Quote:
Originally Posted by Shadow_7 View Post
It looks like you're running kde and are using pulseaudio. You also have a lot of "extras" running that you are probably not using. Samba, ssh, and stuff. Kde has been rummored to have gotten a lot better, but if you're on an older machine with say 0.5GB of ram, you're probably asking too much of it with that setup in my opinion. If you're testing your sound with the browser, you might try starting the browser from the command line and prefix it with padsp.

$ padsp firefox
Actually, I've tested with both Firefox and an MP3 running mostly VLC, but also Amarok. For this thread, mostly MP3 on VLC.
Quote:
Originally Posted by Shadow_7 View Post
It's been a while since I've used kde and naming conventions might have changed. But there used to be a Kontrol thing under the start button from system stuff. Kind of like windows control panel (whatever that is). From it you can select which sound configuration to use. You appear to be using pulseaudio, but kde might default to using alsa. Set it to pulseaudio if you find it and it's not that already.
Yes, it's under system settings/hardware/multimedia/phonon. With headphones disconnected, everything is set to the sound card as built-in digital audio stereo (IEC958).
Quote:
Originally Posted by Shadow_7 View Post
Since you appear to be using pulseaudio, try it's configuration tool. Pulseaudio tends to setup dummy devices and when it gets confused it sets them as the default outputs. Even though it may also list your actual device and it's abilities.

$ pavucontrol
OK...it is installed. When I run it, it shows the same built-in digital audio stereo (IEC958), and the port shown as Digital Output (S/PDIF). That's the only output device - headphones disconnected. Configuration tab shows output profile as digital stereo (IEC958) output + analog stereo output.

Now what?

Thanks!
Optiker
 
Old 11-01-2013, 08:34 AM   #36
aus9
Guru
 
Registered: Oct 2003
Posts: 5,060

Rep: Reputation: Disabled
HUH?

when you run pavucontrol, you are saying you can only see see IEC958 which is the same as SPDIF?

might be better if you run and post the results of
Code:
pulseaudio -vvv
first

and I disagree that pulseaudio was running before. If it was running before the OP would only see one slider in alsamixer

Optiker
while you have PA running might be good to confirm that alsamixer only shows pulse and the its one slider.

2) there are a bucket of graphical tools for PA so no more terminal stuff for alsamixer but lets see what your results are first eh?
speaking of which are you using the modprobe line now or not?
--not a problem if you aren't as it did not solve your issue
 
Old 11-01-2013, 12:28 PM   #37
Optiker
Member
 
Registered: Nov 2005
Distribution: Mint 14 Nadia
Posts: 189

Original Poster
Rep: Reputation: 21
aus8...
Quote:
Originally Posted by aus9 View Post
HUH?

when you run pavucontrol, you are saying you can only see see IEC958 which is the same as SPDIF?
Yes.
Quote:
Originally Posted by aus9 View Post
might be better if you run and post the results of
Code:
pulseaudio -vvv
first
=====================
pulseaudio -vvv
I: [pulseaudio] main.c: setrlimit(RLIMIT_NICE, (31, 31)) failed: Operation not permitted
I: [pulseaudio] main.c: setrlimit(RLIMIT_RTPRIO, (9, 9)) failed: Operation not permitted
D: [pulseaudio] core-rtclock.c: Timer slack is set to 50 us.
I: [pulseaudio] core-util.c: Failed to acquire high-priority scheduling: Permission denied
I: [pulseaudio] main.c: This is PulseAudio 2.1
D: [pulseaudio] main.c: Compilation host: i686-pc-linux-gnu
D: [pulseaudio] main.c: Compilation CFLAGS: -g -O2 -fstack-protector --param=ssp-buffer-size=4 -Wformat -Werror=format-security -Wall -W -Wextra -pipe -Wno-long-long -Wvla -Wno-overlength-strings -Wunsafe-loop-optimizations -Wundef -Wformat=2 -Wlogical-op -Wsign-compare -Wformat-security -Wmissing-include-dirs -Wformat-nonliteral -Wpointer-arith -Winit-self -Wdeclaration-after-statement -Wfloat-equal -Wmissing-prototypes -Wredundant-decls -Wmissing-declarations -Wmissing-noreturn -Wshadow -Wendif-labels -Wcast-align -Wstrict-aliasing -Wwrite-strings -Wno-unused-parameter -ffast-math -Wp,-D_FORTIFY_SOURCE=2 -fno-common -fdiagnostics-show-option
D: [pulseaudio] main.c: Running on host: Linux i686 3.5.0-17-generic #28-Ubuntu SMP Tue Oct 9 19:32:08 UTC 2012
D: [pulseaudio] main.c: Found 2 CPUs.
I: [pulseaudio] main.c: Page size is 4096 bytes
D: [pulseaudio] main.c: Compiled with Valgrind support: no
D: [pulseaudio] main.c: Running in valgrind mode: no
D: [pulseaudio] main.c: Running in VM: no
D: [pulseaudio] main.c: Optimized build: yes
D: [pulseaudio] main.c: FASTPATH defined, only fast path asserts disabled.
I: [pulseaudio] main.c: Machine ID is 2181079223ea3bea010c42915110107e.
I: [pulseaudio] main.c: Session ID is 2181079223ea3bea010c42915110107e-1383251082.235526-668079091.
I: [pulseaudio] main.c: Using runtime directory /home/crlinux/.pulse/2181079223ea3bea010c42915110107e-runtime.
I: [pulseaudio] main.c: Using state directory /home/crlinux/.pulse.
I: [pulseaudio] main.c: Using modules directory /usr/lib/pulse-2.1/modules.
I: [pulseaudio] main.c: Running in system mode: no
E: [pulseaudio] pid.c: Daemon already running.
E: [pulseaudio] main.c: pa_pid_file_create() failed.
=======================
Quote:
Originally Posted by aus9 View Post
and I disagree that pulseaudio was running before. If it was running before the OP would only see one slider in alsamixer

Optiker
while you have PA running might be good to confirm that alsamixer only shows pulse and the its one slider.
Confirmed...pa Volume Control running - only output device shown is Built-in Audio Digital Stereo (S/PDIF. Only Port shown is Digital Output (S/PDIF). Of the five check boxes, only PCM is checked and grayed out. dts, ac3, mpeG and EAC3 not grayed out and not checked. This is all on the Output Devices tab of PulseAudio Volume Control.

The following are the settings of the AlsaMixer in the terminal display, v1.0.25
Card: HDA Intel
Chip: SigmaTel STAC9200

On the ALL display, there are eight sliders, and on the playback display, only the first five. These are the slider settings for all seven:

At the same time, alsamixer graphical display in terminal shows 5 sliders with the following settings in the format name/muted or unmuted/level: Master/unmuted/79; PCH/unmuted/79<>79; LFE/unmuted/75; S/PDIF/unmuted/no level shown (up-down cursors show no effect; S/PDIF Default/muted/ no level shown as with S/PDIF.

In addition, there are three other sliders: Capture/no mute effect/27<>27; Digital/no mute effect/24<>24; Hux/no mute effect/0<>0.
Quote:
Originally Posted by aus9 View Post
2) there are a bucket of graphical tools for PA so no more terminal stuff for alsamixer but lets see what your results are first eh?
speaking of which are you using the modprobe line now or not?
--not a problem if you aren't as it did not solve your issue
No...removed it per your instructions.

Thanks!
Optiker
 
Old 11-01-2013, 07:18 PM   #38
aus9
Guru
 
Registered: Oct 2003
Posts: 5,060

Rep: Reputation: Disabled
Ok sorry for disturbance

I would like you to stay with pulseaudio a bit longer

1) re-insert the "options line" to your modprobe.d file pls and do a full reboot after (2)

2) my bad I forgot vlc needs extra files
Code:
sudo apt-get update
apt-get install vlc-plugin-pulse vlc-plugin-jack browser-plugin-vlc phonon-backend-vlc
some of these would have impacted on a true test of vlc playback function
---once installed phonon and the vlc-plugin "should" now allow correct playback when you go back into vlc options
-------as already described.

3) so now after full reboot, vlc re-configured see if you can play sounds nicely with vlc?

4) now it may be that you need to run pavucontrol and in the last tab
pull down and see how many options are in that pulldown
we know SPDIF is there, but I am hoping analog is now there

can you take a screen shot?

I use mtpaint----with a zero fancy modinfo line no model=string
pulldown file -> time delayed screenshot
minimise mtpaint
hover into pavucontrol

http://oi41.tinypic.com/2pyu9dv.jpg

5) I may be reading your comments wrong
but if PA is in control
this is the image you should get and not an image of spdif

http://oi42.tinypic.com/2qjzl3d.jpg

Last edited by aus9; 11-01-2013 at 07:45 PM.
 
Old 11-01-2013, 08:09 PM   #39
Optiker
Member
 
Registered: Nov 2005
Distribution: Mint 14 Nadia
Posts: 189

Original Poster
Rep: Reputation: 21
aus9
Quote:
Originally Posted by aus9 View Post
Ok sorry for disturbance

I would like you to stay with pulseaudio a bit longer

1) re-insert the "options line" to your modprobe.d file pls and do a full reboot after (2)

2) my bad I forgot vlc needs extra files
Code:
sudo apt-get update
apt-get install vlc-plugin-pulse vlc-plugin-jack browser-plugin-vlc phonon-backend-vlc
some of these would have impacted on a true test of vlc playback function
---once installed phonon and the vlc-plugin "should" now allow correct playback when you go back into vlc options
-------as already described.

3) so now after full reboot, vlc re-configured see if you can play sounds nicely with vlc?
No change.
Quote:
Originally Posted by aus9 View Post
4) now it may be that you need to run pavucontrol and in the last tab
pull down and see how many options are in that pulldown
we know SPDIF is there, but I am hoping analog is now there

can you take a screen shot?
posted
Quote:
Originally Posted by aus9 View Post
5) I may be reading your comments wrong
but if PA is in control
this is the image you should get and not an image of spdif

http://oi42.tinypic.com/2qjzl3d.jpg
alsamixer same as before - no change.

Thanks!
Optiker
Attached Images
File Type: jpeg pavucontrol snap.jpeg (20.9 KB, 5 views)
 
Old 11-01-2013, 09:34 PM   #40
aus9
Guru
 
Registered: Oct 2003
Posts: 5,060

Rep: Reputation: Disabled
Hi

edit while you are gone

your image shows you can move away from SPDIF

just to refresh, your speaker output needs analog not spdif

so pls choose analog stereo output and tell us what happens to speaker sound pls

Last edited by aus9; 11-01-2013 at 09:41 PM.
 
Old 11-01-2013, 09:37 PM   #41
aus9
Guru
 
Registered: Oct 2003
Posts: 5,060

Rep: Reputation: Disabled
sorry I could see you were viewing this post as I was typing

can you confirm that alsamixer is showing only pulseaudio and not spdif
---I am still not sure we are on the same page
 
Old 11-01-2013, 09:57 PM   #42
aus9
Guru
 
Registered: Oct 2003
Posts: 5,060

Rep: Reputation: Disabled
Ok I reviewed my reply (8) and I think its wrong oops

when you get home, use pavucontrol to select either the third or fourth item

I can see you have selected the third item for digital and analog but we know you are not getting speaker sound
and your alsamixer for the actual card shows they are not muted and volumes raised for analog
---but your spdif may be muted at the moment?

so for the moment, pls choose first the first item in pavucontrol -config tab
check your volumes are not muted and are high by running alsamixer -c0

then try again for pavucontrol - config tab but select the second item
and recheck alsamixer?

good luck

EDIT
that also means I need to review your reply (4) ON the tv cables
an image of this 10 pin connector might be handy or as you are away
an image of the 10 pin hole

I was wrong to assume its a DIN without getting confirmation

Last edited by aus9; 11-01-2013 at 10:25 PM.
 
Old 11-02-2013, 04:44 AM   #43
aus9
Guru
 
Registered: Oct 2003
Posts: 5,060

Rep: Reputation: Disabled
yep I think I am wrong to think DIN
ftp://ftp.dell.com/Manuals/all-produ...nual_en-us.pdf

page 23 number 2 is the S video TV out connector----appears to be 9 pins not 10

other candidates are number 7 DVI (video ) aka dvi-d about 24 pins

number 8 vga 15 pins

######
page 41 claims
press the Function key and the End key to mute or unmute the speakers

gosh

press the fn key and page up to increase volume might work?


############
so back to tv, page 57 onwards you have already worked out that you need to enable
DIGITAL SPDIF
and not analog SPDIF

but with PA you can now do that on the fly

good luck

Last edited by aus9; 11-02-2013 at 04:49 AM.
 
Old 11-02-2013, 07:45 AM   #44
Optiker
Member
 
Registered: Nov 2005
Distribution: Mint 14 Nadia
Posts: 189

Original Poster
Rep: Reputation: 21
aus9
Quote:
Originally Posted by aus9 View Post
Hi

edit while you are gone

your image shows you can move away from SPDIF

just to refresh, your speaker output needs analog not spdif

so pls choose analog stereo output and tell us what happens to speaker sound pls
OK...it works!

Speaker sound is working, and plugging in headphones also working. The whole house is sleeping, so I won't check distortion until later today, but even with distortion, this at least gets me back to where I was before I lost sound from the speakers. Not knowing what I was doing, at some point fumbling around trying to find a way to get rid of the distortion, I must have thought that the digital plus stereo would be best because it covers both.

I didn't even know what S/PDIF means, so checked Wikipedia and now understand it a little better. That's why I've been so timid about doing some of the stuff y'all have suggested...not understanding it enough to act intelligently!

Thanks! A huge step forward. I'll read your other two new replies, but may not act on them and reply till later.
Optiker
 
Old 11-02-2013, 07:48 AM   #45
Optiker
Member
 
Registered: Nov 2005
Distribution: Mint 14 Nadia
Posts: 189

Original Poster
Rep: Reputation: 21
Quote:
Originally Posted by aus9 View Post
sorry I could see you were viewing this post as I was typing

can you confirm that alsamixer is showing only pulseaudio and not spdif
---I am still not sure we are on the same page
S/PDIF sliders both there but shown as OFF
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
No sound on speakers, sound on headphones and no system sounds EricTRA Linux Mint 2 10-12-2010 11:39 AM
Sound: how to switch from headphones to speakers? FreakboY Slackware 1 11-28-2007 01:59 AM
Sound from speakers not from headphones crimsontide Linux - Hardware 2 12-21-2006 09:55 AM
no sound in speakers, sound in headphones sduvally Linux - Newbie 4 07-31-2004 11:57 AM
Can get sound from laptop speakers but not from headphones thetremorchrist Linux - Hardware 4 02-14-2004 04:43 AM


All times are GMT -5. The time now is 12:39 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration