LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Laptop and Netbook
User Name
Password
Linux - Laptop and Netbook Having a problem installing or configuring Linux on your laptop? Need help running Linux on your netbook? This forum is for you. This forum is for any topics relating to Linux and either traditional laptops or netbooks (such as the Asus EEE PC, Everex CloudBook or MSI Wind).

Notices

Reply
 
Search this Thread
Old 12-13-2009, 02:13 AM   #1
shva
Member
 
Registered: Feb 2009
Distribution: Fedora, Arch, Debian, Ubuntu
Posts: 56

Rep: Reputation: 15
Sound not working in Debian Lenny


I first configure the sound card by alsaconf and get a successful result, and then adjust the master level in alsamixer to make sure it is on. But still when I play a audio file there is no sound. Do I miss something? This is the info from lspci | grep audio :

Multimedia audio controller: Intel Corporation 82801DB/DBL/DBM (ICH4/ICH4-L/ICH4-M) AC'97 Audio Controller (rev 03)

Thanks!
 
Old 12-13-2009, 01:13 PM   #2
worm5252
Member
 
Registered: Oct 2004
Location: Atlanta
Distribution: CentOS, RHEL, HP-UX
Posts: 565

Rep: Reputation: 57
Can you please post the output of of the following files:

/dev/sndstat
/proc/asound/cards

I would also recommend running "speaker-test" without the quotes to test with. You could also try using "aplay <sourcefile.wav>" without the quotes to test your sound.
 
Old 12-13-2009, 01:45 PM   #3
shva
Member
 
Registered: Feb 2009
Distribution: Fedora, Arch, Debian, Ubuntu
Posts: 56

Original Poster
Rep: Reputation: 15
Quote:
Originally Posted by worm5252 View Post
Can you please post the output of of the following files:

/dev/sndstat
/proc/asound/cards

I would also recommend running "speaker-test" without the quotes to test with. You could also try using "aplay <sourcefile.wav>" without the quotes to test your sound.

Thanks for your reply.

This is the output of /dev/sndstat

Code:
Sound Driver:3.8.1a-980706 (ALSA v1.0.16 emulation code)
Kernel: Linux RedLily 2.6.26-2-686 #1 SMP Wed Nov 4 20:45:37 UTC 2009 i686
Config options: 0

Installed drivers: 
Type 10: ALSA emulation

Card config: 
Intel 82801DB-ICH4 with STAC9752,53 at irq 10
Intel 82801DB-ICH4 Modem at irq 10

Audio devices:
0: Intel 82801DB-ICH4 (DUPLEX)
1: Intel 82801DB-ICH4 Modem - Modem (DUPLEX)

Synth devices: NOT ENABLED IN CONFIG

Midi devices: NOT ENABLED IN CONFIG

Timers:
7: system timer

Mixers:
0: SigmaTel STAC9752,53
1: Silicon Laboratory Si3036,8 rev
and this is output of /proc/asound/cards
Code:
0 [I82801DBICH4   ]: ICH4 - Intel 82801DB-ICH4
                      Intel 82801DB-ICH4 with STAC9752,53 at irq 10
 1 [Modem          ]: ICH-MODEM - Intel 82801DB-ICH4 Modem
                      Intel 82801DB-ICH4 Modem at irq 10
I tried speaker-test, but it did not give any sound, and aplay did not play wav file either.
 
Old 12-13-2009, 04:09 PM   #4
worm5252
Member
 
Registered: Oct 2004
Location: Atlanta
Distribution: CentOS, RHEL, HP-UX
Posts: 565

Rep: Reputation: 57
OK few things. The hardware is detected. That's good. Sound is not played, that is still bad. First thig that comes to mind is, is there a hardware mute button?

You can also try this just to make sure the Master channel is un-muted.
Code:
amixer -c 0 --sset Master unmute
You may also want to make sure you are controlling the Sigmatel device and not the Modem device in your mixer. I am not sure which mixer you are using.

Last edited by worm5252; 12-13-2009 at 04:09 PM. Reason: Wrong command in the code box. Had to fix it.
 
Old 12-13-2009, 04:24 PM   #5
shva
Member
 
Registered: Feb 2009
Distribution: Fedora, Arch, Debian, Ubuntu
Posts: 56

Original Poster
Rep: Reputation: 15
Quote:
Originally Posted by worm5252 View Post
OK few things. The hardware is detected. That's good. Sound is not played, that is still bad. First thig that comes to mind is, is there a hardware mute button?

You can also try this just to make sure the Master channel is un-muted.
Code:
amixer -c 0 --sset Master unmute
You may also want to make sure you are controlling the Sigmatel device and not the Modem device in your mixer. I am not sure which mixer you are using.

The Master channel is unmuted, but there is no sound. How can I see which mixer I am using?
 
Old 12-13-2009, 04:35 PM   #6
worm5252
Member
 
Registered: Oct 2004
Location: Atlanta
Distribution: CentOS, RHEL, HP-UX
Posts: 565

Rep: Reputation: 57
It depends on which mixer software you are using. For example I use Kmix since I use KDE. I can right click the speaker icon next to my clock and select "select master Channel". At the top of the window it will show me current active mixer HDA ATI SB. That is my on board sound card.

If you open your Mixer Window you should have a "help" menu with an "About" option. This will help you identify which mixer you are using.
 
Old 12-13-2009, 04:38 PM   #7
shva
Member
 
Registered: Feb 2009
Distribution: Fedora, Arch, Debian, Ubuntu
Posts: 56

Original Poster
Rep: Reputation: 15
I can see from alsamixer that I am using SigmaTel

Code:
Card: Intel 82801DB-ICH4 
Chip: SigmaTel STAC9752,53
Hmmm..... still don't know why it doesn't work.
 
Old 12-13-2009, 04:46 PM   #8
worm5252
Member
 
Registered: Oct 2004
Location: Atlanta
Distribution: CentOS, RHEL, HP-UX
Posts: 565

Rep: Reputation: 57
Try installing alsa-utils and alsa-base and rebooting.
 
Old 12-13-2009, 04:48 PM   #9
shva
Member
 
Registered: Feb 2009
Distribution: Fedora, Arch, Debian, Ubuntu
Posts: 56

Original Poster
Rep: Reputation: 15
They are already installed and I have rebooted for several times to test it. Unfortunately it still does not work.
 
Old 12-13-2009, 05:02 PM   #10
worm5252
Member
 
Registered: Oct 2004
Location: Atlanta
Distribution: CentOS, RHEL, HP-UX
Posts: 565

Rep: Reputation: 57
hmmm...i dont know what to do other than removing alsa, pulse, jack, or any other audio systems installed using apt-get remove --purge <package> and then reinstall alsa.
 
Old 12-13-2009, 05:14 PM   #11
shva
Member
 
Registered: Feb 2009
Distribution: Fedora, Arch, Debian, Ubuntu
Posts: 56

Original Poster
Rep: Reputation: 15
I check the alsaconf , and in its output:

Code:
Unloading ALSA sound driver modules: (none loaded).
Building card database...


Loading driver...
Setting default volumes...
amixer: Mixer attach default error: No such file or directory


===============================================================================

 Now ALSA is ready to use.
 For adjustment of volumes, use your favorite mixer.

 Have a lot of fun!
It says "amixer: Mixer attach default error: No such file or directory". Does that have something to do with that error?

Last edited by shva; 12-13-2009 at 05:15 PM.
 
Old 12-13-2009, 05:34 PM   #12
shva
Member
 
Registered: Feb 2009
Distribution: Fedora, Arch, Debian, Ubuntu
Posts: 56

Original Poster
Rep: Reputation: 15
Never mind. Just let it be there for some time. Thank you very much for your help
 
Old 12-13-2009, 05:41 PM   #13
worm5252
Member
 
Registered: Oct 2004
Location: Atlanta
Distribution: CentOS, RHEL, HP-UX
Posts: 565

Rep: Reputation: 57
I googled a bit, I found this on the dreamlinux forums.

Quote:
Ok, this error pops up on practically every forum for every distro I have used.

One of the main causes is that the user isn't added to the audio group.

So try to add yourself to the group "audio" as root:
Code:
su
gpasswd -a USERNAME audio
Now logout and then log in again so that the groups reload.
 
  


Reply

Tags
audio, debian


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] HP Scanjet 4400c not working, Debian Lenny mike11 Linux - Hardware 5 08-02-2009 11:51 PM
no video or sound on debian lenny biharibong Debian 6 02-23-2009 07:17 PM
LXer: Fixing sound in Debian Lenny for PCs with ESS Allegro/Maestro3 sound chips.. LXer Syndicated Linux News 0 04-17-2008 03:00 AM
LXer: Fixing sound in Debian Lenny for PCs with ESS Allegro/Maestro3 sound chips.. LXer Syndicated Linux News 0 04-17-2008 02:20 AM
no sound debian lenny/xfce arkadig Linux - Hardware 3 03-28-2008 08:37 AM


All times are GMT -5. The time now is 12:24 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration