LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Laptop and Netbook (http://www.linuxquestions.org/questions/linux-laptop-and-netbook-25/)
-   -   Sound not working in Debian Lenny (http://www.linuxquestions.org/questions/linux-laptop-and-netbook-25/sound-not-working-in-debian-lenny-775278/)

shva 12-13-2009 02:13 AM

Sound not working in Debian Lenny
 
I first configure the sound card by alsaconf and get a successful result, and then adjust the master level in alsamixer to make sure it is on. But still when I play a audio file there is no sound. Do I miss something? This is the info from lspci | grep audio :

Multimedia audio controller: Intel Corporation 82801DB/DBL/DBM (ICH4/ICH4-L/ICH4-M) AC'97 Audio Controller (rev 03)

Thanks!

worm5252 12-13-2009 01:13 PM

Can you please post the output of of the following files:

/dev/sndstat
/proc/asound/cards

I would also recommend running "speaker-test" without the quotes to test with. You could also try using "aplay <sourcefile.wav>" without the quotes to test your sound.

shva 12-13-2009 01:45 PM

Quote:

Originally Posted by worm5252 (Post 3789901)
Can you please post the output of of the following files:

/dev/sndstat
/proc/asound/cards

I would also recommend running "speaker-test" without the quotes to test with. You could also try using "aplay <sourcefile.wav>" without the quotes to test your sound.


Thanks for your reply.

This is the output of /dev/sndstat

Code:

Sound Driver:3.8.1a-980706 (ALSA v1.0.16 emulation code)
Kernel: Linux RedLily 2.6.26-2-686 #1 SMP Wed Nov 4 20:45:37 UTC 2009 i686
Config options: 0

Installed drivers:
Type 10: ALSA emulation

Card config:
Intel 82801DB-ICH4 with STAC9752,53 at irq 10
Intel 82801DB-ICH4 Modem at irq 10

Audio devices:
0: Intel 82801DB-ICH4 (DUPLEX)
1: Intel 82801DB-ICH4 Modem - Modem (DUPLEX)

Synth devices: NOT ENABLED IN CONFIG

Midi devices: NOT ENABLED IN CONFIG

Timers:
7: system timer

Mixers:
0: SigmaTel STAC9752,53
1: Silicon Laboratory Si3036,8 rev

and this is output of /proc/asound/cards
Code:

0 [I82801DBICH4  ]: ICH4 - Intel 82801DB-ICH4
                      Intel 82801DB-ICH4 with STAC9752,53 at irq 10
 1 [Modem          ]: ICH-MODEM - Intel 82801DB-ICH4 Modem
                      Intel 82801DB-ICH4 Modem at irq 10

I tried speaker-test, but it did not give any sound, and aplay did not play wav file either.

worm5252 12-13-2009 04:09 PM

OK few things. The hardware is detected. That's good. Sound is not played, that is still bad. First thig that comes to mind is, is there a hardware mute button?

You can also try this just to make sure the Master channel is un-muted.
Code:

amixer -c 0 --sset Master unmute
You may also want to make sure you are controlling the Sigmatel device and not the Modem device in your mixer. I am not sure which mixer you are using.

shva 12-13-2009 04:24 PM

Quote:

Originally Posted by worm5252 (Post 3790085)
OK few things. The hardware is detected. That's good. Sound is not played, that is still bad. First thig that comes to mind is, is there a hardware mute button?

You can also try this just to make sure the Master channel is un-muted.
Code:

amixer -c 0 --sset Master unmute
You may also want to make sure you are controlling the Sigmatel device and not the Modem device in your mixer. I am not sure which mixer you are using.


The Master channel is unmuted, but there is no sound. How can I see which mixer I am using?

worm5252 12-13-2009 04:35 PM

It depends on which mixer software you are using. For example I use Kmix since I use KDE. I can right click the speaker icon next to my clock and select "select master Channel". At the top of the window it will show me current active mixer HDA ATI SB. That is my on board sound card.

If you open your Mixer Window you should have a "help" menu with an "About" option. This will help you identify which mixer you are using.

shva 12-13-2009 04:38 PM

I can see from alsamixer that I am using SigmaTel

Code:

Card: Intel 82801DB-ICH4
Chip: SigmaTel STAC9752,53

Hmmm..... still don't know why it doesn't work.

worm5252 12-13-2009 04:46 PM

Try installing alsa-utils and alsa-base and rebooting.

shva 12-13-2009 04:48 PM

They are already installed and I have rebooted for several times to test it. Unfortunately it still does not work.

worm5252 12-13-2009 05:02 PM

hmmm...i dont know what to do other than removing alsa, pulse, jack, or any other audio systems installed using apt-get remove --purge <package> and then reinstall alsa.

shva 12-13-2009 05:14 PM

I check the alsaconf , and in its output:

Code:

Unloading ALSA sound driver modules: (none loaded).
Building card database...


Loading driver...
Setting default volumes...
amixer: Mixer attach default error: No such file or directory


===============================================================================

 Now ALSA is ready to use.
 For adjustment of volumes, use your favorite mixer.

 Have a lot of fun!

It says "amixer: Mixer attach default error: No such file or directory". Does that have something to do with that error?

shva 12-13-2009 05:34 PM

Never mind. Just let it be there for some time. Thank you very much for your help:)

worm5252 12-13-2009 05:41 PM

I googled a bit, I found this on the dreamlinux forums.

Quote:

Ok, this error pops up on practically every forum for every distro I have used.

One of the main causes is that the user isn't added to the audio group.

So try to add yourself to the group "audio" as root:
Code:

su
gpasswd -a USERNAME audio

Now logout and then log in again so that the groups reload.


All times are GMT -5. The time now is 10:37 PM.