LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Laptop and Netbook (http://www.linuxquestions.org/questions/linux-laptop-and-netbook-25/)
-   -   Sound No Longer Working when Upgrading to Ubuntu 9.10... (http://www.linuxquestions.org/questions/linux-laptop-and-netbook-25/sound-no-longer-working-when-upgrading-to-ubuntu-9-10-a-781066/)

rtoney5 01-09-2010 10:46 AM

Sound No Longer Working when Upgrading to Ubuntu 9.10...
 
Hello:
Not sure why, but my sound is no longer working when I upgraded from Ubuntu 9.04 to 9.10. I tried installing ubuntu-restricted-extras and that didn't work. Pasted below is my lspci.
Thanks,

$ lspci | grep Audio
00:07.0 Audio device: nVidia Corporation MCP72XE/MCP72P/MCP78U/MCP78S High Definition Audio (rev a1)

amani 01-09-2010 12:07 PM

$sudo lspci -v

Post relevant part

Also you may be having some other audio devices and may need to select the correct one.

rtoney5 01-10-2010 11:28 AM

Ok Thanks. Here's the -v...: (I also put my /proc/cpuinfo below as well)

00:07.0 Audio device: nVidia Corporation MCP72XE/MCP72P/MCP78U/MCP78S High Definition Audio (rev a1)
Subsystem: Hewlett-Packard Company Device 360a
Flags: bus master, 66MHz, fast devsel, latency 0, IRQ 19
Memory at c0000000 (32-bit, non-prefetchable) [size=16K]
Capabilities: <access denied>
Kernel driver in use: HDA Intel
Kernel modules: snd-hda-intel

========
cat /proc/cpuinfo
processor : 0
vendor_id : AuthenticAMD
cpu family : 17
model : 3
model name : AMD Athlon Dual-Core QL-62
stepping : 1
cpu MHz : 1000.000
cache size : 512 KB
physical id : 0
siblings : 2
core id : 0
cpu cores : 2
apicid : 0
initial apicid : 0
fdiv_bug : no
hlt_bug : no
f00f_bug : no
coma_bug : no
fpu : yes
fpu_exception : yes
cpuid level : 1
wp : yes
flags : fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush mmx fxsr sse sse2 ht syscall nx mmxext fxsr_opt rdtscp lm 3dnowext 3dnow constant_tsc pni cx16 lahf_lm cmp_legacy svm extapic cr8_legacy 3dnowprefetch osvw skinit
bogomips : 4000.63
clflush size : 64
power management: ts ttp tm stc 100mhzsteps hwpstate

processor : 1
vendor_id : AuthenticAMD
cpu family : 17
model : 3
model name : AMD Athlon Dual-Core QL-62
stepping : 1
cpu MHz : 1000.000
cache size : 512 KB
physical id : 0
siblings : 2
core id : 1
cpu cores : 2
apicid : 1
initial apicid : 1
fdiv_bug : no
hlt_bug : no
f00f_bug : no
coma_bug : no
fpu : yes
fpu_exception : yes
cpuid level : 1
wp : yes
flags : fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush mmx fxsr sse sse2 ht syscall nx mmxext fxsr_opt rdtscp lm 3dnowext 3dnow constant_tsc pni cx16 lahf_lm cmp_legacy svm extapic cr8_legacy 3dnowprefetch osvw skinit
bogomips : 4000.17
clflush size : 64
power management: ts ttp tm stc 100mhzsteps hwpstate

gmp34 01-11-2010 01:22 PM

Hi,

You may just need to set-up appropriate option in modprobe.conf for your sound card, I had an issue with PUPPY and HDA Intel sound card on an HP Laptop.

My initial problem was sound on headphone but no sound on speakers

I fiddled on the www.alsa.org site the proper answer with link:

http://git.alsa-project.org/?p=alsa-...6b4df94638eac2

and tried to find a card reference sufficiently close to mine and set-up options. snd-hda-intel configurations start at line 746

Quote:

options snd-hda-intel model=laptop


Just to remind you my configuration:
# cat /proc/asound/card0/codec#* | grep Codec
Codec: Analog Devices AD1984A
Codec: LSI ID 1040
I hope this can help ypu

rtoney5 01-11-2010 06:07 PM

Solution for No Sound when Upgrading from Ubuntu 9.04 to 9.10
 
SOLUTION!!!
Ok figured out what went wrong with the Sound when I Upgraded from Ubuntu 9.04 to 9.10. I remember while installing the upgrade, the prompt asked me if I wanted to keep the old version of the menu.lst. I replied no, and that was the problem. Even though the new kernel was built, the grub menu.lst did not pick it up, and was still using the older kernel.

So here's the SOLUTION...:
-->Goto Synaptic Package Manager

-->search for grub-pc

-->Install it

-->When the system reboots, you'll see the grub menu. If it boots up ok, and you can verify sound is occuring, then reboot and pull up a terminal and type the following...:

upgrade-from-grub-legacy

-->(press ok to the first prompt, then MAKE SURE TO PRESS THE SPACE BAR when the [ ] /dev/sda prompt appears so that an * populates the brackets[*]. Then tab down and press ok.)

--> You should be good to go.


All times are GMT -5. The time now is 01:23 PM.