LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Laptop and Netbook
User Name
Password
Linux - Laptop and Netbook Having a problem installing or configuring Linux on your laptop? Need help running Linux on your netbook? This forum is for you. This forum is for any topics relating to Linux and either traditional laptops or netbooks (such as the Asus EEE PC, Everex CloudBook or MSI Wind).

Notices

Reply
 
Search this Thread
Old 11-18-2006, 10:14 AM   #1
Enphuego
LQ Newbie
 
Registered: Dec 2005
Posts: 5

Rep: Reputation: 0
Sound issues on Acer with Knoppix 3.9 HD install


I've installed Knoppix 3.9 on an Acer TravelMate 2451WLCi and I can't get the sound working.

Hardware:
IntelŽ CeleronŽ M processor 410
Mobile IntelŽ 940GML Express chipset
ATI Mobility Xpress 200M

I tried alsaconf and got:
No supported PnP or PCI card found

sndconfig:
You don't seem to be running a kernel with modular sound enabled. (soundcore.o was not found in the module search path)

lsmod:
Module Size Used by
ub 18332 2
lp 13448 0
snd 46308 0
soundcore 11104 1 snd
agpgart 30512 0
autofs4 18820 1
af_packet 20104 0
ath_pci 53024 0
ath_rate_onoe 10632 1 ath_pci
wlan 102876 2 ath_pci,ath_rate_onoe
ath_hal 150480 1 ath_pci
8139too 25600 0
mii 7808 1 8139too
parport_pc 38596 0
parport 33480 2 lp,parport_pc
8250 41692 0
serial_core 21120 1 8250
unionfs 109944 0
sbp2 24456 0
usb_storage 63296 0
ehci_hcd 31752 0
ohci1394 33028 0
ieee1394 300600 2 sbp2,ohci1394
usbhid 42176 0
ohci_hcd 21896 0
uhci_hcd 31376 0
usbcore 101496 7 ub,usb_storage,ehci_hcd,usbhid,ohci_hcd,uhci_hcd
pcmcia 21776 2
yenta_socket 21896 1
rsrc_nonstatic 12160 1 yenta_socket
pcmcia_core 42272 3 pcmcia,yenta_socket,rsrc_nonstatic
video 18308 0
thermal 14984 0
processor 24552 1 thermal
fan 7300 0
container 7296 0
button 7168 0
battery 12420 0
ac 7556 0
rtc 13772 0
ext3 124552 0
jbd 65060 1 ext3
reiserfs 232304 1

lspci:
0000:00:00.0 Host bridge: ATI Technologies Inc: Unknown device 5a31 (rev 01)
0000:00:01.0 PCI bridge: ATI Technologies Inc: Unknown device 5a3f
0000:00:13.0 USB Controller: ATI Technologies Inc: Unknown device 4374 (rev 80)
0000:00:13.1 USB Controller: ATI Technologies Inc: Unknown device 4375 (rev 80)
0000:00:13.2 USB Controller: ATI Technologies Inc: Unknown device 4373 (rev 80)
0000:00:14.0 SMBus: ATI Technologies Inc: Unknown device 4372 (rev 83)
0000:00:14.1 IDE interface: ATI Technologies Inc: Unknown device 4376 (rev 80)
0000:00:14.2 0403: ATI Technologies Inc: Unknown device 437b (rev 01)
0000:00:14.3 ISA bridge: ATI Technologies Inc: Unknown device 4377 (rev 80)
0000:00:14.4 PCI bridge: ATI Technologies Inc: Unknown device 4371 (rev 80)
0000:01:05.0 VGA compatible controller: ATI Technologies Inc: Unknown device 5a62
0000:09:02.0 Ethernet controller: Atheros Communications, Inc.: Unknown device 001a (rev 01)
0000:09:04.0 CardBus bridge: ENE Technology Inc CB1410 Cardbus Controller (rev 01)
0000:09:06.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL-8139/8139C/8139C+ (rev 10)

Does anyone have any suggestions? I've searced the forums but couldn't come up with anything.
 
Old 11-18-2006, 03:29 PM   #2
Enphuego
LQ Newbie
 
Registered: Dec 2005
Posts: 5

Original Poster
Rep: Reputation: 0
FYI I followed the troubleshooting steps at alsa.opensrc.org. (I can't post the link since I've just been lurking the forums for a while) I got to step 4 where it checks to make sure your soundcard drivers are active. The lspci | grep audio turns up with nothing for me so I don't know which driver to use. I tried running modprobe snd-intel8x0 and snd-intel8x0m with no results.
 
Old 11-20-2006, 04:00 PM   #3
Enphuego
LQ Newbie
 
Registered: Dec 2005
Posts: 5

Original Poster
Rep: Reputation: 0
I posted this over to the hardware forums as it wasn't getting much of a response here and it perhaps the hardware forum is a better place for it.
http://www.linuxquestions.org/questi...d.php?t=503355
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Acer Aspire 5504WXMi on Knoppix (or the other way round?) somebodyconfused Linux - Laptop and Netbook 1 12-12-2005 10:25 PM
Debian from Knoppix HD install driver issues jmoschetti45 Linux - Laptop and Netbook 3 10-04-2004 05:47 AM
Knoppix doesn´t work on a acer travelmate 243lc cruxx Linux - Laptop and Netbook 1 08-18-2004 08:26 PM
Debian Sid install using Knoppix Issues EwanG Debian 2 05-27-2004 08:52 AM
Acer Ferrari on Knoppix? Greenlandic Linux - Laptop and Netbook 2 04-29-2004 06:05 AM


All times are GMT -5. The time now is 11:00 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration