LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Laptop and Netbook (http://www.linuxquestions.org/questions/linux-laptop-and-netbook-25/)
-   -   Sound Input NOT working [Latitude E6500] [snd-hda-intel] (http://www.linuxquestions.org/questions/linux-laptop-and-netbook-25/sound-input-not-working-%5Blatitude-e6500%5D-%5Bsnd-hda-intel%5D-789121/)

rdagold 02-14-2010 08:30 PM

Sound Input NOT working [Latitude E6500] [snd-hda-intel]
 
So, I have a Dell Latitude E6500 laptop and I have installed Slackware 13.0:
Quote:

[rdagold@slack13 ~]$ uname -a
Linux mhq 2.6.29.6 #3 SMP Mon Dec 7 15:01:06 CST 2009 x86_64 Intel(R) Core(TM) 2 Duo CPU T9600@2.80GHz GenuineIntel GNU/Linux
Everything is just fine, except that I am completely unable to record audio, either using the built-in microphone or an external one. I can do this under Windows 7, which was installed in the laptop by Dell.

Audio output is ok, both for the built-in speakers and the external headset. I can listen to my mp3 in mpd/ncmpcpp and watch (HD) movies at youtube, for example.

However, as I have already mentioned, audio input is not ok. Following advice I found at Archlinux, Ubuntu and Suse forums, I have run alsaconf and I changed /etc/modprobe.d/sound:

Quote:

[rdagold@slack13 ~]$ cat /etc/modprobe.d/sound
alias snd-card-0 snd-hda-intel
alias sound-slot-0 snd-hda-intel
options snd-hda-intel model=dell-m4-1
I have then tried to record sound using sox (rec) and arecord applications. Both of them returned perfectly (and annoyingly) clean WAV files. :( I've also given Ekiga a try but it didn't work either, as expected.

Afterwards, I have tried several different alsamixer configurations for my capture devices and tried to record sound both via the builtin microphone and via an external one. It was all to no avail. Here are two screenshots of (rather obvious testing) configurations that I attempted:

1)http://tinyurl.com/yb8wb33
2)http://tinyurl.com/yepnxw6

In case you prefer, here is the output of amixer:

Quote:

Simple mixer control 'Master',0
Capabilities: pvolume pvolume-joined pswitch pswitch-joined
Playback channels: Mono
Limits: Playback 0 - 127
Mono: Playback 127 [100%] [0.00dB] [on]
Simple mixer control 'Headphone',0
Capabilities: pvolume pswitch
Playback channels: Front Left - Front Right
Limits: Playback 0 - 127
Mono:
Front Left: Playback 126 [99%] [0.75dB] [on]
Front Right: Playback 126 [99%] [0.75dB] [on]
Simple mixer control 'PCM',0
Capabilities: pvolume
Playback channels: Front Left - Front Right
Limits: Playback 0 - 255
Mono:
Front Left: Playback 255 [100%] [0.00dB]
Front Right: Playback 255 [100%] [0.00dB]
Simple mixer control 'Front',0
Capabilities: pvolume pswitch
Playback channels: Front Left - Front Right
Limits: Playback 0 - 127
Mono:
Front Left: Playback 127 [100%] [0.00dB] [on]
Front Right: Playback 127 [100%] [0.00dB] [on]
Simple mixer control 'Capture',0
Capabilities: cvolume cswitch
Capture channels: Front Left - Front Right
Limits: Capture 0 - 15
Front Left: Capture 15 [100%] [22.50dB] [off]
Front Right: Capture 15 [100%] [22.50dB] [off]
Simple mixer control 'Capture',1
Capabilities: cvolume cswitch
Capture channels: Front Left - Front Right
Limits: Capture 0 - 15
Front Left: Capture 15 [100%] [22.50dB] [off]
Front Right: Capture 15 [100%] [22.50dB] [off]
Simple mixer control 'Analog Loopback',0
Capabilities: pswitch pswitch-joined
Playback channels: Mono
Mono: Playback [off]
Simple mixer control 'Analog Loopback',1
Capabilities: pswitch pswitch-joined
Playback channels: Mono
Mono: Playback [off]
Simple mixer control 'DAC0',0
Capabilities: cvolume cswitch
Capture channels: Front Left - Front Right
Limits: Capture 0 - 31
Front Left: Capture 31 [100%] [12.00dB] [off]
Front Right: Capture 31 [100%] [12.00dB] [off]
Simple mixer control 'DAC1',0
Capabilities: cvolume cswitch
Capture channels: Front Left - Front Right
Limits: Capture 0 - 31
Front Left: Capture 31 [100%] [12.00dB] [off]
Front Right: Capture 31 [100%] [12.00dB] [off]
Simple mixer control 'Digital',0
Capabilities: cvolume
Capture channels: Front Left - Front Right
Limits: Capture 0 - 120
Front Left: Capture 120 [100%] [30.00dB]
Front Right: Capture 120 [100%] [30.00dB]
Simple mixer control 'Digital Input Source',0
Capabilities: enum
Items: 'Analog Inputs' 'Mixer' 'Digital Mic 1'
Item0: 'Analog Inputs'
Simple mixer control 'Import0 Mux',0
Capabilities: cvolume cswitch
Capture channels: Front Left - Front Right
Limits: Capture 0 - 31
Front Left: Capture 31 [100%] [12.00dB] [off]
Front Right: Capture 31 [100%] [12.00dB] [off]
Simple mixer control 'Import1 Mux',0
Capabilities: cvolume cswitch
Capture channels: Front Left - Front Right
Limits: Capture 0 - 31
Front Left: Capture 31 [100%] [12.00dB] [off]
Front Right: Capture 31 [100%] [12.00dB] [off]
Simple mixer control 'Input Source',0
Capabilities: cenum
Items: 'Mic' 'Front Mic'
Item0: 'Front Mic'
Simple mixer control 'Input Source',1
Capabilities: cenum
Items: 'Mic' 'Front Mic'
Item0: 'Front Mic'
Simple mixer control 'Mux',0
Capabilities: cvolume
Capture channels: Front Left - Front Right
Limits: Capture 0 - 3
Front Left: Capture 3 [100%] [30.00dB]
Front Right: Capture 3 [100%] [30.00dB]
Simple mixer control 'Mux',1
Capabilities: cvolume
Capture channels: Front Left - Front Right
Limits: Capture 0 - 3
Front Left: Capture 3 [100%] [30.00dB]
Front Right: Capture 3 [100%] [30.00dB]
It is worth to note that the codec to be used is correctly assigned (IDT 92HD71B7X):

Quote:

[rdagold@slack13 ~]$ cat /proc/asound/card0/codec#* | grep Codec
Codec: IDT 92HD71B7X
Finally, maybe I should add that the currently installed alsa packages in the system are:

Quote:

[rdagold@slack13 ~]$ ls /var/log/packages/ | grep alsa
alsa-lib-1.0.18-x86_64-2
alsa-oss-1.0.17-x86_64-1
alsa-utils-1.0.18-x86_64-2
I hope to have included all relevant information. I feel quite lost on what to try next. Thank you all in advance for any help/suggestions/orientation you may be able to provide me! ;)

business_kid 02-15-2010 01:20 PM

get hda-analyswer from the alsa site.

rdagold 02-15-2010 02:23 PM

Quote:

Originally Posted by business_kid (Post 3864677)
get hda-analyswer from the alsa site.

Thanks for the hint!

I still don't have any success when I try to record something but I feel I am getting close somehow ;)

Here is some more information on my system, in case some of you find important.

Output of lspci -vvnn
Quote:

00:1b.0 Audio device [0403]: Intel Corporation 82801I (ICH9 Family) HD Audio Controller [8086:293e] (rev 03)
Subsystem: Dell Device [1028:024f]
Control: I/O- Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR+ FastB2B- DisINTx-
Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
Latency: 0, Cache Line Size: 64 bytes
Interrupt: pin A routed to IRQ 21
Region 0: Memory at f6fdc000 (64-bit, non-prefetchable) [size=16K]
Capabilities: [50] Power Management version 2
Flags: PMEClk- DSI- D1- D2- AuxCurrent=55mA PME(D0+,D1-,D2-,D3hot+,D3cold+)
Status: D0 NoSoftRst- PME-Enable- DSel=0 DScale=0 PME-
Capabilities: [60] MSI: Enable- Count=1/1 Maskable- 64bit+
Address: 0000000000000000 Data: 0000
Capabilities: [70] Express (v1) Root Complex Integrated Endpoint, MSI 00
DevCap: MaxPayload 128 bytes, PhantFunc 0, Latency L0s <64ns, L1 <1us
ExtTag- RBE- FLReset+
DevCtl: Report errors: Correctable- Non-Fatal- Fatal- Unsupported-
RlxdOrd- ExtTag- PhantFunc- AuxPwr- NoSnoop+
MaxPayload 128 bytes, MaxReadReq 128 bytes
DevSta: CorrErr- UncorrErr- FatalErr- UnsuppReq- AuxPwr+ TransPend-
LnkCap: Port #0, Speed unknown, Width x0, ASPM unknown, Latency L0 <64ns, L1 <1us
ClockPM- Surprise- LLActRep- BwNot-
LnkCtl: ASPM Disabled; Disabled- Retrain- CommClk-
ExtSynch- ClockPM- AutWidDis- BWInt- AutBWInt-
LnkSta: Speed unknown, Width x0, TrErr- Train- SlotClk- DLActive- BWMgmt- ABWMgmt-
Capabilities: [100] Virtual Channel <?>
Capabilities: [130] Root Complex Link <?>
Kernel driver in use: HDA Intel
Kernel modules: snd-hda-intel
Output of alsa-info.sh: http://pastebin.com/f214a29fa

rdagold 02-15-2010 06:23 PM

I removed the (ancient) slackware alsa packages and I have just compiled (and installed) the latest stable version (1.0.22.1) of alsa-lib, alsa-utils and alsa-driver available at alsa-project.org.

Things look better now, although the problem remains. In fact, I am unable to change two of the values through amixer.


Current amixer output:

Quote:

[rdagold@slack13 ~]$ amixer | grep Capture
Simple mixer control 'Capture',0
Capture channels: Front Left - Front Right
Limits: Capture 0 - 15
Front Left: Capture 15 [100%] [22.50dB] [off]
Front Right: Capture 15 [100%] [22.50dB] [off]

Simple mixer control 'Capture',1
Capture channels: Front Left - Front Right
Limits: Capture 0 - 15
Front Left: Capture 15 [100%] [22.50dB] [off]
Front Right: Capture 15 [100%] [22.50dB] [off]

Capture channels: Front Left - Front Right
Limits: Capture 0 - 120
Front Left: Capture 60 [50%] [0.00dB]
Front Right: Capture 60 [50%] [0.00dB]
Capture channels: Front Left - Front Right
Limits: Capture 0 - 3
Front Left: Capture 3 [100%] [30.00dB]
Front Right: Capture 3 [100%] [30.00dB]
Capture channels: Front Left - Front Right
Limits: Capture 0 - 3
Front Left: Capture 3 [100%] [30.00dB]
Front Right: Capture 3 [100%] [30.00dB]
Capture channels: Front Left - Front Right
Limits: Capture 0 - 3
Front Left: Capture 3 [100%] [30.00dB]
Front Right: Capture 3 [100%] [30.00dB]
(full amixer output: http://pastebin.com/f2c4203e1)


Current alsamixer screenshots:

1)http://tinyurl.com/yhbnsba
2)http://tinyurl.com/yznqv6s

business_kid 02-16-2010 05:37 AM

What I did with hda-analyser was open it in gui, unmute every pin, and set all volumes at half mast. Then I went intyo alsamixer and sorted things by ear. Try that.

rdagold 02-16-2010 09:43 AM

Quote:

Originally Posted by business_kid (Post 3865419)
What I did with hda-analyser was open it in gui, unmute every pin, and set all volumes at half mast. Then I went intyo alsamixer and sorted things by ear. Try that.

It worked. Thank you a lot. :D How can i add the tag [SOLVED] to the title of the thread?

Thanks.

business_kid 02-17-2010 03:02 AM

Quote:

Originally Posted by rdagold (Post 3865684)
It worked. Thank you a lot. :D How can i add the tag [SOLVED] to the title of the thread?

Thanks.

There's some doo-dah on the page you see when you're logged in as the OP. On the left, IIRC, but it could be in thread tools. Or you can just edit the first post, go advanced, and edit the subject.


All times are GMT -5. The time now is 05:38 AM.