LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Laptop and Netbook
User Name
Password
Linux - Laptop and Netbook Having a problem installing or configuring Linux on your laptop? Need help running Linux on your netbook? This forum is for you. This forum is for any topics relating to Linux and either traditional laptops or netbooks (such as the Asus EEE PC, Everex CloudBook or MSI Wind).

Notices

Reply
 
Search this Thread
Old 11-10-2009, 01:57 PM   #1
Suppen
Member
 
Registered: Mar 2009
Distribution: Ubuntu, Linux Mint
Posts: 35

Rep: Reputation: 17
Sleep mode when i close laptop before login (Ubuntu 9.10)


When i close my laptop on the login screen, it goes into this sleep mode. This is damn annoying, because I use it for SSH and other stuff when I am in school. Before I leave home, I turn on the computer, and close it. Result: I can't access it. It didn't happen in earlier versions of Ubuntu, and doesn't happen after login. How can I fix this?
 
Old 11-10-2009, 03:41 PM   #2
tredegar
LQ 5k Club
 
Registered: May 2003
Location: London, UK
Distribution: Debian "Jessie"
Posts: 6,012

Rep: Reputation: 367Reputation: 367Reputation: 367Reputation: 367
Quote:
How can I fix this?
I can't tell you exactly how the 'buntus are sorting this out, but .. .. .

Some suggestions for further research:

Easy:

- Don't close your laptop ?

- Login before you close it ?

More difficult, but still "easy":

- Read up on the differences between hibernate and suspend and sleep.

- Make the services you require - "other stuff" to be started as your username at boot.

You can call scripts from /etc/rc.local and have them run them as any non-root user by using the su command. Read up on that.

Hope this helps.
 
Old 11-10-2009, 03:41 PM   #3
kbp
Senior Member
 
Registered: Aug 2009
Posts: 3,758

Rep: Reputation: 643Reputation: 643Reputation: 643Reputation: 643Reputation: 643Reputation: 643
If you run Gnome try this:
System >> Preferences >> Power Management >> When laptop lid is closed: _

cheers
 
Old 11-13-2009, 06:39 AM   #4
Suppen
Member
 
Registered: Mar 2009
Distribution: Ubuntu, Linux Mint
Posts: 35

Original Poster
Rep: Reputation: 17
Quote:
Originally Posted by kbp View Post
If you run Gnome try this:
System >> Preferences >> Power Management >> When laptop lid is closed: _

cheers
Done a long time ago. This only affects behavior AFTER login, and that is already as i want it.
 
Old 11-13-2009, 07:42 AM   #5
kbp
Senior Member
 
Registered: Aug 2009
Posts: 3,758

Rep: Reputation: 643Reputation: 643Reputation: 643Reputation: 643Reputation: 643Reputation: 643
And if you click "make default" ?
 
Old 11-14-2009, 07:57 AM   #6
Suppen
Member
 
Registered: Mar 2009
Distribution: Ubuntu, Linux Mint
Posts: 35

Original Poster
Rep: Reputation: 17
Thanks. That worked. Problem solved
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
i m running ubuntu 8.10 .unable to login as a user in gui mode. chandan766 Linux - Newbie 1 04-05-2009 05:03 PM
how to disable sleep/hibernate mode in runlevel 3 mode libin88 Linux - General 1 11-23-2008 04:54 AM
Lid Close = Sleep mangogreg Linux - Hardware 2 08-28-2008 03:17 PM
disable sleep mode, away mode standby, etc. ZiGz Linux - General 3 02-04-2008 12:32 AM
Where's sleep mode in RH 8.0? bobterri Linux - Distributions 4 11-26-2002 11:13 PM


All times are GMT -5. The time now is 07:28 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration