LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Laptop and Netbook (http://www.linuxquestions.org/questions/linux-laptop-and-netbook-25/)
-   -   Slackware 12.2 will not connect to Wireless Networks (http://www.linuxquestions.org/questions/linux-laptop-and-netbook-25/slackware-12-2-will-not-connect-to-wireless-networks-714128/)

picketfence 03-24-2009 03:32 PM

Slackware 12.2 will not connect to Wireless Networks
 
Ok, I have a HP G60-237NR Notebook laptop with an Atheros AR5009 802.11a/g/n WiFi Adapter card built in. I am running Slackware 12.2, and all works great except for the WiFi. Slackware will recognize and enable my WiFi card, but will not let me connect. I have read different articles which suggest I may have a missing driver, but I don't know which one to look for. I have even been to the website for Atheros, but could find no information there.

I have used a LiveCD version of Knoppix, and it finds wireless networks with ease.

farslayer 03-24-2009 03:43 PM

I believe you need the ath9k Driver which is included with kernel 2.6.27 and higher..

or you can git the driver or install compat-wireless, for older kernels..

allend 03-25-2009 02:44 AM

Slackware 12.2 has the 2.6.27.7 kernel, so that should be OK. Try reininstalling the kernel-firmware package.

picketfence 03-25-2009 03:47 PM

As much as I know about Linux, I'm ashamed to say there's even more I don't know. What or in what installation group is the kernel-firmware package?

farslayer 03-25-2009 04:16 PM

Quote:

http://wiki.debian.org/ath9k
ath9k is a module for Atheros 802.11n (non-USB) wireless LAN chipsets.

It does not require a binary HAL (hardware abstraction layer) for its use. No firmware is required to be loaded from userspace. It is a completely free and open-source driver.

This driver is included in the mainline Linux kernel since 2.6.27-rc3
I don't think firmware is the issue. but I'm not finding any Slackware guides for the ath9k

I would start with installing wireless-tools then loading the driver module..
modprobe ath9k


No need to be ashamed.. the more I learn about Linux the more I realize how much is still out there that I don't know.. so we are ultimately in the same boat.

picketfence 03-26-2009 10:50 AM

Ok, I did the modprobe ath9k, and now I see it getting a signal. My problem might now be FireFox. When I try to connect with FireFox, I keep seeing "Unknown Host" no matter where I try to go. Please forgive me, but what setting should I check?

While I'm waiting for help here, I'm going to check the Mozilla website as well. Hopefully I get Slackware fully functional soon. I'm trying to migrate away from Windows Vista.

farslayer 03-26-2009 12:09 PM

OK so you have wireless signal,

Does the system recognize your wireless card properly ?
iwconfig

Did you get an IP address from DHCP ?
ifconfig -a

Did you get DNS info from DHCP ?
cat /etc/resolv.conf

picketfence 03-27-2009 11:00 PM

More Information on not connecting
 
I don't know how everyone does the inset box thingy to show the information they needed to give, so I'll do my best. First was the iwconfig command. It picks up my wlan0 for my home wireless router. My only concern is the Access Point hex doesn't exactly match the MAC Address hex on the underside of the router. Is that a problem?

Second, ifconfig -a lists an "inet addr:192.168.1.66" for my wlan0. Is that what you were looking for?

Third, cat /etc/resolv.conf returned this:
search domain_not_set.invalid
nameserver 192.168.1.1
nameserver 68.238.0.12

I have screenshots of all three commands if it would be helpful for me to upload them. Hopefully, though, I have provided the information you were looking for.

H_TeXMeX_H 03-28-2009 05:51 AM

You may also want to try wicd in the '/extra/wicd/' directory.

picketfence 03-28-2009 11:00 AM

I don't know what combination of advice finally got me working properly, so I want to thank you all. Oh, and this message is being typed in FireFox on my brand new Slackware 12.2 distro running KDE 3.5. Thanks to you all!


All times are GMT -5. The time now is 03:35 PM.