LinuxQuestions.org
Visit the LQ Articles and Editorials section
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Laptop and Netbook
User Name
Password
Linux - Laptop and Netbook Having a problem installing or configuring Linux on your laptop? Need help running Linux on your netbook? This forum is for you. This forum is for any topics relating to Linux and either traditional laptops or netbooks (such as the Asus EEE PC, Everex CloudBook or MSI Wind).

Notices

Reply
 
Search this Thread
Old 04-25-2005, 07:56 PM   #1
Mr.Bone
Member
 
Registered: Aug 2004
Location: An Igloo in Alaska
Distribution: Ubuntu/Debian Sarge
Posts: 31

Rep: Reputation: 15
screen shuts off


I have a bit of a weird problem I think. I run Ubuntu linux right now and I have a problem with my screen shutting off. When I watch movies or video clips on my computer it does not realize that I am using the computer and every minute the screen turns off which is quite an annoyance to have to move the mouse or hit a key every minute. I also have my screen saver shut off. I originally thought this might be a setting in my bios ( It is a toshiba satellite A45 by the way) but I cannot find anything in there that fixes the problem. I also have all Power Management disabled for the computer. I used to rune SuSE linux a while back and I never had this problem. I have tried asking in the ubuntu forusm but they cannot figure out what is going on so I thought I would try another linux forum. Also I was wondering if anyone out there could program for linux, would it be very hard to write a program that gives the same effect as if the mouse was always being moved or a key on the keyboard was always being pressed. Something so that nix knows that the computer is being used and the screen does not shurt off?. Thanks for any help.
 
Old 04-25-2005, 08:15 PM   #2
Brian1
Guru
 
Registered: Jan 2003
Location: Seymour, Indiana
Distribution: Distribution: RHEL 5 with Pieces of this and that. Kernel 2.6.23.1, KDE 3.5.8 and KDE 4.0 beta, Plu
Posts: 5,700

Rep: Reputation: 61
Some thoughts.
If running acpi then turn off the daemon and see if that works. ' service acpid stop '. If that works then look into /etc/acpi and see what scripts in there say.

Also make sure xscreensaver is not running. ' ps -ax | grep xsreen '. Something may ahve started the app without you knowing.

I know you mentioned power management, I assume you mean in the bios?

If I think of more ideas I will post back. Good luck.

Brian1
 
Old 04-25-2005, 08:37 PM   #3
mrcheeks
Senior Member
 
Registered: Mar 2004
Location: far enough
Distribution: OS X 10.6.7
Posts: 1,690

Rep: Reputation: 50
disable the screensaver.
 
Old 04-25-2005, 08:37 PM   #4
Mr.Bone
Member
 
Registered: Aug 2004
Location: An Igloo in Alaska
Distribution: Ubuntu/Debian Sarge
Posts: 31

Original Poster
Rep: Reputation: 15
Code:
steve@blackbetty:~$ service acpid stop
bash: service: command not found
So that one doesnt work

Code:
steve@blackbetty:~$ sudo ps -ax | grep xscreen
Warning: bad ps syntax, perhaps a bogus '-'? See http://procps.sf.net/faq.html
 7345 ?        S      0:01 xscreensaver -nosplash
14417 pts/0    S+     0:00 grep xscreen
I did that one and unplugged the power still shut off after about a minute.

By power management I mean I open up the xscreensaver options and there is some power management options in there. I have searched through my bios for anything about powermanagement and I cannot find anything.
 
Old 04-25-2005, 08:38 PM   #5
Mr.Bone
Member
 
Registered: Aug 2004
Location: An Igloo in Alaska
Distribution: Ubuntu/Debian Sarge
Posts: 31

Original Poster
Rep: Reputation: 15
Quote:
Originally posted by mrcheeks
disable the screensaver.
umm I already mentioned I tried that in the first post...
 
Old 04-25-2005, 08:57 PM   #6
Brian1
Guru
 
Registered: Jan 2003
Location: Seymour, Indiana
Distribution: Distribution: RHEL 5 with Pieces of this and that. Kernel 2.6.23.1, KDE 3.5.8 and KDE 4.0 beta, Plu
Posts: 5,700

Rep: Reputation: 61
From your above post you show this.
Code:
steve@blackbetty:~$ sudo ps -ax | grep xscreen
Warning: bad ps syntax, perhaps a bogus '-'? See http://procps.sf.net/faq.html
 7345 ?        S      0:01 xscreensaver -nosplash
14417 pts/0    S+     0:00 grep xscreen
xscreensaver is running. Kill it by running the command ' kill 7345 '
Other ways are ' pkill xscreensaver ' if you pkill installed. Of course rerun the command above to make sure what the process id number is.

You may disabled it in the gui but it could still be looking at another config to continue running. xscreensaver is strange with the gui's

Brian1

Last edited by Brian1; 04-25-2005 at 08:59 PM.
 
Old 04-25-2005, 09:08 PM   #7
Mr.Bone
Member
 
Registered: Aug 2004
Location: An Igloo in Alaska
Distribution: Ubuntu/Debian Sarge
Posts: 31

Original Poster
Rep: Reputation: 15
Aweomse it looks like that worked. Now is there way to make it so it turns off when I turn it off on the gui?
 
Old 04-26-2005, 03:58 PM   #8
Brian1
Guru
 
Registered: Jan 2003
Location: Seymour, Indiana
Distribution: Distribution: RHEL 5 with Pieces of this and that. Kernel 2.6.23.1, KDE 3.5.8 and KDE 4.0 beta, Plu
Posts: 5,700

Rep: Reputation: 61
Okay if you have the pkill command then it is easy to do. Just right a script like this called xscreensaver_off. Open your favoraite text editor and enter this.
Code:
#!/bin/bash
pkill xscreensaver
Once saved it will need to be executable. This can be done two ways. In a terminal screen issue he command ' chmod + xscreensaver_off '. Or in the gui if using kde then right click the script and check the box in permissions to make it executable.

But guessing root has control of pkill to kill xscreensaver you will either need to make pkill usable to you by changing ownership of the command pkill. Or it can be added to your sudoers file. Little harder to do that way.

Let me know how it goes.
Brian1
 
Old 04-26-2005, 11:14 PM   #9
Mr.Bone
Member
 
Registered: Aug 2004
Location: An Igloo in Alaska
Distribution: Ubuntu/Debian Sarge
Posts: 31

Original Poster
Rep: Reputation: 15
Well was going to watch a movie and the screen shut off again. It looks like I just didnt wait long enough last night to see if it would. I tried removing option "DPMS" in my /etc/X11/xorg.conf to make sure it wouldnt shut off. Guess it is still just blanking out.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
screen shuts off Mr.Bone Linux - Laptop and Netbook 1 02-03-2005 11:11 PM
Computer shuts down saurabhchandhok Linux - Laptop and Netbook 1 01-01-2005 03:00 PM
startx shuts down TonyD Debian 5 10-13-2004 04:48 AM
Screen shuts off while loading mandrake 9.1 Stephen_Ri Linux - General 2 09-13-2003 10:16 PM
adsl shuts down saavik Linux - Networking 0 05-24-2002 02:38 AM


All times are GMT -5. The time now is 12:54 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration