LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Laptop and Netbook
User Name
Password
Linux - Laptop and Netbook Having a problem installing or configuring Linux on your laptop? Need help running Linux on your netbook? This forum is for you. This forum is for any topics relating to Linux and either traditional laptops or netbooks (such as the Asus EEE PC, Everex CloudBook or MSI Wind).

Notices

Reply
 
Search this Thread
Old 06-26-2012, 02:11 PM   #1
Kvbx4
LQ Newbie
 
Registered: Dec 2011
Distribution: Kubuntu Precise, Debian Lenny
Posts: 14

Rep: Reputation: Disabled
Exclamation Screen Resolution Problems in Fedora 17 KDE with Intel GMA 950 GPU


First, some background:
I am running Fedora 17 KDE Spin on a Toshiba Satellite A105-S4164 laptop, which contains an Intel Graphics Media Accelerator 950 GPU. I keep the built-in display disabled, and I use an external VGA 21 CRT monitor at a resolution of 1024x768.

The first indication of a problem arose the first time I booted the computer after installing Fedora. The Grub kernel selection screen got cut off on the left edge of the screen, so I adjusted the monitor to make it fit. However, the monitor resolution didn't change after that screen was dismissed, so the boot splash screen and the desktop were way too small and I had to adjust the monitor again.

If that were the only effect, I could live with it and wouldn't be posting this. But the real problems come when I load a program such as DOSBox or ScummVM (both obtained from the default Fedora repos) and try to switch to fullscreen mode. Then, one of three things happens, seemingly at random:

Scenario 1: The monitor resolution doesn't change, and the fullscreen program appears very small in the center of the screen, surrounded by a thick windowbox. Switching between fullscreen and windowed modes causes brief system slowdowns lasting a few seconds.

Scenario 2: The monitor resolution changes to the fullscreen resolution as it should. However, when switching to windowed mode or exiting the program, the screen resolution does not reset to 1024x768 automatically as it should. After I reset it manually, graphical elements (such as menubars) of many programs opened after this are smaller than they should be, and remain this way until a system reboot. Switching between fullscreen and windowed modes causes brief system slowdowns lasting a few seconds.

Scenario 3: The entire screen turns gray and the system does not respond to any keystrokes or mouse movements, except for ctrl+alt+F1 and ctrl+alt+F2, which make the screen blink when pressed alternately. To regain control of the computer, I have to force a power-off and reboot, as the system does not respond to the ACPI power off command as it normally does when I press the power button.

Also, the screen only occupies the upper left quadrant of the monitor during the shutdown splash screen or if I press esc at the boot splash screen. It did not do this previously, and I don't know what caused it or when it started.

It seems fairly obvious to me that I have discovered some nasty bug, but I have no idea whether it's an issue with KDE, with the kernel, with the graphics driver, or what. Does anyone have a solution to this issue or can assist me in tracking down the source?

Many thanks in advance.
 
Old 07-01-2012, 05:26 PM   #2
RockDoctor
Senior Member
 
Registered: Nov 2003
Location: Minnesota, US
Distribution: Fedora, Ubuntu
Posts: 1,225

Rep: Reputation: 251Reputation: 251Reputation: 251
What if you boot with the nomodeset option? To do this select F17 from the grub menu, then hit the tab key and edit the kernel line, adding nomodeset to the end, then press F10 to continue booting. This will force use of the vesa driver, and may give you 1024x768 by default. If this works, you can make the change permanent by editing /etc/default/grub then rerunning /usr/sbin/grub2-mkconfig
 
1 members found this post helpful.
Old 07-03-2012, 09:46 AM   #3
Kvbx4
LQ Newbie
 
Registered: Dec 2011
Distribution: Kubuntu Precise, Debian Lenny
Posts: 14

Original Poster
Rep: Reputation: Disabled
Thanks for the reply, RockDoctor. Pressing tab on the GRUB screen with Fedora selected does nothing. I can press e to go to an "edit commands" screen, but then it puts me at a text editor box with several lines of code. I think this might be similar to what you were talking about, but I'm not sure where to put the nomodeset option. The version number at the top of the screen is "GNU GRUB version 2.00~beta4," if that helps anything.

Last edited by Kvbx4; 07-03-2012 at 09:47 AM.
 
Old 07-04-2012, 11:11 AM   #4
RockDoctor
Senior Member
 
Registered: Nov 2003
Location: Minnesota, US
Distribution: Fedora, Ubuntu
Posts: 1,225

Rep: Reputation: 251Reputation: 251Reputation: 251
Put nomodeset at the end of the kernel line (the kernel line may span two lines onscreen)
 
1 members found this post helpful.
Old 07-04-2012, 09:43 PM   #5
Kvbx4
LQ Newbie
 
Registered: Dec 2011
Distribution: Kubuntu Precise, Debian Lenny
Posts: 14

Original Poster
Rep: Reputation: Disabled
Okay. That fixes my problem (yay!) but introduces a few new problems. My fonts appear smaller, although the font settings haven't changed, and I had some issues with my window themes not displaying properly. Both problems persist after toggling the settings and rebooting. However, if I remove the nomodeset flag, reboot, and toggle the settings, my theme/font problems are fixed but the old problems are back. Any idea how to fix this?

Thanks so much for your help so far!
 
Old 07-05-2012, 07:25 AM   #6
RockDoctor
Senior Member
 
Registered: Nov 2003
Location: Minnesota, US
Distribution: Fedora, Ubuntu
Posts: 1,225

Rep: Reputation: 251Reputation: 251Reputation: 251
Had you asked about LXDE, I might have been able to help; KDE is just not my cup of tea. To see if it's a KDE problem or something else, what happens if you install openbox and obconf and select an openbox session (or openbox-KDE, if offerred) from the display manager? Then use obconf to configure openbox, and see if the theme and font display correctly.
 
Old 07-05-2012, 07:39 PM   #7
Kvbx4
LQ Newbie
 
Registered: Dec 2011
Distribution: Kubuntu Precise, Debian Lenny
Posts: 14

Original Poster
Rep: Reputation: Disabled
Okay,

I installed openbox, openbox-kde, and obconf as you suggested. With nomodeset enabled, the openbox-kde session did not have font issues, but my theme (QtCurve) did not show up in obconf and the cursor kept disappearing and flickering (something that happened before that I forgot to mention). The regular openbox session did not work at all, whether nomodeset was enabled or not. I only got a grey screen. I could right click to access a few menu options, but if I hovered over "applications," it just gave me an error message. I have no idea at this point.

One thing worth mentioning: when I installed Fedora, I copied over my prefrences folders from my old Kubuntu install, including ~/.kde and ~/.qt. I don't know if that would make a difference or not. It might, though, since I think I had an LTS release that used an older KDE version.
 
Old 07-05-2012, 09:02 PM   #8
RockDoctor
Senior Member
 
Registered: Nov 2003
Location: Minnesota, US
Distribution: Fedora, Ubuntu
Posts: 1,225

Rep: Reputation: 251Reputation: 251Reputation: 251
Old preferences have an interesting way of messing things up at times, especially when moving between Fedora and a -buntu; been there, done that, got the bite marks to prove it. I suggest renaming .kde to dot_kde, .qt to dot_qt and rebooting into a normal KDE session.
 
1 members found this post helpful.
Old 07-06-2012, 06:34 PM   #9
Kvbx4
LQ Newbie
 
Registered: Dec 2011
Distribution: Kubuntu Precise, Debian Lenny
Posts: 14

Original Poster
Rep: Reputation: Disabled
Done. With the nomodeset flag enabled, all my problems are gone except for the blinking/disappearing cursor, which is driving me crazzy.

EDIT: Never mind. After a reboot, small text is back too. During boot, after the GRUB menu goes away, my screen goes completely blank until the login screen appears. Grr.

Last edited by Kvbx4; 07-06-2012 at 06:38 PM.
 
Old 07-07-2012, 07:53 AM   #10
RockDoctor
Senior Member
 
Registered: Nov 2003
Location: Minnesota, US
Distribution: Fedora, Ubuntu
Posts: 1,225

Rep: Reputation: 251Reputation: 251Reputation: 251
I've run out of ideas, so I'll suggest you try the Fedora users mailing list. Sorry I couldn't help
 
Old 07-17-2012, 11:11 AM   #11
Kvbx4
LQ Newbie
 
Registered: Dec 2011
Distribution: Kubuntu Precise, Debian Lenny
Posts: 14

Original Poster
Rep: Reputation: Disabled
Thanks, but I decided to just wipe Fedora and reinstall Kubuntu. Fedora had a number of other small problems that were bothering me, and I decided it would be better to go back to what I know works instead of chasing everything down. Thanks for your help though!
 
  


Reply

Tags
fedora 17, fullscreen, graphics, kde, resolution


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Intel GMA x4500 wrong resolution TimmyTurner Linux - Hardware 2 11-03-2010 12:54 AM
Intel GMA 900 1440x900 Resolution Problem Omnipresence Linux - Hardware 1 10-06-2008 04:13 PM
Increase VRAM in intel gma 950 ? moljac024 Linux - Laptop and Netbook 2 05-04-2008 01:12 PM
XGL/Beryl Performance on Laptop with Intel GMA 950 Integrated graphics 945GM Jyneo Linux - General 1 09-24-2007 04:46 PM
xcompmgr with intel gma 950 graphics card Geminias Linux - General 0 07-29-2007 11:16 PM


All times are GMT -5. The time now is 02:41 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration