LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Laptop and Netbook
User Name
Password
Linux - Laptop and Netbook Having a problem installing or configuring Linux on your laptop? Need help running Linux on your netbook? This forum is for you. This forum is for any topics relating to Linux and either traditional laptops or netbooks (such as the Asus EEE PC, Everex CloudBook or MSI Wind).

Notices

Reply
 
LinkBack Search this Thread
Old 06-15-2008, 11:55 PM   #1
spaje
LQ Newbie
 
Registered: Jul 2007
Posts: 6

Rep: Reputation: 0
Screen resolution not taking up the hole screen leaving black edges


Hi
I have a old IBM Thinkpad 1711
I have Debain Linux Lenny Testing installed on it
And the screen resolution is set to 800*600 but the screen is 1024*768
But there no option for 1024*768 in the options fir screen resolution
I'm using Gnome
Heres my xorg.conf file
Code:
# xorg.conf (X.Org X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the xorg.conf manual page.
# (Type "man xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
#   sudo dpkg-reconfigure -phigh xserver-xorg

Section "InputDevice"
	Identifier	"Generic Keyboard"
	Driver		"kbd"
	Option		"XkbRules"	"xorg"
	Option		"XkbModel"	"pc104"
	Option		"XkbLayout"	"us"
EndSection

Section "InputDevice"
	Identifier	"Configured Mouse"
	Driver		"mouse"
EndSection

Section "Device"
	Identifier	"Configured Video Device"
EndSection

Section "Monitor"
	Identifier	"Configured Monitor"
EndSection

Section "Screen"
	Identifier	"Default Screen"
	Monitor		"Configured Monitor"
EndSection
I'll answer any questions you have to ask me to help you help me as soon as I can
Thanks
 
Old 06-16-2008, 12:02 AM   #2
deepumnit
Member
 
Registered: Dec 2006
Location: NOIDA, India
Distribution: Debian, SUSE, Fedora
Posts: 334
Blog Entries: 1

Rep: Reputation: 31
Hi,

Under the Section 'Screen', Include a 'Subsection' as shown below:
Code:
Section "Screen"
        Identifier      "Default Screen"
        Monitor         "Configured Monitor"
        Device          "Configured Video Device"
        Defaultdepth    24
        SubSection "Display"
                Depth          24
                Modes         "1024x768"
        EndSubSection
EndSection
Then, just save the file and restart the X-server by pressing 'Ctlr + Alt + Bkspc'
 
Old 06-16-2008, 12:40 AM   #3
spaje
LQ Newbie
 
Registered: Jul 2007
Posts: 6

Original Poster
Rep: Reputation: 0
No that didn't do it
X still starts but it's also still set to 800*600
And 1024*768 is still not in the opstions for screen res
Code:
# xorg.conf (X.Org X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the xorg.conf manual page.
# (Type "man xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
#   sudo dpkg-reconfigure -phigh xserver-xorg

Section "InputDevice"
	Identifier	"Generic Keyboard"
	Driver		"kbd"
	Option		"XkbRules"	"xorg"
	Option		"XkbModel"	"pc104"
	Option		"XkbLayout"	"us"
EndSection

Section "InputDevice"
	Identifier	"Configured Mouse"
	Driver		"mouse"
EndSection

Section "Device"
	Identifier	"Configured Video Device"
EndSection

Section "Monitor"
	Identifier	"Configured Monitor"
EndSection

Section "Screen"
	Identifier	"Default Screen"
        Monitor         "Configured Monitor"
        Device          "Configured Video Device"
        Defaultdepth    24
        SubSection "Display"
                Depth          24
                Modes         "1024x768"
        EndSubSection
EndSection
Heres my xorg file now
 
Old 06-16-2008, 04:05 AM   #4
deepumnit
Member
 
Registered: Dec 2006
Location: NOIDA, India
Distribution: Debian, SUSE, Fedora
Posts: 334
Blog Entries: 1

Rep: Reputation: 31
Do you have 'system-config-display'? Just type it in the terminal. And a window pops up. Now, in that, in the second tab, choose the screen, which otherwise is set by default. Set it according to your configuration.
 
Old 06-16-2008, 10:39 AM   #5
spaje
LQ Newbie
 
Registered: Jul 2007
Posts: 6

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by deepumnit View Post
Do you have 'system-config-display'? Just type it in the terminal. And a window pops up. Now, in that, in the second tab, choose the screen, which otherwise is set by default. Set it according to your configuration.
:~$ system-config-display
bash: system-config-display: command not found
 
Old 06-16-2008, 11:29 AM   #6
spaje
LQ Newbie
 
Registered: Jul 2007
Posts: 6

Original Poster
Rep: Reputation: 0
http://dreamlinuxforums.org/index.ph...c,2411.15.html
Check this out
xorg has been updated and thats the problem but the new xorg sultion isn't working for me still
See the link it will explain
 
Old 06-16-2008, 08:25 PM   #7
jglen490
Member
 
Registered: Apr 2002
Location: The next brick house on the right.
Distribution: Kubuntu 8.04
Posts: 668

Rep: Reputation: 31
I'm not familiar with a "Thinkpad 1711" and I couldn't find it referenced at thinkwiki.org, but I do have Thinkpad T20 so I'll give it a try.

Open a terminal and enter"
Code:
sudo lshw|less
It will prompt you for your user password and then output a hardware list into less. You can scroll up or down within less. Scroll until you see "*-display". It'll look something like this:
Code:
 *-display
                description: VGA compatible controller
                product: 86C270-294 Savage/IX-MV
                vendor: S3 Inc.
                physical id: 0
                bus info: pci@0000:01:00.0
                version: 11
                width: 32 bits
                clock: 66MHz
                capabilities: pm agp agp-1.0 vga bus_master cap_list
                configuration: latency=64 maxlatency=255 mingnt=4
I think your xorg.conf needs an actual video card reference instead of the generic statement. My xorg.conf looks like this in that section:
Code:
Section "Device"
#  4-28-2008 made changes that should accomodate the full capability of the Savage video card.
#  No particular problem, just want to optimize, as can be done.  Shouldn't need to use vesa
#   when the Savage card is better than that.
        Identifier      "S3 Inc. 86C270-294 Savage/IX-MV"
#  4-28-2008 switched driver from vesa to savage
#        Driver         "vesa"
       Driver          "savage"
#       Driver          "savagefb"
#       BusID           "PCI:1:0:0"
        VideoRam        8192
#        Option          "ShadowStatus"  "true"
#        Option          "AGPMode"  "2"
#  4-28-2008 added bustype option and uncommented dmamode
        Option          "Bustype"  "PCI"
        Option          "DmaMode"  "None"
EndSection
Come on back with your specific hardware list output and maybe we can figure a good entry for your machine.

And please double check the "1711" reference, or better yet try to get the type reference from the back of the machine (i.e., 2647-84U, that's my T20).
 
Old 06-16-2008, 09:56 PM   #8
spaje
LQ Newbie
 
Registered: Jul 2007
Posts: 6

Original Poster
Rep: Reputation: 0
Code:
thinker                   
    description: Computer
    width: 32 bits
  *-core
       description: Motherboard
       physical id: 0
     *-memory
          description: System memory
          physical id: 0
          size: 183MiB
     *-cpu
          product: Celeron (Coppermine)
          vendor: Intel Corp.
          physical id: 1
          bus info: cpu@0
          version: 6.8.6
          size: 700MHz
          width: 32 bits
          capabilities: fpu fpu_exception wp vme de pse tsc msr pae mce cx8 sep mtrr pge mca cmov pat pse36 mmx fxsr sse up
        *-cache:0
             description: L1 cache
             physical id: 0
 
Old 06-17-2008, 06:09 PM   #9
spaje
LQ Newbie
 
Registered: Jul 2007
Posts: 6

Original Poster
Rep: Reputation: 0
I have fixed my problem thanks for all the help you all gave me
 
Old 04-01-2010, 10:24 PM   #10
mr.simo
LQ Newbie
 
Registered: Feb 2010
Posts: 12

Rep: Reputation: 0
Quote:
Originally Posted by spaje View Post
I have fixed my problem thanks for all the help you all gave me
Sorry can You tell us how you fixed your problem? Because I have the same... Thank You
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
I messed with the screen resolution and now Redhat will boot into a black screen! Mr. Hill Linux - Newbie 29 05-04-2009 11:52 AM
Screen Resolution 800x600 with black borders JoSch1337 Linux - Hardware 6 11-10-2006 01:43 PM
Black Screen after changing vga resolution qakhan78 Red Hat 2 04-12-2005 09:51 AM
Screen goes black when restarting X after changing resolution Bix Linux - Newbie 25 06-29-2004 12:27 AM
Black screen after changing resolution limbless Linux - Newbie 1 12-03-2002 06:39 PM


All times are GMT -5. The time now is 01:00 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration