LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Laptop and Netbook (http://www.linuxquestions.org/questions/linux-laptop-and-netbook-25/)
-   -   Screen resolution not taking up the hole screen leaving black edges (http://www.linuxquestions.org/questions/linux-laptop-and-netbook-25/screen-resolution-not-taking-up-the-hole-screen-leaving-black-edges-649545/)

spaje 06-16-2008 12:55 AM

Screen resolution not taking up the hole screen leaving black edges
 
Hi
I have a old IBM Thinkpad 1711
I have Debain Linux Lenny Testing installed on it
And the screen resolution is set to 800*600 but the screen is 1024*768
But there no option for 1024*768 in the options fir screen resolution
I'm using Gnome
Heres my xorg.conf file
Code:

# xorg.conf (X.Org X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the xorg.conf manual page.
# (Type "man xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
#  sudo dpkg-reconfigure -phigh xserver-xorg

Section "InputDevice"
        Identifier        "Generic Keyboard"
        Driver                "kbd"
        Option                "XkbRules"        "xorg"
        Option                "XkbModel"        "pc104"
        Option                "XkbLayout"        "us"
EndSection

Section "InputDevice"
        Identifier        "Configured Mouse"
        Driver                "mouse"
EndSection

Section "Device"
        Identifier        "Configured Video Device"
EndSection

Section "Monitor"
        Identifier        "Configured Monitor"
EndSection

Section "Screen"
        Identifier        "Default Screen"
        Monitor                "Configured Monitor"
EndSection

I'll answer any questions you have to ask me to help you help me as soon as I can
Thanks

deepumnit 06-16-2008 01:02 AM

Hi,

Under the Section 'Screen', Include a 'Subsection' as shown below:
Code:

Section "Screen"
        Identifier      "Default Screen"
        Monitor        "Configured Monitor"
        Device          "Configured Video Device"
        Defaultdepth    24
        SubSection "Display"
                Depth          24
                Modes        "1024x768"
        EndSubSection
EndSection

Then, just save the file and restart the X-server by pressing 'Ctlr + Alt + Bkspc'

spaje 06-16-2008 01:40 AM

No that didn't do it
X still starts but it's also still set to 800*600
And 1024*768 is still not in the opstions for screen res
Code:

# xorg.conf (X.Org X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the xorg.conf manual page.
# (Type "man xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
#  sudo dpkg-reconfigure -phigh xserver-xorg

Section "InputDevice"
        Identifier        "Generic Keyboard"
        Driver                "kbd"
        Option                "XkbRules"        "xorg"
        Option                "XkbModel"        "pc104"
        Option                "XkbLayout"        "us"
EndSection

Section "InputDevice"
        Identifier        "Configured Mouse"
        Driver                "mouse"
EndSection

Section "Device"
        Identifier        "Configured Video Device"
EndSection

Section "Monitor"
        Identifier        "Configured Monitor"
EndSection

Section "Screen"
        Identifier        "Default Screen"
        Monitor        "Configured Monitor"
        Device          "Configured Video Device"
        Defaultdepth    24
        SubSection "Display"
                Depth          24
                Modes        "1024x768"
        EndSubSection
EndSection

Heres my xorg file now

deepumnit 06-16-2008 05:05 AM

Do you have 'system-config-display'? Just type it in the terminal. And a window pops up. Now, in that, in the second tab, choose the screen, which otherwise is set by default. Set it according to your configuration.

spaje 06-16-2008 11:39 AM

Quote:

Originally Posted by deepumnit (Post 3185970)
Do you have 'system-config-display'? Just type it in the terminal. And a window pops up. Now, in that, in the second tab, choose the screen, which otherwise is set by default. Set it according to your configuration.

:~$ system-config-display
bash: system-config-display: command not found

spaje 06-16-2008 12:29 PM

http://dreamlinuxforums.org/index.ph...c,2411.15.html
Check this out
xorg has been updated and thats the problem but the new xorg sultion isn't working for me still
See the link it will explain

jglen490 06-16-2008 09:25 PM

I'm not familiar with a "Thinkpad 1711" and I couldn't find it referenced at thinkwiki.org, but I do have Thinkpad T20 so I'll give it a try.

Open a terminal and enter"
Code:

sudo lshw|less
It will prompt you for your user password and then output a hardware list into less. You can scroll up or down within less. Scroll until you see "*-display". It'll look something like this:
Code:

*-display
                description: VGA compatible controller
                product: 86C270-294 Savage/IX-MV
                vendor: S3 Inc.
                physical id: 0
                bus info: pci@0000:01:00.0
                version: 11
                width: 32 bits
                clock: 66MHz
                capabilities: pm agp agp-1.0 vga bus_master cap_list
                configuration: latency=64 maxlatency=255 mingnt=4

I think your xorg.conf needs an actual video card reference instead of the generic statement. My xorg.conf looks like this in that section:
Code:

Section "Device"
#  4-28-2008 made changes that should accomodate the full capability of the Savage video card.
#  No particular problem, just want to optimize, as can be done.  Shouldn't need to use vesa
#  when the Savage card is better than that.
        Identifier      "S3 Inc. 86C270-294 Savage/IX-MV"
#  4-28-2008 switched driver from vesa to savage
#        Driver        "vesa"
      Driver          "savage"
#      Driver          "savagefb"
#      BusID          "PCI:1:0:0"
        VideoRam        8192
#        Option          "ShadowStatus"  "true"
#        Option          "AGPMode"  "2"
#  4-28-2008 added bustype option and uncommented dmamode
        Option          "Bustype"  "PCI"
        Option          "DmaMode"  "None"
EndSection

Come on back with your specific hardware list output and maybe we can figure a good entry for your machine.

And please double check the "1711" reference, or better yet try to get the type reference from the back of the machine (i.e., 2647-84U, that's my T20).

spaje 06-16-2008 10:56 PM

Code:

thinker                 
    description: Computer
    width: 32 bits
  *-core
      description: Motherboard
      physical id: 0
    *-memory
          description: System memory
          physical id: 0
          size: 183MiB
    *-cpu
          product: Celeron (Coppermine)
          vendor: Intel Corp.
          physical id: 1
          bus info: cpu@0
          version: 6.8.6
          size: 700MHz
          width: 32 bits
          capabilities: fpu fpu_exception wp vme de pse tsc msr pae mce cx8 sep mtrr pge mca cmov pat pse36 mmx fxsr sse up
        *-cache:0
            description: L1 cache
            physical id: 0


spaje 06-17-2008 07:09 PM

I have fixed my problem thanks for all the help you all gave me

mr.simo 04-01-2010 11:24 PM

Quote:

Originally Posted by spaje (Post 3187820)
I have fixed my problem thanks for all the help you all gave me

Sorry can You tell us how you fixed your problem? Because I have the same... Thank You


All times are GMT -5. The time now is 09:08 PM.