LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Laptop and Netbook
User Name
Password
Linux - Laptop and Netbook Having a problem installing or configuring Linux on your laptop? Need help running Linux on your netbook? This forum is for you. This forum is for any topics relating to Linux and either traditional laptops or netbooks (such as the Asus EEE PC, Everex CloudBook or MSI Wind).

Notices

Closed Thread
 
Search this Thread
Old 03-09-2005, 12:49 AM   #1
cspclay
LQ Newbie
 
Registered: Mar 2005
Location: kentucky
Distribution: suse 9.2
Posts: 7

Rep: Reputation: 0
resolution too low


I am not entirely new to the linux world, I have been "tinkering" with it for a while now but I have just recently gotten into using it alot and I am currently making the transition from windows to linux on all of my computers. So far I have had very little trouble except with my laptop. I have a Gateway M305CRV laptop. Specs are as follows :
Intel P4 2.2ghz
512 mb DDR PC2100
30 gig HD
Intel 852GM chipset with integrated LAN, Audio, and Video cards.
Integrated Actiontec Wireless 802.11G LAN card
CD Rom drive
5 in 1 card reader

I am running Suse Linux 9.2 Professional. I managed to configure ndiswrapper and get my wireless network adapter runnign fairly easily. The audio card was detected and configured on boot with little help from me. The integrated intel LAN card was detected and loaded properly out of the box as well. My only problem is I cannot get my resolution to go any higher than 800x600 or 640x480. Upon the first loading of Suse, the video card was detected as an Intel 855GM video card and the monitor was set to the basic Vesa 800x600 setting. I downloaded the newest set of linux drivers for the 852/855 video cards from the Intel website and installed and configured them. I followed the directions precisely and when i was finished installing them i had extra features enabled but was still unable to increase my resolution beyond 800x600. I tried updating X to the newer 6.8.2 but this did not help out either. After updating X, i reinstalled the intel drivers and reconfigured everything all over again and but still the problem remains. I began editing my XF86Config file trying to resolve the issue but have had no success. I have a second desktop computer running Suse 9.2 as well and i compard the two different XF86Config files and found only relatively minor differences. My LCD monitor on my laptop is capable of running 1024x768 resolution at 32 bits, but so far the best i have been able to obtain is 800x600 at 24 bits. If anyone has any insight into this i would be extremely grateful for any help what-so-ever. Thank you in advance for anyone responding.

Clay Powell
 
Old 03-09-2005, 03:34 AM   #2
masand
Guru
 
Registered: May 2003
Location: INDIA
Distribution: Ubuntu, Solaris,CentOS
Posts: 5,522

Rep: Reputation: 58
what editing did u try in XF86Config file???
did u change the horizontal/vertical settings

regards
 
Old 03-09-2005, 12:10 PM   #3
shpishay
LQ Newbie
 
Registered: Mar 2005
Posts: 1

Rep: Reputation: 0
http://www.hrivnak.org/~stmiller/400vtx/ explains the problem as best as I can find. It's an issue that I, too, would definately like fixed.

Just found this: http://www.chzsoft.com.ar/855patch.html

I'll try it out tonight and let you know if it works if you don't beat me to it.

Last edited by shpishay; 03-09-2005 at 12:17 PM.
 
Old 03-09-2005, 01:17 PM   #4
cspclay
LQ Newbie
 
Registered: Mar 2005
Location: kentucky
Distribution: suse 9.2
Posts: 7

Original Poster
Rep: Reputation: 0
i already tried the link you gave me to the 855patch. it did not work for me. the way the problem is decribed there it makes sense why the video card will not go to a higher resolution and i believe that may very well be my problem but i cant figure out how to get linux to increase the video memory. the bios default for itis 8mb, but i cant change it in the bios. wheni had windows on it the driver's properties page allowed me to adjust the amount of memory alloted to the video card itself. i tried that 855patch and set it up to load on boot but it did nothing to help with my resolution. in the xf86config file i tried adjusting the different modes available to the monitor, i added viewport settings that were missing, changed the settings around for my synaptics touchpad toget rid of that annoying tap click and make my scroll wheel work right, i adjusted the vertrefresh and hsync rates as well. I am at work currently and can not post my file or i would just to let someone get a look at it and perhaps see something im missing. however as i stated in my original post i have a second computer running suse 9.2 and i compared the two different xf86config files and found very few differences. on the video card and monitor sections the only difference i found was on my laptop i have the intel card and with the i810 drivers for it and LCD monitor. on my desktop with suse 9.2 the file dhowed generic S3 for the video card and generic vesa drivers for the monitor. I tried changing my settings on my laptop to the same as the ones on my desktop and it did absolutely nothing. Thank you to all trying to help i appreciate your feedback and responses.
 
Old 03-09-2005, 03:25 PM   #5
curleyg
Member
 
Registered: Mar 2005
Posts: 37

Rep: Reputation: 15
I was having the same problem with an IBM 600E. After cursing cussing and fussing for a few hours, I stumbled on seting the colors to "thousands of colors" V. "millions of colors". I then had the options of raising the resolution. I don't notice any degradation on the lcd.
 
Old 03-09-2005, 11:10 PM   #6
cspclay
LQ Newbie
 
Registered: Mar 2005
Location: kentucky
Distribution: suse 9.2
Posts: 7

Original Poster
Rep: Reputation: 0
when i first installed suse on this laptop the default setting was thousands of colors and the resolution didnt work then either. my card is capable of running 1024x768 at 32 bit resolution. in linux the highest i can set the color setting is 24 bit and i cant even get the 1024x768 i want. im not too worried about only being able to get 24 bit color instead of 32 bit, i do however want my 1024x768 back. I only have a 15" screen and this 800x600 sucks majorly. thank you for the response and suggestion though.
 
Old 03-10-2005, 12:55 AM   #7
J.W.
LQ Veteran
 
Registered: Mar 2003
Location: Milwaukee, WI
Distribution: Mint
Posts: 6,642

Rep: Reputation: 69
Please do not post the same thread in more than one forum. Picking the most relevant forum and posting it once there makes it easier for other members to help you and keeps the discussion all in one place.

http://www.linuxquestions.org/rules.php

Please post any replies to this thread Thanks -- J.W.
 
  


Closed Thread


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Resolution Too Low BarfBag Suse/Novell 2 09-24-2005 08:05 PM
resolution too low cspclay Linux - Hardware 4 03-09-2005 01:08 PM
resolution too low cspclay Suse/Novell 1 03-09-2005 12:57 AM
low resolution fatblueduck Linux - Software 5 02-25-2005 03:25 PM
low resolution tomato Slackware 23 09-07-2003 07:45 AM


All times are GMT -5. The time now is 07:55 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration