LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Laptop and Netbook
User Name
Password
Linux - Laptop and Netbook Having a problem installing or configuring Linux on your laptop? Need help running Linux on your netbook? This forum is for you. This forum is for any topics relating to Linux and either traditional laptops or netbooks (such as the Asus EEE PC, Everex CloudBook or MSI Wind).

Notices

Reply
 
Search this Thread
Old 03-04-2008, 07:17 PM   #1
dmarti
LQ Newbie
 
Registered: Aug 2006
Location: Alameda, California
Distribution: debian, ubuntu
Posts: 4

Rep: Reputation: 0
"Rescheduling interrupts" in powertop


I have a Lenovo X61 tablet, and am trying to get the wakeups down using powertop. Kernel is the latest stable: 2.6.24.3 and I have built with CONFIG_IRQBALANCE off.

The number one item is:

<kernel IPI> : Rescheduling interrupts

which comes in at 30-35 per second. Total wakeups are 40-70 so this one item is accounting for most of the wakeups on the system.

I have tried the tip from Ingo Molnar here...
http://www.nabble.com/Re%3A-Reschedu...p15021468.html
but no apparent effect. Thanks in advance for any help or pointers.
 
Old 04-08-2008, 09:02 AM   #2
helgesdk
LQ Newbie
 
Registered: Apr 2008
Posts: 1

Rep: Reputation: 0
On my ThinkPad Z60m, acpi is responsible for a constant 25-30 wakeups or almost 50% of total when idle.
Is there any way of reducing acpi interrupts?
Unloading the thinkpad_acpi module does not help and thermal sensor polling is disabled in /proc/acpi.

Last edited by helgesdk; 04-08-2008 at 09:04 AM.
 
Old 01-12-2009, 08:14 PM   #3
RadonPL
Member
 
Registered: Dec 2005
Location: Gdansk, Poland
Distribution: openSUSE 11.0, Ubuntu 8.04
Posts: 37

Rep: Reputation: 15
I would also like to know if it is possible to reduce Rescheduling interrupts. Is this due to the Intel chipset which produces 35% of the wakeups (81 wakeups from uhci_hcd:USB4, HDA Intel, i915@pci:0000:00:02.0) or ACPI which produces 20% (72) wakeups?

Currently my Asus EeePC 901 spends only 20% in C2 and 20% in C4 state due to this problem producing an estimated 10W power usage at constant 800MHz. The CPU is supposed to use 0.1W in C4 state and 2.5W in C0 (I know it is coupled with an ancient 90nm Chipset) (OpenSUSE 11.1 + KDE 4.2)

Last edited by RadonPL; 01-12-2009 at 08:56 PM.
 
  


Reply

Tags
irq, powertop


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
powertop reporting a huge number of acpi interrupts gawhelan Linux - Laptop and Netbook 5 01-15-2009 03:12 AM
net working eth0 eth1 wlan0 "no connection" "no LAN" "no wi-fi" Cayitano Linux - Newbie 5 12-09-2007 08:11 PM
Standard commands give "-bash: open: command not found" even in "su -" and "su root" mibo12 Linux - General 4 11-11-2007 11:18 PM
"Xlib: extension "XFree86-DRI" missing on display ":0.0"." zaps Linux - Games 9 05-14-2007 04:07 PM
LXer: Displaying "MyComputer", "Trash", "Network Servers" Icons On A GNOME Desktop LXer Syndicated Linux News 0 04-02-2007 09:31 AM


All times are GMT -5. The time now is 08:11 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration