LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Laptop and Netbook (http://www.linuxquestions.org/questions/linux-laptop-and-netbook-25/)
-   -   "Rescheduling interrupts" in powertop (http://www.linuxquestions.org/questions/linux-laptop-and-netbook-25/rescheduling-interrupts-in-powertop-625728/)

dmarti 03-04-2008 06:17 PM

"Rescheduling interrupts" in powertop
 
I have a Lenovo X61 tablet, and am trying to get the wakeups down using powertop. Kernel is the latest stable: 2.6.24.3 and I have built with CONFIG_IRQBALANCE off.

The number one item is:

<kernel IPI> : Rescheduling interrupts

which comes in at 30-35 per second. Total wakeups are 40-70 so this one item is accounting for most of the wakeups on the system.

I have tried the tip from Ingo Molnar here...
http://www.nabble.com/Re%3A-Reschedu...p15021468.html
but no apparent effect. Thanks in advance for any help or pointers.

helgesdk 04-08-2008 08:02 AM

On my ThinkPad Z60m, acpi is responsible for a constant 25-30 wakeups or almost 50% of total when idle.
Is there any way of reducing acpi interrupts?
Unloading the thinkpad_acpi module does not help and thermal sensor polling is disabled in /proc/acpi.

RadonPL 01-12-2009 07:14 PM

I would also like to know if it is possible to reduce Rescheduling interrupts. Is this due to the Intel chipset which produces 35% of the wakeups (81 wakeups from uhci_hcd:USB4, HDA Intel, i915@pci:0000:00:02.0) or ACPI which produces 20% (72) wakeups?

Currently my Asus EeePC 901 spends only 20% in C2 and 20% in C4 state due to this problem producing an estimated 10W power usage at constant 800MHz. The CPU is supposed to use 0.1W in C4 state and 2.5W in C0 (I know it is coupled with an ancient 90nm Chipset) (OpenSUSE 11.1 + KDE 4.2)


All times are GMT -5. The time now is 05:37 AM.