LinuxQuestions.org
LinuxAnswers - the LQ Linux tutorial section.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Laptop and Netbook
User Name
Password
Linux - Laptop and Netbook Having a problem installing or configuring Linux on your laptop? Need help running Linux on your netbook? This forum is for you. This forum is for any topics relating to Linux and either traditional laptops or netbooks (such as the Asus EEE PC, Everex CloudBook or MSI Wind).

Notices

Reply
 
Search this Thread
Old 10-07-2004, 03:17 PM   #1
such007
LQ Newbie
 
Registered: Sep 2004
Location: Baltimore, MD
Distribution: Fedora Core 2
Posts: 5

Rep: Reputation: 0
R51 with Intel 2200BG wireless card on FC2


Ive been fighting with the wireless card on this machine for a little while now. I am attempting to use Linuxant.com's driverloader. I have installed the (2.6.8.1) kernel from kernel.org which supposedly fixes the stack problem in many of the standard kernels. Apparently windows drivers need a lot of stack space to run. Anyway onto the problem.

After installing the driverloader software, loading the necessary files for driverloader, and setting my wireless settings to match my current network configuration at home, I still cannot obtain an IP address through DHCP or otherwise. Do I need to have my firewall turned off? Any hints would be helpful.

Thanks

Scott
 
Old 10-08-2004, 05:09 PM   #2
philipacamaniac
Member
 
Registered: Oct 2003
Distribution: Slackware 10, Slackware-current, Slax
Posts: 50

Rep: Reputation: 15
Please don't tell me you PAID for DriverLoader! I suggest not using the DriverLoader, because it requires kernel 2.6.8.1, except that 2.6.8.1 is unstable as far as many are concerned. What you should do is install the Intel-supported native Linux drivers from http://ipw2200.sourceforge.net/ . The maintainer of that driver is an employee of the Intel Corp. The minimum kernel requirements for ipw2200 is 2.6.4... Bear in mind that this driver is still under active development, but I've tried it on my Centrino laptop and it works great for my purposes.

Receiving an IP address from your router is not affected by the router's firewall. If you can connect, but receive no IP, check to make sure you are not using MAC authentication, or, if you are, make sure that the MAC address is in your access point's "ACCEPT" list. If that is not the case, try manually configuring your IP address, setting the default gateway as your router's IP, and the DNS servers as your ISP's official DNS servers. That should get you in no matter what, unless MAC authentication is enabled and improperly configured.

For troubleshooting purposes with wireless networks, I always disable ALL security features (WEP/WPA/MAC) and start from there. Many security features are not supported by certain cards and/or drivers.

Hope that helps.

Last edited by philipacamaniac; 10-08-2004 at 05:11 PM.
 
Old 10-09-2004, 03:52 PM   #3
such007
LQ Newbie
 
Registered: Sep 2004
Location: Baltimore, MD
Distribution: Fedora Core 2
Posts: 5

Original Poster
Rep: Reputation: 0
thanks a bunch for the swift reply, I was very surprised to see an answer last evening. So far everything seems to be going just fine, but when I try to do the make command, i get all sorts of errors:

[scott@localhost ipw2200-0.10]$ make
make -C /lib/modules/2.6.8-1.521/build SUBDIRS=/home/scott/temp/ipw2200-0.10 MODVERDIR=/home/scott/temp/ipw2200-0.10 modulesmake[1]: Entering directory `/lib/modules/2.6.8-1.521/build'
Building modules, stage 2.
MODPOST
*** Warning: "ieee80211_free" [/home/scott/temp/ipw2200-0.10/ipw2200.ko] has no CRC!
*** Warning: "ieee80211_alloc" [/home/scott/temp/ipw2200-0.10/ipw2200.ko] has no CRC!
*** Warning: "ieee80211_wx_get_encode" [/home/scott/temp/ipw2200-0.10/ipw2200.ko] has no CRC!
*** Warning: "ieee80211_wx_set_encode" [/home/scott/temp/ipw2200-0.10/ipw2200.ko] has no CRC!
*** Warning: "ieee80211_wx_get_scan" [/home/scott/temp/ipw2200-0.10/ipw2200.ko] has no CRC!
*** Warning: "ieee80211_rx" [/home/scott/temp/ipw2200-0.10/ipw2200.ko] has no CRC!
*** Warning: "ieee80211_rx_mgt" [/home/scott/temp/ipw2200-0.10/ipw2200.ko] has no CRC!
*** Warning: "ieee80211_skb_to_txb" [/home/scott/temp/ipw2200-0.10/ipw2200.ko] has no CRC!
*** Warning: "ieee80211_txb_free" [/home/scott/temp/ipw2200-0.10/ipw2200.ko] has no CRC!
*** Warning: "ieee80211_unregister_crypto_ops" [/home/scott/temp/ipw2200-0.10/ieee80211_crypt_wep.ko] has no CRC!
*** Warning: "ieee80211_register_crypto_ops" [/home/scott/temp/ipw2200-0.10/ieee80211_crypt_wep.ko] has no CRC!
*** Warning: "ieee80211_crypt_deinit_handler" [/home/scott/temp/ipw2200-0.10/ieee80211.ko] has no CRC!
*** Warning: "ieee80211_crypt_delayed_deinit" [/home/scott/temp/ipw2200-0.10/ieee80211.ko] has no CRC!
*** Warning: "ieee80211_crypt_deinit_entries" [/home/scott/temp/ipw2200-0.10/ieee80211.ko] has no CRC!
*** Warning: "ieee80211_get_crypto_ops" [/home/scott/temp/ipw2200-0.10/ieee80211.ko] has no CRC!
make[1]: Leaving directory `/lib/modules/2.6.8-1.521/build'

I read all the documentation and checked my kernel to make sure that everything was configured the way they suggest. I moved the firmware files to the proper location. My only issue seems to be this CRC thing...

The documentation says something like this:

KERNEL REQUIREMENTS - Crypto Library
---------- -------- --------- ----- ----- --- -- -
IPW2200 uses the WEP encryption and decryption algorimths provided
by the Linux kernel. As such, in order to use WEP you must enable the
Crypto library support (CONFIG_CRYPTO) and the following algorithms:

ARC4 cipher algorithm (CONFIG_CRYPTO_ARC4)

You also need to enable the following from Library routines:

CRC32 (CONFIG_CRC32)

I do not know what exactly this means. I am very much a newb with Linux and this seems to be my only roadblock using the driver. Got any suggestions on this one?

Thanks in advance

Scott
 
Old 10-09-2004, 04:57 PM   #4
philipacamaniac
Member
 
Registered: Oct 2003
Distribution: Slackware 10, Slackware-current, Slax
Posts: 50

Rep: Reputation: 15
Quote:
Driver Compile

3.1. I see CRC warnings of the format (<file>) has no CRC! when I compile the kernel.
This is due to a bug in the kernel build process and is benign.
This is from the FAQ. Did you try a make install after compiling? Or did the compiling never finish? You might also try some of the RedHat/Fedora specific packages that I believe are binary versions of the module.

I tried it on Slack with the test build of kernel 2.6.7; I don't know much about RH.
 
Old 10-09-2004, 05:04 PM   #5
philipacamaniac
Member
 
Registered: Oct 2003
Distribution: Slackware 10, Slackware-current, Slax
Posts: 50

Rep: Reputation: 15
I found an open source project that enables you to use Windows wireless drivers. I guess that's what DriverLoader does, but DriverLoader costs money. Anyway, the project is called NdisWrapper and can be found at http://ndiswrapper.sourceforge.net/

If you can't get the native ipw2200 to work, maybe give this one a try; the Intel 2200BG is listed as a supported card.
 
Old 10-09-2004, 08:16 PM   #6
such007
LQ Newbie
 
Registered: Sep 2004
Location: Baltimore, MD
Distribution: Fedora Core 2
Posts: 5

Original Poster
Rep: Reputation: 0
I ignored the warnings, did the make install, and restarted the machine. When it restarted, it found the new hardware, I set it for dhcp, and found that the device was listed in Network Configuration. However when I go to activate it, it says:

ipw2200 device eth1 does not seem to be present, delaying initialization.

Under the hardware tab on Network Configuration it does say that the status is "ok."

NDISwrapper aparently has issues with the stack size in FC2, thats why i'm not using it.
 
Old 10-11-2004, 09:33 PM   #7
coops1
Newbie
 
Registered: Sep 2004
Distribution: Fedora Core 2
Posts: 5

Rep: Reputation: 0
Quote:
Originally posted by such007
ipw2200 device eth1 does not seem to be present, delaying initialization.
I managed to get my centrino wlan to work with FC2 (Sony Vaio VGN-A17GP) using the ipw2200 drivers. Also worked with linuxant (windows drivers) but i am not about to pay to keep using it.

Check the output of dmesg to see if the firmware has been loaded,
#dmesg | grep ipw2200

also, since you have done a make install make sure you do the modprobe ipw2200 see install guide, very last line.

I didnt need to do a restart to get it to work, actually if i restart the machine i get the dmesg error that the firmwire did not load and need to modprobe ipw2200 to get it up.

Quote:
Under the hardware tab on Network Configuration it does say that the status is "ok."
I do all my stuff from the command line, i have read about problems with FC2 net config tool and wlan interfaces, i think its ok if it appears as an eth? interface rather than wlan? interface but not sure right now.

to check if the card is ready do iwconfig
#iwconfig

you should see wireless tools/extensions available for one of the interfaces, non wireless interfaces will report no wireless tools/extensions.

if the wireless interface is not reported in the list when you do ifconfig (#ifconfig) you will need to do
#ifup eth1
replace 1 with the number for you wireless interface

once the interface is up you need to associate it with you access point, i use iwconfig to do this (you can also set the details up in the eth1-cfg file - do not have that info at hand right now), see the man page for more details on iwconfig. I am pretty sure once i set up the essid i then see details of Access Point MAC address and signal strength in the output of #iwconfig eth1. Its a good idea to ensure the WEP is turned off on the access point until you can associate in the clear before playing with encrypted/restricted mode.

Quote:
NDISwrapper aparently has issues with the stack size in FC2, thats why i'm not using it.
I tryed this out as well but kept freezing the system.


Sorry if this is lacking in some detail, i am doing this from memory without access to my laptop right now.

Hope it helps,
 
Old 10-11-2004, 11:30 PM   #8
such007
LQ Newbie
 
Registered: Sep 2004
Location: Baltimore, MD
Distribution: Fedora Core 2
Posts: 5

Original Poster
Rep: Reputation: 0
Smile

Thanks a bunch for your reply. I actually just got it up and running today. My workaround was this...

after doing all the installs according to the install doc, i ran (as root):

% rmmod ipw2200
% modprobe ipw2200
% iwconfig

After these, everything worked. I was getting the message in dmesg about the firmware not loading so this is the workaround that I came up with.

There are also apparently some rpms for this stuff out there too. I did not try them but they may be worth looking into.

Thanks much all
 
Old 10-13-2004, 11:01 AM   #9
vasundhar
LQ Newbie
 
Registered: Oct 2004
Location: India
Distribution: Redhat 9,RHEL
Posts: 8

Rep: Reputation: 0
Ooops bugged of RELinux
Its not detecting my ethernet adapter and hence not able to connect to my lan and no updates possible ...
If any one of u find driver for that please let me know
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Intel PRO/Wireless 2200BG henriette Linux - Laptop and Netbook 5 05-20-2007 02:50 PM
Intel PRO/Wireless 2200BG wfischer Linux - Wireless Networking 3 10-25-2006 09:20 AM
Intel pro/wireless 2200BG lobwolf Linux - Wireless Networking 27 11-01-2005 10:20 AM
Intel 2200BG wireless problems idahoakl Suse/Novell 4 03-12-2005 08:24 AM
FC2 not recognizing the Intel PRO/Wireless 2200BG wireless card mdslf Linux - Laptop and Netbook 2 08-24-2004 02:25 AM


All times are GMT -5. The time now is 10:16 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration