LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Laptop and Netbook (http://www.linuxquestions.org/questions/linux-laptop-and-netbook-25/)
-   -   Problems with wireless network card on Toshiba Satellite Pro A60/Ubuntu 5.10 (http://www.linuxquestions.org/questions/linux-laptop-and-netbook-25/problems-with-wireless-network-card-on-toshiba-satellite-pro-a60-ubuntu-5-10-a-387093/)

CTM 11-27-2005 06:19 PM

Problems with wireless network card on Toshiba Satellite Pro A60/Ubuntu 5.10
 
Hi there :)

I'm having big big problems getting my PCMCIA wireless network card working on Linux. Basically I plug in my card and the power light comes on, but there's no network activity - I don't think Linux can even see my card. This is on a laptop (Toshiba Satellite Pro A60). I'm currently using the latest version of Ubuntu (5.10), and a Linksys WPC54G wireless card (it has "v1.2" written on the bottom for what it's worth).

I've also tried using a Netgear card with both ndiswrapper and Linuxant, so I'm guessing this isn't a card problem. The laptop has a Texas Instruments PCI1410 PCI controller, and apparently this takes some configuration to work on Linux. Both cards work perfectly on Windows XP (dual-boot).

Here's some output from various commands. I suck at Linux so I might have gotten this wrong - if so please let me know and I'll supply whatever information I can.

uname -r:

Quote:

2.6.12-9-386
lspci:

Quote:

0000:00:00.0 Host bridge: ATI Technologies Inc: Unknown device cab3 (rev 05)
0000:00:01.0 PCI bridge: ATI Technologies Inc PCI Bridge [IGP 340M]
0000:00:13.0 USB Controller: ATI Technologies Inc: Unknown device 4347 (rev 01)
0000:00:13.1 USB Controller: ATI Technologies Inc: Unknown device 4348 (rev 01)
0000:00:13.2 USB Controller: ATI Technologies Inc: Unknown device 4345 (rev 01)
0000:00:14.0 SMBus: ATI Technologies Inc ATI SMBus (rev 18)
0000:00:14.1 IDE interface: ATI Technologies Inc: Unknown device 4349
0000:00:14.3 ISA bridge: ATI Technologies Inc: Unknown device 434c
0000:00:14.4 PCI bridge: ATI Technologies Inc: Unknown device 4342
0000:00:14.5 Multimedia audio controller: ATI Technologies Inc IXP150 AC'97 Audio Controller
0000:00:14.6 Modem: ATI Technologies Inc: Unknown device 434d (rev 01)
0000:01:05.0 VGA compatible controller: ATI Technologies Inc: Unknown device 4437
0000:02:06.0 CardBus bridge: Texas Instruments PCI1410 PC card Cardbus Controller (rev 02)
0000:02:07.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL-8139/8139C/8139C+ (rev 10)
0000:02:0a.0 FireWire (IEEE 1394): Texas Instruments TSB43AB21 IEEE-1394a-2000 Controller (PHY/Link)
cardctl ident:

Quote:

Socket 0:
no product info available
dmesg (card inserted before I booted the laptop):

Quote:

[4294668.886000] not found!
[4294668.934000] ENABLING IO-APIC IRQs
[4294668.934000] ..TIMER: vector=0x31 pin1=2 pin2=-1
[4294669.045000] NET: Registered protocol family 16
[4294669.045000] EISA bus registered
[4294669.045000] ACPI: bus type pci registered
[4294669.045000] PCI: PCI BIOS revision 2.10 entry at 0xe9964, last bus=2
[4294669.045000] PCI: Using configuration type 1
[4294669.045000] mtrr: v2.0 (20020519)
[4294669.046000] ACPI: Subsystem revision 20050729
[4294669.060000] ACPI: Interpreter enabled
[4294669.060000] ACPI: Using IOAPIC for interrupt routing
[4294669.061000] ACPI: PCI Root Bridge [PCI0] (0000:00)
[4294669.061000] PCI: Probing PCI hardware (bus 00)
[4294669.062000] ACPI: Assume root bridge [\_SB_.PCI0] segment is 0
[4294669.062000] ACPI: Assume root bridge [\_SB_.PCI0] bus is 0
[4294669.063000] PCI: Ignoring BAR0-3 of IDE controller 0000:00:14.1
[4294669.064000] Boot video device is 0000:01:05.0
[4294669.064000] PCI: Transparent bridge - 0000:00:14.4
[4294669.068000] ACPI: PCI Interrupt Routing Table [\_SB_.PCI0._PRT]
[4294669.069000] ACPI: PCI Interrupt Routing Table [\_SB_.PCI0.AGP_._PRT]
[4294669.071000] ACPI: PCI Interrupt Link [LNK0] (IRQs 5 7 10 *11)
[4294669.072000] ACPI: PCI Interrupt Link [LNK1] (IRQs 5 7 *10 11)
[4294669.072000] ACPI: PCI Interrupt Link [LNK2] (IRQs 5 7 10 *11)
[4294669.073000] ACPI: PCI Interrupt Link [LNK3] (IRQs *5 7 10 11)
[4294669.074000] burst-mode-ec-10-Aug
[4294669.074000] ACPI: Embedded Controller [EC0] (gpe 7)
[4294669.085000] ACPI: Power Resource [PUT2] (on)
[4294669.085000] ACPI: PCI Interrupt Routing Table [\_SB_.PCI0.P2P_._PRT]
[4294669.086000] ACPI: Power Resource [PFA1] (off)
[4294669.087000] Linux Plug and Play Support v0.97 (c) Adam Belay
[4294669.087000] pnp: PnP ACPI init
[4294669.092000] pnp: PnP ACPI: found 11 devices
[4294669.092000] PnPBIOS: Disabled by ACPI PNP
[4294669.092000] PCI: Using ACPI for IRQ routing
[4294669.092000] PCI: If a device doesn't work, try "pci=routeirq". If it helps, post a report
[4294669.095000] pnp: 00:06: ioport range 0x200-0x20f has been reserved
[4294669.095000] pnp: 00:06: ioport range 0x280-0x29f has been reserved
[4294669.095000] pnp: 00:06: ioport range 0x40b-0x40b has been reserved
[4294669.096000] Simple Boot Flag at 0x37 set to 0x1
[4294669.097000] audit: initializing netlink socket (disabled)
[4294669.097000] audit: initialized
[4294669.097000] highmem bounce pool size: 64 pages
[4294669.097000] VFS: Disk quotas dquot_6.5.1
[4294669.097000] Dquot-cache hash table entries: 1024 (order 0, 4096 bytes)
[4294669.097000] devfs: 2004-01-31 Richard Gooch (rgooch@atnf.csiro.au)
[4294669.097000] devfs: boot_options: 0x0
[4294669.097000] Initializing Cryptographic API
[4294669.098000] isapnp: Scanning for PnP cards...
[4294669.452000] isapnp: No Plug & Play device found
[4294669.571000] PNP: PS/2 Controller [PNP0303:KBC0,PNP0f13:PS2M] at 0x60,0x64 irq 1,12
[4294669.574000] serio: i8042 AUX port at 0x60,0x64 irq 12
[4294669.574000] serio: i8042 KBD port at 0x60,0x64 irq 1
[4294669.574000] Serial: 8250/16550 driver $Revision: 1.90 $ 54 ports, IRQ sharing enabled
[4294669.575000] ttyS2 at I/O 0x3e8 (irq = 4) is a 16550A
[4294669.585000] ACPI: PCI Interrupt 0000:00:14.6[B] -> GSI 17 (level, low) -> IRQ 17
[4294669.585000] ACPI: PCI interrupt for device 0000:00:14.6 disabled
[4294669.585000] io scheduler noop registered
[4294669.585000] io scheduler anticipatory registered
[4294669.585000] io scheduler deadline registered
[4294669.585000] io scheduler cfq registered
[4294669.587000] RAMDISK driver initialized: 16 RAM disks of 65536K size 1024 blocksize
[4294669.587000] EISA: Probing bus 0 at eisa.0
[4294669.587000] Cannot allocate resource for EISA slot 4
[4294669.587000] Cannot allocate resource for EISA slot 8
[4294669.587000] EISA: Detected 0 cards.
[4294669.587000] NET: Registered protocol family 2
[4294669.597000] IP: routing cache hash table of 16384 buckets, 128Kbytes
[4294669.597000] TCP established hash table entries: 262144 (order: 9, 2097152 bytes)
[4294669.602000] TCP bind hash table entries: 65536 (order: 6, 262144 bytes)
[4294669.603000] TCP: Hash tables configured (established 262144 bind 65536)
[4294669.603000] NET: Registered protocol family 8
[4294669.603000] NET: Registered protocol family 20
[4294669.603000] ACPI wakeup devices:
[4294669.603000] LID USB0 USB1 USB2 MC97 P2P LAN0
[4294669.603000] ACPI: (supports S0 S3 S4 S5)
[4294669.604000] Freeing unused kernel memory: 224k freed
[4294669.636000] input: AT Translated Set 2 keyboard on isa0060/serio0
[4294669.650000] vga16fb: initializing
[4294669.650000] vga16fb: mapped to 0xc00a0000
[4294669.778000] Console: switching to colour frame buffer device 80x30
[4294669.778000] fb0: VGA16 VGA frame buffer device
[4294670.918000] Capability LSM initialized
[4294670.941000] NET: Registered protocol family 1
[4294670.966000] Uniform Multi-Platform E-IDE driver Revision: 7.00alpha2
[4294670.966000] ide: Assuming 33MHz system bus speed for PIO modes; override with idebus=xx
[4294670.966000] ACPI: bus type ide registered
[4294670.985000] ATIIXP: IDE controller at PCI slot 0000:00:14.1
[4294670.985000] ACPI: PCI Interrupt 0000:00:14.1[A] -> GSI 16 (level, low) -> IRQ 16
[4294670.985000] ATIIXP: chipset revision 0
[4294670.985000] ATIIXP: not 100% native mode: will probe irqs later
[4294670.985000] ide0: BM-DMA at 0x8070-0x8077, BIOS settings: hda:DMA, hdb:pio
[4294670.985000] ide1: BM-DMA at 0x8078-0x807f, BIOS settings: hdc:DMA, hdd:pio
[4294670.985000] Probing IDE interface ide0...
[4294671.249000] hda: TOSHIBA MK4025GAS, ATA DISK drive
[4294671.861000] ide0 at 0x1f0-0x1f7,0x3f6 on irq 14
[4294671.861000] Probing IDE interface ide1...
[4294672.533000] hdc: TOSHIBA DVD-ROM SD-R2512, ATAPI CD/DVD-ROM drive
[4294673.145000] ide1 at 0x170-0x177,0x376 on irq 15
[4294673.145000] ide2: I/O resource 0x3EE-0x3EE not free.
[4294673.145000] ide2: ports already in use, skipping probe
[4294673.145000] Probing IDE interface ide3...
[4294673.658000] Probing IDE interface ide4...
[4294674.171000] Probing IDE interface ide5...
[4294674.691000] hda: max request size: 128KiB
[4294674.740000] hda: 78140160 sectors (40007 MB), CHS=65535/16/63, UDMA(100)
[4294674.740000] hda: cache flushes supported
[4294674.740000] /dev/ide/host0/bus0/target0/lun0: p1 p2 p3
[4294674.843000] hdc: ATAPI 24X DVD-ROM CD-R/RW drive, 2048kB Cache
[4294674.843000] Uniform CD-ROM driver Revision: 3.20
[4294675.774000] Attempting manual resume
[4294675.822000] swsusp: Suspend partition has wrong signature?
[4294675.853000] usbcore: registered new driver usbfs
[4294675.853000] usbcore: registered new driver hub
[4294675.854000] ohci_hcd: 2004 Nov 08 USB 1.1 'Open' Host Controller (OHCI) Driver (PCI)
[4294675.855000] ACPI: PCI Interrupt 0000:00:13.0[A] -> GSI 19 (level, low) -> IRQ 19
[4294675.855000] ohci_hcd 0000:00:13.0: ATI Technologies Inc OHCI USB Controller #1
[4294675.855000] ohci_hcd 0000:00:13.0: new USB bus registered, assigned bus number 1
[4294675.855000] ohci_hcd 0000:00:13.0: irq 19, io mem 0xf0001000
[4294675.870000] hub 1-0:1.0: USB hub found
[4294675.870000] hub 1-0:1.0: 3 ports detected
[4294675.875000] ACPI: PCI Interrupt 0000:00:13.1[A] -> GSI 19 (level, low) -> IRQ 19
[4294675.875000] ohci_hcd 0000:00:13.1: ATI Technologies Inc OHCI USB Controller #2
[4294675.875000] ohci_hcd 0000:00:13.1: new USB bus registered, assigned bus number 2
[4294675.875000] ohci_hcd 0000:00:13.1: irq 19, io mem 0xf0002000
[4294675.930000] hub 2-0:1.0: USB hub found
[4294675.930000] hub 2-0:1.0: 3 ports detected
[4294675.955000] PCI: Enabling device 0000:00:13.2 (0000 -> 0002)
[4294675.955000] ACPI: PCI Interrupt 0000:00:13.2[A] -> GSI 19 (level, low) -> IRQ 19
[4294675.955000] ehci_hcd 0000:00:13.2: ATI Technologies Inc EHCI USB Controller[4294675.955000] ehci_hcd 0000:00:13.2: new USB bus registered, assigned bus number 3
[4294675.955000] ehci_hcd 0000:00:13.2: irq 19, io mem 0x4c000000
[4294675.955000] ehci_hcd 0000:00:13.2: USB 2.0 initialized, EHCI 1.00, driver 10 Dec 2004
[4294675.955000] hub 3-0:1.0: USB hub found
[4294675.956000] hub 3-0:1.0: 6 ports detected
[4294676.061000] 8139cp: 10/100 PCI Ethernet driver v1.2 (Mar 22, 2004)
[4294676.061000] 8139cp: pci dev 0000:02:07.0 (id 10ec:8139 rev 10) is not an 8139C+ compatible chip
[4294676.061000] 8139cp: Try the "8139too" driver instead.
[4294676.063000] 8139too Fast Ethernet driver 0.9.27
[4294676.063000] ACPI: PCI Interrupt 0000:02:07.0[A] -> GSI 18 (level, low) -> IRQ 18
[4294676.064000] eth0: RealTek RTL8139 at 0xa000, 00:a0:d1:b1:02:21, IRQ 18
[4294676.064000] eth0: Identified 8139 chip type 'RTL-8100B/8139D'
[4294676.552000] usb 1-3: new low speed USB device using ohci_hcd and address 2
[4294678.097000] usbcore: registered new driver hiddev
[4294678.104000] input: USB HID v1.10 Mouse [ELECOM ELECOM USB mouse with wheel ] on usb-0000:00:13.0-3
[4294678.104000] usbcore: registered new driver usbhid
[4294678.104000] drivers/usb/input/hid-core.c: v2.01:USB HID core driver
[4294679.149000] ACPI: Fan [FAN1] (off)
[4294679.155000] ACPI: CPU0 (power states: C1[C1] C2[C2])
[4294679.183000] ACPI: Thermal Zone [THZN] (57 C)
[4294679.477000] Attempting manual resume
[4294679.489000] swsusp: Suspend partition has wrong signature?
[4294679.519000] kjournald starting. Commit interval 5 seconds
[4294679.520000] EXT3-fs: mounted filesystem with ordered data mode.
[4294680.992000] md: md driver 0.90.1 MAX_MD_DEVS=256, MD_SB_DISKS=27
[4294686.868000] Adding 690784k swap on /dev/hda3. Priority:-1 extents:1
[4294687.222000] EXT3 FS on hda2, internal journal
[4294695.990000] parport: PnPBIOS parport detected.
[4294695.990000] parport0: PC-style at 0x378 (0x778), irq 7, dma 3 [PCSPP,TRISTATE,COMPAT,ECP,DMA]
[4294696.085000] lp0: using parport0 (interrupt-driven).
[4294696.148000] mice: PS/2 mouse device common for all mice
[4294696.240000] ieee1394: Initialized config rom entry `ip1394'
[4294696.279000] SCSI subsystem initialized
[4294696.290000] sbp2: $Rev: 1219 $ Ben Collins <bcollins@debian.org>
[4294696.445000] ndiswrapper version 1.1 loaded (preempt=no,smp=no)
[4294696.631000] ndiswrapper (wrapper_init:1534): loadndiswrapper failed (1792); check system log for messages from 'loadndisdriver'
[4294697.000000] Synaptics Touchpad, model: 1, fw: 5.9, id: 0xa56eb1, caps: 0x804713/0x0
[4294697.000000] synaptics: Toshiba Satellite Pro A60 detected, limiting rate to 40pps.
[4294697.011000] input: SynPS/2 Synaptics TouchPad on isa0060/serio1
[4294698.399000] ts: Compaq touchscreen protocol output
[4294700.467000] device-mapper: 4.4.0-ioctl (2005-01-12) initialised: dm-devel@redhat.com
[4294701.708000] cdrom: open failed.
[4294704.263000] Linux agpgart interface v0.101 (c) Dave Jones
[4294704.282000] agpgart: Detected Ati IGP7000/M chipset
[4294704.317000] agpgart: AGP aperture is 64M @ 0xb0000000
[4294704.737000] pci_hotplug: PCI Hot Plug PCI Core version: 0.5
[4294704.750000] shpchp: acpi_shpchprm:\_SB_.PCI0 evaluate _BBN fail=0x5
[4294704.750000] shpchp: acpi_shpchprm:get_device PCI ROOT HID fail=0x5
[4294705.674000] ACPI: PCI Interrupt 0000:00:14.5[B] -> GSI 17 (level, low) -> IRQ 17
[4294705.675000] atiixp: codec reset timeout
[4294707.163000] ACPI: PCI Interrupt 0000:00:14.6[B] -> GSI 17 (level, low) -> IRQ 17
[4294707.729000] Linux Kernel Card Services
[4294707.729000] options: [pci] [cardbus] [pm]
[4294707.758000] ACPI: PCI Interrupt 0000:02:06.0[A] -> GSI 19 (level, low) -> IRQ 19
[4294707.758000] Yenta: CardBus bridge found at 0000:02:06.0 [1179:ff10]
[4294707.758000] Yenta: Enabling burst memory read transactions
[4294707.758000] Yenta: Using CSCINT to route CSC interrupts to PCI
[4294707.758000] Yenta: Routing CardBus interrupts to PCI
[4294707.758000] Yenta TI: socket 0000:02:06.0, mfunc 0x01111122, devctl 0x64
[4294707.979000] Yenta: ISA IRQ mask 0x0c78, PCI irq 19
[4294707.979000] Socket status: 30000020
[4294708.302000] ohci1394: $Rev: 1250 $ Ben Collins <bcollins@debian.org>
[4294708.302000] ACPI: PCI Interrupt 0000:02:0a.0[A] -> GSI 19 (level, low) -> IRQ 19
[4294708.364000] ohci1394: fw-host0: OHCI-1394 1.1 (PCI): IRQ=[19] MMIO=[d0000000-d00007ff] Max Packet=[2048]
[4294709.626000] ieee1394: Host added: ID:BUS[0-00:1023] GUID[00080da0d1b10221][4294710.479000] Real Time Clock Driver v1.12
[4294710.651000] input: PC Speaker
[4294712.988000] eth0: link down
[4294713.007000] NET: Registered protocol family 17
[4294781.238000] ACPI: AC Adapter [AC] (off-line)
[4294781.322000] ACPI: Battery Slot [BAT1] (battery present)
[4294781.355000] ACPI: Power Button (FF) [PWRF]
[4294781.355000] ACPI: Lid Switch [LID]
[4294781.355000] ACPI: Power Button (CM) [PWRB]
[4294781.555000] ibm_acpi: ec object not found
[4294791.648000] [drm] Initialized drm 1.0.0 20040925
[4294791.666000] ACPI: PCI Interrupt 0000:01:05.0[A] -> GSI 16 (level, low) -> IRQ 16
[4294791.670000] [drm] Initialized radeon 1.16.0 20050311 on minor 0: ATI Technologies Inc Radeon Mobility 7000 IGP
[4294791.672000] agpgart: Found an AGP 2.0 compliant device at 0000:00:00.0.
[4294791.672000] agpgart: Putting AGP V2 device at 0000:00:00.0 into 4x mode
[4294791.672000] agpgart: Putting AGP V2 device at 0000:01:05.0 into 4x mode
[4294795.748000] apm: BIOS version 1.2 Flags 0x03 (Driver version 1.16ac)
[4294795.748000] apm: overridden by ACPI.
[4294797.407000] cs: IO port probe 0x100-0x4ff: excluding 0x220-0x227 0x300-0x307 0x310-0x317 0x4d0-0x4d7
[4294797.409000] cs: IO port probe 0xc00-0xcf7: excluding 0xc00-0xc07 0xc10-0xc17 0xc50-0xc57 0xc68-0xc6f 0xcd0-0xcd7
[4294797.410000] cs: IO port probe 0xa00-0xaff: clean.
[4294801.061000] Bluetooth: Core ver 2.7
[4294801.061000] NET: Registered protocol family 31
[4294801.061000] Bluetooth: HCI device and connection manager initialized
[4294801.062000] Bluetooth: HCI socket layer initialized
[4294801.142000] Bluetooth: L2CAP ver 2.7
[4294801.142000] Bluetooth: L2CAP socket layer initialized
[4294801.192000] Bluetooth: RFCOMM ver 1.5
[4294801.192000] Bluetooth: RFCOMM socket layer initialized
[4294801.192000] Bluetooth: RFCOMM TTY layer initialized
[4294808.161000] NET: Registered protocol family 10
[4294808.161000] Disabled Privacy Extensions on device c02eb280(lo)
[4294808.161000] IPv6 over IPv4 tunneling driver
[4294818.608000] eth0: no IPv6 routers present
Thanks for your help :)

XavierP 11-28-2005 01:44 PM

I have that model of card and an A10 and kernel 2.6.13. Go to the Ndiswrapper page and install it using the instructions. It's never failed for me - and I have used it with a 2.4.x kernel as well as 2.6.x.

CTM 11-28-2005 02:04 PM

Quote:

Originally posted by XavierP
I have that model of card and an A10 and kernel 2.6.13. Go to the Ndiswrapper page and install it using the instructions. It's never failed for me - and I have used it with a 2.4.x kernel as well as 2.6.x.
Thanks for the reassurance. :) Two questions:

(a) Does the A10 have the same PCI controller (TI PCI1410) as the A60;
(b) Which drivers should I use with ndiswrapper? Could you post a link to the ones that you're using, please?

Thanks loads for the help :)

XavierP 11-28-2005 04:46 PM

a) no idea, sorry

b) http://ndiswrapper.sourceforge.net/m...dex.php/List#L is where I found the drivers and http://ndiswrapper.sourceforge.net/m...p/Installation has the install instructions read them fully and follow them closely

I would have posted my lspci results, but my laptop has died - hard drive problems. Go here to read them (thank god I posted them up :)) and to compare with yours.


All times are GMT -5. The time now is 03:28 PM.