LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Laptop and Netbook
User Name
Password
Linux - Laptop and Netbook Having a problem installing or configuring Linux on your laptop? Need help running Linux on your netbook? This forum is for you. This forum is for any topics relating to Linux and either traditional laptops or netbooks (such as the Asus EEE PC, Everex CloudBook or MSI Wind).

Notices

Reply
 
Search this Thread
Old 03-17-2005, 11:03 AM   #1
daguerr
LQ Newbie
 
Registered: Mar 2005
Posts: 4

Rep: Reputation: 0
Problems with res 1280x800


Hi,

i'm having trouble with resolution on Debian Linux. I have the XFree86 server runing, and installed the nvidia drivers for my nVidia GeForceGo 6200. This part works fine, but i have trouble setting the resolution of the screen. It's an X-Black widescreen which supports 1280x800, but i can only display at 1024x768.

I've tried many configurations but nothing worked at all.

Another trouble with screen is that console mode is only 640x480. Anybody knows how to solve it?

I attach my XF86Config-4 here,

thanks a lot for any help.


# XF86Config-4 (XFree86 X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the XF86Config-4 manual page.
# (Type "man XF86Config-4" at the shell prompt.)
#
# This file is automatically updated on xserver-xfree86 package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xfree86
# package.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following commands as root:
#
# cp /etc/X11/XF86Config-4 /etc/X11/XF86Config-4.custom
# md5sum /etc/X11/XF86Config-4 >/var/lib/xfree86/XF86Config-4.md5sum
# dpkg-reconfigure xserver-xfree86

Section "ServerLayout"
Identifier "Default Layout"
Screen "Default Screen"
InputDevice "Generic Keyboard"
InputDevice "Configured Mouse"
InputDevice "Generic Mouse"
EndSection

Section "Files"

# local font server
# if the local font server has problems, we can fall back on these
FontPath "unix/:7100"
FontPath "/usr/lib/X11/fonts/misc"
FontPath "/usr/lib/X11/fonts/cyrillic"
FontPath "/usr/lib/X11/fonts/100dpi/:unscaled"
FontPath "/usr/lib/X11/fonts/75dpi/:unscaled"
FontPath "/usr/lib/X11/fonts/Type1"
FontPath "/usr/lib/X11/fonts/CID"
FontPath "/usr/lib/X11/fonts/Speedo"
FontPath "/usr/lib/X11/fonts/100dpi"
FontPath "/usr/lib/X11/fonts/75dpi"
EndSection

Section "Module"
#Load "GLcore"
Load "bitmap"
Load "dbe"
Load "ddc"
#Load "dri"
Load "extmod"
Load "freetype"
Load "glx"
Load "int10"
Load "record"
Load "speedo"
Load "type1"
Load "vbe"
EndSection

Section "InputDevice"
Identifier "Generic Keyboard"
Driver "keyboard"
Option "CoreKeyboard"
Option "XkbRules" "xfree86"
Option "XkbModel" "pc105"
Option "XkbLayout" "es"
EndSection

Section "InputDevice"
Identifier "Configured Mouse"
Driver "mouse"
Option "CorePointer"
Option "Device" "/dev/psaux"
Option "Protocol" "ImPS/2"
Option "Emulate3Buttons" "true"
Option "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"
Identifier "Generic Mouse"
Driver "mouse"
Option "SendCoreEvents" "true"
Option "Device" "/dev/input/mice"
Option "Protocol" "ImPS/2"
Option "Emulate3Buttons" "true"
Option "ZAxisMapping" "4 5"
EndSection
Section "Monitor"
Identifier "Monitor genérico"
#HorizSync 30.0 - 57.0
#VertRefresh 43.0 - 72.0
#Option "DPMS"
HorizSync 28.0 - 110.0
VertRefresh 43.0 - 90.0
#ModeLine "1280x800@60" 83.9 1280 1312 1624 1656 800 816 824 841
#ModeLine "1280x800@70" 101.92 1280 1312 1696 1728 800 816 825 841
Option "dpms"

EndSection
#EndSection

Section "Device"
Identifier "Tarjeta de vídeo genérica"
Driver "nvidia"
#Driver "vesa"
VideoRam 65536
Option "NoLogo" "true"
Option "RenderAccel" "true"
Option "CursorShadow" "true"
Option "CursorShadowAlpha" "50"
EndSection

Section "Screen"
Identifier "Default Screen"
Device "Tarjeta de vídeo genérica"
Monitor "Monitor genérico"
DefaultDepth 24

Subsection "Display"
Depth 8
#Virtual 800 600
EndSubsection

Subsection "Display"
Depth 15
#Virtual 800 600
EndSubsection

Subsection "Display"
Depth 16
#Virtual 800 600
EndSubsection

Subsection "Display"
Depth 24
Modes "1280x800" "1024x768"
ViewPort 0 0
EndSubsection
EndSection

Section "DRI"
Mode 0666
EndSection
 
Old 03-17-2005, 12:23 PM   #2
IsaacKuo
Senior Member
 
Registered: Apr 2004
Location: Baton Rouge, Louisiana, USA
Distribution: Debian 4.0 Etch
Posts: 1,349

Rep: Reputation: 49
Insert this line into your "Monitor" section (underneath VertRefresh 43.0 - 90.0):
Code:
ModeLine "1280x800" 87.09 1280 1336 1616 1728 800 802 814 840 #60Hz
Also, change this line:

Modes "1280x800" "1024x768"

to this:

Modes "1280x800"

It might help to add this for all bit depths rather than just 24 bit.
 
Old 03-17-2005, 12:40 PM   #3
daguerr
LQ Newbie
 
Registered: Mar 2005
Posts: 4

Original Poster
Rep: Reputation: 0
i've tried so but it stills display a 1024x768 resolution
 
Old 03-17-2005, 02:43 PM   #4
Gigantas
LQ Newbie
 
Registered: Mar 2005
Posts: 7

Rep: Reputation: 0
Hi, I have exactly the same problem you do...
no solution for that either...
 
Old 03-17-2005, 03:07 PM   #5
IsaacKuo
Senior Member
 
Registered: Apr 2004
Location: Baton Rouge, Louisiana, USA
Distribution: Debian 4.0 Etch
Posts: 1,349

Rep: Reputation: 49
Are you using GNOME? If so, then you need to go into GNOME control center and tell it to use 1280x800. Otherwise, GNOME may thickheadedly use whatever resolution it thinks it wants.

If you're using KDE or some other Window Manager, then this should have been sufficient.
 
Old 03-17-2005, 03:16 PM   #6
Gigantas
LQ Newbie
 
Registered: Mar 2005
Posts: 7

Rep: Reputation: 0
I just solved my problem on my Vaio VGN-FS115M.
I found the correct modeline after trying several ones:

Section "Monitor"
Identifier "Monitor0"
VendorName "Monitor Vendor"
ModelName "Monitor Model"
# http://www.linuxforen.de/forums/arch.../t-175226.html
Modeline "1280x800" 80.58 1280 1344 1480 1680 800 801 804 827
...
hope that helps
 
Old 03-17-2005, 03:44 PM   #7
daguerr
LQ Newbie
 
Registered: Mar 2005
Posts: 4

Original Poster
Rep: Reputation: 0
Quote:
Originally posted by Gigantas
I just solved my problem on my Vaio VGN-FS115M.
I found the correct modeline after trying several ones:

Section "Monitor"
Identifier "Monitor0"
VendorName "Monitor Vendor"
ModelName "Monitor Model"
# http://www.linuxforen.de/forums/arch.../t-175226.html
Modeline "1280x800" 80.58 1280 1344 1480 1680 800 801 804 827
...
hope that helps
Yes! It's great! i tried a lot of modelines but didn't work. With that above this lines it works fine at 58 Hz.

But now i realise another problem. When i'm in console mode, the resolution is only 640x480, and don't know how to change. This also happens at system startup.

Thanks a lot!

:-D

Last edited by daguerr; 03-17-2005 at 03:46 PM.
 
Old 03-17-2005, 07:04 PM   #8
jschiwal
Guru
 
Registered: Aug 2001
Location: Fargo, ND
Distribution: SuSE AMD64
Posts: 15,733

Rep: Reputation: 654Reputation: 654Reputation: 654Reputation: 654Reputation: 654Reputation: 654
When you boot up, the x-windows system isn't running. You want to include a boot option to increase the resolution of the vt's. You might try 'vga=791'. You can add it manually as an option to try it out before editing your lilo or grub configuration file. This option uses the frame buffer, assuming the fbdev is installed.
This gives the same resolution as 1024x768. I tried a higher resolution on my LCD screen, but it didn't look right.

There is a program that is a part of x-windows called 'gtf' that can analyze your system and give you a modeline to use.

gtf 1280 800 60 -x

Last edited by jschiwal; 03-17-2005 at 07:07 PM.
 
Old 04-06-2005, 10:41 AM   #9
Ford Prefect
LQ Newbie
 
Registered: Apr 2005
Location: an insignificant planet in the Galaxy
Posts: 11

Rep: Reputation: 0
Please, where you can find the gtf program?
It is not included in my distribution.
 
Old 04-06-2005, 01:44 PM   #10
Baz8080
LQ Newbie
 
Registered: Mar 2005
Location: Ireland
Distribution: Fedora Core X
Posts: 13

Rep: Reputation: 0
/usr/X11R6/bin/gtf

on my system anyway. Maybe that is not in your path the the moment?
 
Old 04-18-2005, 06:43 AM   #11
Ford Prefect
LQ Newbie
 
Registered: Apr 2005
Location: an insignificant planet in the Galaxy
Posts: 11

Rep: Reputation: 0
There is no gtf file in my /usr/X11R6/bin/ ...
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
changing res to 1280x800? furtivefelon Debian 7 07-15-2005 02:31 PM
Problems configuring aspire 1363 wlmi for 1280x800 tommy_vossy Linux - Laptop and Netbook 4 06-20-2005 02:23 AM
problems setting 1280x800 resolution robbymcw Mandriva 10 03-04-2005 02:25 AM
Console res problems and a thank you... redkazan Linux - General 1 01-11-2004 01:26 PM
Slackware KDE res problems.... AnalogXXX Linux - Software 4 01-23-2003 12:53 AM


All times are GMT -5. The time now is 11:02 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration