LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Laptop and Netbook
User Name
Password
Linux - Laptop and Netbook Having a problem installing or configuring Linux on your laptop? Need help running Linux on your netbook? This forum is for you. This forum is for any topics relating to Linux and either traditional laptops or netbooks (such as the Asus EEE PC, Everex CloudBook or MSI Wind).

Notices

Reply
 
Search this Thread
Old 12-09-2011, 06:10 PM   #1
rickpenn
LQ Newbie
 
Registered: Dec 2011
Posts: 6

Rep: Reputation: Disabled
Problems mounting disk in Ubuntu 11.10 (NTFS signature missing)


Hi,

I am trying to get into a laptop I just locked myself out of by changing the domain to a workgroup (old work laptop I'm using at home now).

I am attempting to use the Ubuntu bootable CD and everything is working fine except I can't mount the disk to get to my files.

I am following the steps I found here:
http://www.howtogeek.com/howto/windo...dows-computer/

Here is my output and where I am stuck (NTFS signature missing):

root@ubuntu:~# fdisk -l

Disk /dev/sda: 80.0 GB, 80026361856 bytes
255 heads, 63 sectors/track, 9729 cylinders, total 156301488 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0x83c583c5

Device Boot Start End Blocks Id System
/dev/sda1 * 63 156296384 78148161 7 HPFS/NTFS/exFAT
root@ubuntu:~# mount -t ntfs-3g /dev/sda /media/disk -o force
NTFS signature is missing.
Failed to mount '/dev/sda': Invalid argument
The device '/dev/sda' doesn't seem to have a valid NTFS.
Maybe the wrong device is used? Or the whole disk instead of a
partition (e.g. /dev/sda, not /dev/sda1)? Or the other way around?

(so I tried sda1)...

root@ubuntu:~# mount -t ntfs-3g /dev/sda1 /media/disk -o force
NTFS signature is missing.
Failed to mount '/dev/sda1': Invalid argument
The device '/dev/sda1' doesn't seem to have a valid NTFS.
Maybe the wrong device is used? Or the whole disk instead of a
partition (e.g. /dev/sda, not /dev/sda1)? Or the other way around?
root@ubuntu:~#

I'm not very familiar with Linux yet so any help would be greatly appreciated. (I did search through the existing threads and did not see anything exactly like my issue, hence the new post. Apologies if I overlooked a thread that had this solution)

Thanks,
Rick
 
Old 12-10-2011, 12:34 PM   #2
Doc CPU
Member
 
Registered: Jun 2011
Location: Stuttgart, Germany
Distribution: Mint, Debian, Gentoo, Win 2k/XP
Posts: 999

Rep: Reputation: 294Reputation: 294Reputation: 294
Hi there,

Quote:
Originally Posted by rickpenn View Post
Code:
root@ubuntu:~# fdisk -l

Disk /dev/sda: 80.0 GB, 80026361856 bytes
255 heads, 63 sectors/track, 9729 cylinders, total 156301488 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0x83c583c5

   Device Boot      Start         End      Blocks   Id  System
/dev/sda1   *          63   156296384    78148161    7  HPFS/NTFS/exFAT
okay, so the HDD contains only one partition spanning the entire disk.

Quote:
Originally Posted by rickpenn View Post
Code:
root@ubuntu:~# mount -t ntfs-3g /dev/sda /media/disk -o force
Wrong. You can't mount an entire drive; you have to mount the partition, /dev/sda1 in this case.

Quote:
Originally Posted by rickpenn View Post
Code:
root@ubuntu:~# mount -t ntfs-3g /dev/sda1 /media/disk -o force
NTFS signature is missing.
Failed to mount '/dev/sda1': Invalid argument
The device '/dev/sda1' doesn't seem to have a valid NTFS.
What you did here looks correct, however, there seem to be issues with NTFS-3g and partitions used with Windows 7.
Have a look at this thread at tuxera.com, the company that has been developing NTFS-3g. I didn't read it thoroughly, so I can't promise there is a solution for you. It may give a few hints, though.

[X] Doc CPU
 
Old 12-10-2011, 01:26 PM   #3
jefro
Guru
 
Registered: Mar 2008
Posts: 11,086

Rep: Reputation: 1362Reputation: 1362Reputation: 1362Reputation: 1362Reputation: 1362Reputation: 1362Reputation: 1362Reputation: 1362Reputation: 1362Reputation: 1362
Does this laptop use an encryption scheme? I suspect this laptop may have more than meets the eye.

A normal windows 7 install has more than one partition.

Any live linux cd ought to easily mount the ntfs drive either with read only or with read write. Most distro's offer ntfs-3g default. The issue usually is how they assign use or mount for the live cd.

Last edited by jefro; 12-10-2011 at 01:28 PM.
 
Old 12-10-2011, 01:36 PM   #4
camorri
Senior Member
 
Registered: Nov 2002
Location: Somewhere inside 9.9 million sq. km. Canada
Distribution: Slackware 14.0 + 14.1
Posts: 4,834

Rep: Reputation: 431Reputation: 431Reputation: 431Reputation: 431Reputation: 431
Quote:
Device Boot Start End Blocks Id System
/dev/sda1 * 63 156296384 78148161 7 HPFS/NTFS/exFAT
Are you sure this is NTFS ? rickpenn did not state what OS this is. On an 'old laptop' with a 80 gig drive, good bet it was XP not W7. A lot of XP systems on older hardware are fat32 file systems.

Give the mount command a try with -t vfat and see what happens.
 
Old 12-10-2011, 02:05 PM   #5
asimba
Member
 
Registered: Mar 2005
Location: 127.0.0.0
Distribution: Red Hat / Fedora
Posts: 349

Rep: Reputation: 42
Quote:
Originally Posted by camorri View Post
Are you sure this is NTFS ? rickpenn did not state what OS this is. On an 'old laptop' with a 80 gig drive, good bet it was XP not W7. A lot of XP systems on older hardware are fat32 file systems.

Give the mount command a try with -t vfat and see what happens.
my 2 cents - majority of laptops do have recovery partition. Thats again a probability. Unless it was changed to suit business purpose etc.

some laptops have functionality to run diagnostics - rickpenn might want to run that as well while is at it to make sure its not hard disk related issue.
 
Old 12-10-2011, 02:18 PM   #6
Doc CPU
Member
 
Registered: Jun 2011
Location: Stuttgart, Germany
Distribution: Mint, Debian, Gentoo, Win 2k/XP
Posts: 999

Rep: Reputation: 294Reputation: 294Reputation: 294
Hi there,

Quote:
Originally Posted by camorri View Post
Are you sure this is NTFS ?
who is it you're asking? Me?
If so, yes, I'm pretty sure it is NTFS. Alright, fdisk says "HPFS/NTFS/exFAT", but AFAIK, exFAT was only introduced with Vista. And it has never been explicitly promoted, nor did MS make any effort to make it known. Still today, very few Windows users know that there is such a thing as exFAT. Therefore it's a very unlikely assumption. And so is HPFS, which is linked to OS/2.
That leaves NTFS.

Quote:
Originally Posted by camorri View Post
rickpenn did not state what OS this is. On an 'old laptop' with a 80 gig drive, good bet it was XP not W7.
Could be. I was sure, however, that I'd read something about Win7 in the initial post. Must've been my imagination.

Quote:
Originally Posted by camorri View Post
A lot of XP systems on older hardware are fat32 file systems.
Yes, but far too few. Most XP installations are running on NTFS.

[X] Doc CPU
 
1 members found this post helpful.
Old 12-10-2011, 02:46 PM   #7
camorri
Senior Member
 
Registered: Nov 2002
Location: Somewhere inside 9.9 million sq. km. Canada
Distribution: Slackware 14.0 + 14.1
Posts: 4,834

Rep: Reputation: 431Reputation: 431Reputation: 431Reputation: 431Reputation: 431
Quote:
who is it you're asking? Me?
That question was for the original poster, since he is the only one who can determine file system type for sure.

Since it was a linux command displaying a list of possible F/S types, there is no guarantee exFat is a good guess. It does guess.

Since the things we know; old laptop, 80 gig disk... was used in a company environment, just about anything is possible.
 
Old 12-10-2011, 02:51 PM   #8
asimba
Member
 
Registered: Mar 2005
Location: 127.0.0.0
Distribution: Red Hat / Fedora
Posts: 349

Rep: Reputation: 42


That bring us to this article


http://stackoverflow.com/questions/6...n-ubuntu-11-04

Following may hold key to OP's issue

Code:
mount -t exfat
 
Old 12-12-2011, 12:16 AM   #9
Brains
Member
 
Registered: Apr 2009
Distribution: Debian testing
Posts: 258

Rep: Reputation: 42
/dev/sda1 * 63 156296384 78148161 7 HPFS/NTFS/exFAT
Type seven is HPFS/NTFS
Did you create the directory /media/disk?
You don't need to mount to /media, you can just mount to /mnt.
Quote:
mount -t ntfs-3g /dev/sda1 /mnt
Quote:
mount -t ntfs /dev/sda1
Quote:
mount /dev/sda1 /mnt
Since you only need to get to your files, no need for write access is there?
Since I don't need to specify NTFS in mount command over here, nor should you over there.
 
Old 12-12-2011, 12:37 AM   #10
syg00
LQ Veteran
 
Registered: Aug 2003
Location: Australia
Distribution: Lots ...
Posts: 12,094

Rep: Reputation: 978Reputation: 978Reputation: 978Reputation: 978Reputation: 978Reputation: 978Reputation: 978Reputation: 978
Run this (as root) - it has the added benefit (over fdisk) of trying to guess the filesystem type as well as just display the partition type.
Code:
parted -l
 
Old 12-12-2011, 11:57 AM   #11
rickpenn
LQ Newbie
 
Registered: Dec 2011
Posts: 6

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by camorri View Post
Are you sure this is NTFS ? rickpenn did not state what OS this is. On an 'old laptop' with a 80 gig drive, good bet it was XP not W7. A lot of XP systems on older hardware are fat32 file systems.

Give the mount command a try with -t vfat and see what happens.
The OS is Windows XP Professional.

---------- Post added 12-12-11 at 12:57 PM ----------

Quote:
Originally Posted by syg00 View Post
Run this (as root) - it has the added benefit (over fdisk) of trying to guess the filesystem type as well as just display the partition type.
Code:
parted -l
here is the parted -l output:
root@ubuntu:~# parted -l
Model: ATA TOSHIBA MK8046GS (scsi)
Disk /dev/sda: 80.0GB
Sector size (logical/physical): 512B/512B
Partition Table: msdos

Number Start End Size Type File system Flags
1 32.3kB 80.0GB 80.0GB primary boot


Warning: Unable to open /dev/sr0 read-write (Read-only file system). /dev/sr0
has been opened read-only.
Error: Can't have a partition outside the disk!
 
Old 12-12-2011, 12:00 PM   #12
rickpenn
LQ Newbie
 
Registered: Dec 2011
Posts: 6

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by Brains View Post
/dev/sda1 * 63 156296384 78148161 7 HPFS/NTFS/exFAT
Type seven is HPFS/NTFS
Did you create the directory /media/disk?
You don't need to mount to /media, you can just mount to /mnt.



Since you only need to get to your files, no need for write access is there?
Since I don't need to specify NTFS in mount command over here, nor should you over there.
root@ubuntu:~# mount /dev/sda1 /mnt
mount: you must specify the filesystem type
root@ubuntu:~#
 
Old 12-12-2011, 12:11 PM   #13
asimba
Member
 
Registered: Mar 2005
Location: 127.0.0.0
Distribution: Red Hat / Fedora
Posts: 349

Rep: Reputation: 42
did you try following

Code:
mount -t exfat
 
Old 12-12-2011, 12:21 PM   #14
Brains
Member
 
Registered: Apr 2009
Distribution: Debian testing
Posts: 258

Rep: Reputation: 42
There is something in the journal of the NTFS file system that prevents Linux from mounting it. Either it was not cleanly powered down or something else. Most often, if one was able to run check disk utility in Windows would remedy the situation. It is also possible this can be provoked during the boot process or by using a Windows XP installation disk to repair the file system.
Ubuntu may have testdisk installed, if not it can be installed while running it live. I have never used testdisk for repairing disks but many have been given smiles using it in such predicaments, not sure how successful it is with NTFS. Try doing repairs with an XP installation disk first if possible.

Actually: Since it is saying the NTFS signature is missing, this might be a breeze for a partition recovery utility like testdisk or bootitng. To use testdisk, read man pages, open a terminal full screen and run command: testdisk. Or try fix /mbr with Windows XP recovery console with install disk.

Last edited by Brains; 12-12-2011 at 12:34 PM.
 
Old 12-12-2011, 03:56 PM   #15
rickpenn
LQ Newbie
 
Registered: Dec 2011
Posts: 6

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by asimba View Post
did you try following

Code:
mount -t exfat
yes, that did not work either. I am running testdisk now
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
NTFS signature is missing, trying to mount RAID-5 volume ofuser Linux - Hardware 4 10-15-2010 02:21 AM
G4L - ntfs signature missing Christian271 Linux - Software 1 08-29-2010 04:09 PM
NTFS mounting problems Gighen Linux - Newbie 2 01-05-2005 10:31 AM
mounting ntfs disk uv1 Linux - Hardware 7 08-22-2004 09:15 AM
NTFS mounting problems thorax Linux - General 0 06-09-2004 08:57 AM


All times are GMT -5. The time now is 11:07 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration