LinuxQuestions.org
LinuxAnswers - the LQ Linux tutorial section.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Laptop and Netbook
User Name
Password
Linux - Laptop and Netbook Having a problem installing or configuring Linux on your laptop? Need help running Linux on your netbook? This forum is for you. This forum is for any topics relating to Linux and either traditional laptops or netbooks (such as the Asus EEE PC, Everex CloudBook or MSI Wind).

Notices

Reply
 
Search this Thread
Old 11-05-2007, 05:17 PM   #1
gawhelan
LQ Newbie
 
Registered: Jun 2007
Posts: 2

Rep: Reputation: 0
powertop reporting a huge number of acpi interrupts


Hi, I'm running Ubuntu Gutsy on a Zepto Znote 6625wd laptop. I ran powertop to see if I could improve the disappointing battery life and got the following results:

Code:
Cn                Avg residency       P-states (frequencies)
C0 (cpu running)        (16.1%)         2.00 Ghz     0.0%
C1                0.0ms ( 0.0%)         1.60 Ghz     0.0%
C2                0.4ms (83.9%)         1200 Mhz   100.0%



Wakeups-from-idle per second : 2115.3   interval: 10.0s
Power usage (ACPI estimate): 30.5W (1.1 hours)

Top causes for wakeups:
  90.1% (3626.5)       <interrupt> : acpi 
   2.8% (113.7)       firefox-bin : schedule_timeout (process_timeout) 
   2.3% ( 94.4)       <interrupt> : uhci_hcd:usb3, iwl4965, nvidia 
   2.3% ( 90.6)       <interrupt> : extra timer interrupt 
   0.6% ( 22.8)       firefox-bin : futex_wait (hrtimer_wakeup) 
   0.6% ( 22.4)              Xorg : do_setitimer (it_real_fn)
Anyone have any ideas why I'm seeing so many acpi interrupts?
 
Old 11-13-2007, 08:46 AM   #2
FeepingCreature
LQ Newbie
 
Registered: Nov 2007
Posts: 1

Rep: Reputation: 0
I have the same problem, though slightly less.
No idea what causes it, either.

Quote:
Top causes for wakeups:
63.0% (699.9) <interrupt> : acpi
System is Linux gentoo-pc 2.6.22-suspend2-r2 #13 SMP Mon Nov 5 18:19:59 CET 2007 i686 Intel(R) Core(TM)2 CPU T5500 @ 1.66GHz GenuineIntel GNU/Linux, running KDE3.5.
The problem only seems to happen in KDE.

Does anybody know?

<Edit> I went through a KDE startup manually, watching powertop. The problem seems to appear whenever anything related to ACPI is started, i.e. ksysguard or the taskbar applet. Doesn't go away when the respective program is closed though. Very weird.

Last edited by FeepingCreature; 11-13-2007 at 09:03 AM.
 
Old 11-30-2007, 06:53 PM   #3
laur
LQ Newbie
 
Registered: Nov 2007
Posts: 1

Rep: Reputation: 0
I also experience the same problem on my Znote 6625wd laptop with Ubuntu gutsy. Powertop says:

Code:
  83,7% (1690,9)       <interrupt> : acpi
I wonder if the bugs relates to powertop, because of the extreme high number of wakeups (I used powertop 1.9).
 
Old 12-05-2007, 07:01 AM   #4
nidelius
LQ Newbie
 
Registered: Dec 2007
Posts: 3

Rep: Reputation: 0
Same type of problem for me :/
Running Kubuntu 7.10

Cn Avg residency P-states (frequencies)
C0 (cpu running) (39.5%) 2.21 Ghz 8.5%
C1 0.0ms ( 0.0%) 2.21 Ghz 0.0%
C2 0.2ms ( 7.1%) 1200 Mhz 0.6%
C3 0.4ms (53.4%) 800 Mhz 90.9%


Wakeups-from-idle per second : 1749.7 interval: 10.0s
Power usage (5 minute ACPI estimate) : 360.4 W (0.0 hours left)

Top causes for wakeups:
50.4% (2039.7) <interrupt> : acpi
25.3% (1023.7) <interrupt> : rtc
 
Old 02-12-2008, 03:59 PM   #5
nidelius
LQ Newbie
 
Registered: Dec 2007
Posts: 3

Rep: Reputation: 0
site with relevance

Look at this

http://linux.developers.dk/ich8m/
 
Old 01-15-2009, 02:12 AM   #6
RadonPL
Member
 
Registered: Dec 2005
Location: Gdansk, Poland
Distribution: openSUSE 11.0, Ubuntu 8.04
Posts: 37

Rep: Reputation: 15
Quote:
Originally Posted by nidelius View Post
I'm in the process of fixing the same problem with interrupts, could you please review the link because it doesn't work.
 
  


Reply

Tags
acpi, powertop, ubuntu


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
C-state not showing in powertop rengo.Java Linux - Laptop and Netbook 6 09-26-2007 06:44 AM
mod_status reporting number of processes exceeding MaxClients thetawaverider Linux - Server 1 02-28-2007 11:14 PM
CUPS not reporting number of pages technopasta Linux - Desktop 0 08-17-2006 11:51 PM
acpi is causing huge problems on laptop cjae Linux - Hardware 5 03-30-2006 04:05 AM
Problem with huge number of pthreads Berng Programming 7 12-17-2003 07:33 AM


All times are GMT -5. The time now is 10:56 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration