LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Laptop and Netbook
User Name
Password
Linux - Laptop and Netbook Having a problem installing or configuring Linux on your laptop? Need help running Linux on your netbook? This forum is for you. This forum is for any topics relating to Linux and either traditional laptops or netbooks (such as the Asus EEE PC, Everex CloudBook or MSI Wind).

Notices

Reply
 
Search this Thread
Old 07-28-2007, 02:36 PM   #1
streamkid
LQ Newbie
 
Registered: Nov 2006
Distribution: gentoo
Posts: 7

Rep: Reputation: 0
Pavilion + RTL8101e/8169 Problem


Hello,
this is my first laptop, so I may be missing laptop-specific linux things

The thing is a Pavilion 6520ea with core 2 duo 7100, and I have hard time installing 2007.0 from minimal cd (amd64).

I googled and found a gentoo-wiki page, where's stated that windblows disables the eth0 on shutdown so it doesn't WoL. I fixed this.

When I boot the cd, by the time I am logged in as root, both the leds from the notebook are down and from the switch (ie link is down). eth0 seems to exist though, and i can configure it too.

Looking more closely, the net link is up till the time when autoconfig starts, and in my laptop says "Detected Intel Core 2 Duo CPU 7100 @ 1.80GHz CPUs @ 1795MHz". Then, it goes down.

If i don't allow autoconfig to start, the link will remain active, but i won't have any eth0, ie not configured.

System also reports these:

Code:
livecd root# dmesg | grep eth0
eth0: RTL8101e at 0xffffc20010094000, 00:1b:24:2a:8e:f8, IRC 17
eth0: RTL8101e at 0xffffc20010094000, 00:1b:24:2a:8e:f8, IRC 17
r8169: eth0: link down
r8169: eth0: link down

livecd root# lspci
06:00.0 Ethernet Controller: Realtek Semiconductor Co., Ltd. RTL8101e PCI Express Fast Ethernet controller (rev 01)
Help me which ever way you can 8)

PS: I 'll try to configure the card myself, but i suppose autoconfig does more than configuring my eth0, and i 'm not willing to configure the whole livecd by hand :!:
 
  


Reply

Tags
dv6000, ethernet, fast, gentoo, pavilion, r1000, realtek


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
modem problem on hp pavilion zv5212EA baambooli Ubuntu 2 05-20-2007 07:16 PM
mouse problem with hp pavilion series remiopakunle Linux - Laptop and Netbook 2 04-16-2007 10:02 AM
HP Pavilion Integrated Wireless problem Balkce Linux - Wireless Networking 6 10-05-2004 04:08 PM
HP Pavilion- internal modem problem lubond Linux - Hardware 3 02-02-2004 10:08 AM
HP Pavilion NIC problem - need help! madangsweh Linux - Networking 0 08-23-2003 10:34 PM


All times are GMT -5. The time now is 04:15 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration