LinuxQuestions.org
Did you know LQ has a Linux Hardware Compatibility List?
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Laptop and Netbook
User Name
Password
Linux - Laptop and Netbook Having a problem installing or configuring Linux on your laptop? Need help running Linux on your netbook? This forum is for you. This forum is for any topics relating to Linux and either traditional laptops or netbooks (such as the Asus EEE PC, Everex CloudBook or MSI Wind).

Notices



Reply
 
Search this Thread
Old 07-17-2009, 04:23 AM   #1
merajul
LQ Newbie
 
Registered: Feb 2006
Posts: 5

Rep: Reputation: 0
No sound with Fedora Core 11 + HP Pavilion dv6-1116tx + ATI R700 Audio Device


Hello,

I recently installed Fedora core 11 on my HP Pavilion dv6-1116tx laptop with ATI R700 Audio Device. System detects sound card properly and I can change mixer settings, but no audio comes out of either the internal speaker or ATI R700.

output from /sbin/lspci -

00:1b.0 Audio device: Intel Corporation 82801I (ICH9 Family) HD Audio Controller (rev 03)
01:00.1 Audio device: ATI Technologies Inc R700 Audio Device [Radeon HD 4000 Series]

Any help to make it work will be highly appreciated!

--
Thanks,
- M
 
Old 07-18-2009, 08:27 PM   #2
chickenlinux
Member
 
Registered: Mar 2008
Location: Here - Where else?
Distribution: Fedora 12, Arch Linux (updated daily =D)
Posts: 270

Rep: Reputation: 31
For starters, the R700, [Radeon HD 4000 Series] is probably the just HDMI output from your graphics card. Use the Intel sound card, unless you're hooked up to the HDMI.

Have you tried installing pulseaudio and pulseaudio-libs along with pulseaudio-module-x11, pulseaudio-utils, pulseaudio-module-gconf, alsa-plugins-pulseaudio, and pulseaudio-libs-glib2 yet? (I'm not sure all those are completely necessary, I'm telling you some of what I have here, but I'd reckon this'd work) I've heard installing pulseaudio and rebooting fixes the problem. You also might want to try running "alsamixer" (w/o quotes) in a terminal, and adjusting it with the arrow keys to stuff is turned up. More often than not, that's the problem. I've had that happen to be before - problem was, PCM was muted Easy fix though!

Post the output of lsmod and we'll see if the driver's loaded
 
Old 07-18-2009, 09:59 PM   #3
scottro11
Member
 
Registered: Jun 2009
Location: NYC
Posts: 257

Rep: Reputation: 58
Pulseaudio is almost certainly installed, as it usually comes by default. You can poke around fedora forums for one of the many sound threads. Did you go with the default Gnome desktop? Like too many of the desktop distributions, Fedora ties various system things like sound to the desktop, and some folks have trouble if they don't use Gnome.

I think there was also a volume issue--that everything was muted by default. Try running alsamixer and raising the volume. (I believe it's provided by the alsa-utils package--if you can't find that then it's alsa-util, or possibly alsautil(s).
 
Old 07-21-2009, 06:16 AM   #4
merajul
LQ Newbie
 
Registered: Feb 2006
Posts: 5

Original Poster
Rep: Reputation: 0
I am running default gnome desktop. Pulseaudio is already installed.

output from ps -ef | grep pulseaudio:

2464 1 0 16:29 ? 00:00:05 /usr/bin/pulseaudio --start --log-target=syslog
3472 3455 0 16:49 pts/1 00:00:00 man pulseaudio
3475 3472 0 16:49 pts/1 00:00:00 sh -c (cd "/usr/share/man" && (echo ".pl 1100i"; /usr/bin/gunzip -c '/usr/share/man/man1/pulseaudio.1.gz'; echo ".\\\""; echo ".pl \n(nlu+10") | /usr/bin/gtbl | /usr/bin/nroff -c -mandoc 2>/dev/null | /usr/bin/less -is)
3476 3475 0 16:49 pts/1 00:00:00 sh -c (cd "/usr/share/man" && (echo ".pl 1100i"; /usr/bin/gunzip -c '/usr/share/man/man1/pulseaudio.1.gz'; echo ".\\\""; echo ".pl \n(nlu+10") | /usr/bin/gtbl | /usr/bin/nroff -c -mandoc 2>/dev/null | /usr/bin/less -is)

I checked that nothing is muted; turned all mixer settings to 100%.

output from /sbin/lsmod | grep sound:

soundcore 5404 1 snd


Still no luck.

Is Radeon HD 4000 Series fully supported yet under Linux?

--
Thanks,
- j
 
Old 07-21-2009, 05:21 PM   #5
chickenlinux
Member
 
Registered: Mar 2008
Location: Here - Where else?
Distribution: Fedora 12, Arch Linux (updated daily =D)
Posts: 270

Rep: Reputation: 31
On linux with fglrx driver yes. Are you using the HDMI output for sound? If not, don't use the Radeon card; I've got a radeon HD, and, being a graphics card, sound does not work correctly unless I use my HDA Intel sound card instead.
 
Old 07-23-2009, 12:09 PM   #6
business_kid
Guru
 
Registered: Jan 2006
Location: Ireland
Distribution: Slackware & Android
Posts: 6,625

Rep: Reputation: 585Reputation: 585Reputation: 585Reputation: 585Reputation: 585Reputation: 585
I have the AMD/ATI 690/600 chipset in my laptop. The video is in the Northbridge(fast stuff) and the sound in the Southbridge(Slower stuff) unless I am very much mistaken. All the bits behave independently as separate chips. Along with audio are usb, ide & sata, isa bridge, etc.etc.

hda_intel is your module. You need to know that the kernel compile has a menu for this module offering support for chips from various manufacturers.
 
Old 07-24-2009, 12:19 AM   #7
scottro11
Member
 
Registered: Jun 2009
Location: NYC
Posts: 257

Rep: Reputation: 58
I have had times, though this was more often with F8 and F9, where I had to add options snd-hda-intel model=acer on a few Acer machines. (Added it to /etc/modprobe.conf)
 
Old 07-24-2009, 04:08 AM   #8
merajul
LQ Newbie
 
Registered: Feb 2006
Posts: 5

Original Poster
Rep: Reputation: 0
I am using internal audio. My /etc/modprobe.conf is empty. But I have hda_intel module loaded. Still no luck.

/sbin/lsmod | grep hda_intel
snd_hda_intel 23920 5
snd_hda_codec 54264 3 snd_hda_codec_atihdmi,snd_hda_codec_idt,snd_hda_intel
snd_pcm 62520 3 snd_hda_intel,snd_hda_codec
snd 49044 15 snd_hda_codec_idt,snd_hda_intel,snd_hda_codec,snd_hwdep,snd_pcm,snd_timer
snd_page_alloc 7572 2 snd_hda_intel,snd_pcm

I don't have fglrx driver installed either (and no xorg.conf file which used to be there!!! kind of strange ...)
 
Old 07-25-2009, 08:33 AM   #9
business_kid
Guru
 
Registered: Jan 2006
Location: Ireland
Distribution: Slackware & Android
Posts: 6,625

Rep: Reputation: 585Reputation: 585Reputation: 585Reputation: 585Reputation: 585Reputation: 585
Quote:
Originally Posted by merajul View Post
I am using internal audio. My /etc/modprobe.conf is empty. But I have hda_intel module loaded. Still no luck.

/sbin/lsmod | grep hda_intel
snd_hda_intel 23920 5
snd_hda_codec 54264 3 snd_hda_codec_atihdmi,snd_hda_codec_idt,snd_hda_intel
snd_pcm 62520 3 snd_hda_intel,snd_hda_codec
snd 49044 15 snd_hda_codec_idt,snd_hda_intel,snd_hda_codec,snd_hwdep,snd_pcm,snd_timer
snd_page_alloc 7572 2 snd_hda_intel,snd_pcm

I don't have fglrx driver installed either (and no xorg.conf file which used to be there!!! kind of strange ...)
You can do without fglrx; but if you put it in, removing it is a pain.
use radeonhd instead.

X -Configure provides an xorg.conf

Your sound is all messed up. the 'snd' module should have all the others listed in beside it like this (Here's my list)
snd_hda_intel 28056 0
snd_hda_codec 71184 1 snd_hda_intel,snd_hda_codec,snd_pcm_oss
snd 65512 10 snd_hda_intel,snd_hda_codec,snd_hwdep,snd_seq_o
ss,snd_seq,snd_seq_device,snd_pcm_oss,snd_mixer_oss,snd_pcm,snd_timer
snd_page_alloc 9856 2 snd_hda_intel,snd_pcm

As Capt. Piquard of SS Enterprise might say: "Make it so!"
 
Old 07-25-2009, 07:04 PM   #10
chickenlinux
Member
 
Registered: Mar 2008
Location: Here - Where else?
Distribution: Fedora 12, Arch Linux (updated daily =D)
Posts: 270

Rep: Reputation: 31
Question radeonhd?

Quote:
Originally Posted by business_kid View Post
You can do without fglrx; but if you put it in, removing it is a pain.
use radeonhd instead.
Whoa there! radeonhd is *still* under heavy development and will be for a while, they just lost quite a few SuSE developers! The site says that it "may result in damaged displays and other undesirable phenomena." I'm not too sure I'd use it... sounds scary to me. Especially if this laptop is new, it'd sure suck to break it by accident.

While I'm almost certain fglrx will mess up your X.Org on FC11 because of the new X server/new kernel combo, and it is really an awful driver, I'd read some disclaimers before using radeonhd.

I might be somewhat wrong however, radeonhd might be completely safe and easy. (though I doubt it...) if I am indeed wrong, please call me out on it, and explain why. I've actually been looking into using it once it gets a bit more stable
 
Old 07-26-2009, 12:06 PM   #11
business_kid
Guru
 
Registered: Jan 2006
Location: Ireland
Distribution: Slackware & Android
Posts: 6,625

Rep: Reputation: 585Reputation: 585Reputation: 585Reputation: 585Reputation: 585Reputation: 585
I am using radeonhd no problems yet.

In my experience, most drivers have disclaimers

I did have fglrx, tried to make it work, but every time I built a kernel (I went through a phase of that) it had to be reinstalled. The install script is the most dangerous software out there in linux, and eventually I ended up in a major mess.

YMMV.
 
Old 07-26-2009, 03:33 PM   #12
chickenlinux
Member
 
Registered: Mar 2008
Location: Here - Where else?
Distribution: Fedora 12, Arch Linux (updated daily =D)
Posts: 270

Rep: Reputation: 31
Whoa! Great!

Sounds good to me! I'm thinking about using it! I have a question though, where can I find good documentation for DRI and acceleration with radeonhd, and how do I determine what GPG chipset my card (ATI mobility radeon 3470) uses?
and does a, say, RV670 chipset count as R6xx? and how safe, exactly is the driver? I'm really interested now...
 
Old 07-27-2009, 07:12 AM   #13
merajul
LQ Newbie
 
Registered: Feb 2006
Posts: 5

Original Poster
Rep: Reputation: 0
I am not going to take risk with my new machine. I guess I will just wait until this card is fully supported. Thanks anyway.
 
Old 08-02-2009, 01:38 AM   #14
R03L
Member
 
Registered: Feb 2008
Distribution: mepis, ubuntu server ed. Debian. Redhat. Fedora, centos, LFS
Posts: 211

Rep: Reputation: 31
i alsa have no sound in fedora core 11 on my main system.
i installed it whit sound but afther wine installed the pulseaudio plugin for wine the sound alsa is gone, its kde-system-config alsa wanted to be removed alsa from listing. i removed pulseaudio but it still exists in system-config running but no sound anymore.

when i remove all pulseaudio enhancementś i remove half of kde whit it.
 
Old 08-03-2009, 04:20 AM   #15
business_kid
Guru
 
Registered: Jan 2006
Location: Ireland
Distribution: Slackware & Android
Posts: 6,625

Rep: Reputation: 585Reputation: 585Reputation: 585Reputation: 585Reputation: 585Reputation: 585
hmmm.

Have you tried going to runlevel 3 and using the system tool system-config-sound? That way, no gnome, no kde which simplifies matters. As mentioned, also run alsamixer and unmute everything, whether it makes sense or not. m for mute/unmute; arrows tp move around.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
No sound from SigmaTel C-Major Audio on Fedora Core 4 jun_tuko Fedora 3 01-10-2006 03:56 PM
No sound from SigmaTel C-Major Audio on Fedora Core 4 jun_tuko Fedora 1 01-08-2006 02:32 PM
Fedora Core 3, No Sound, Intel HD audio (ACL880) Sabrelinux Linux - Hardware 0 12-09-2005 12:56 AM
No sound on Intel High Def Audio on Fedora Core 3 ck1125 Linux - Hardware 2 06-06-2005 09:45 PM
No sound from audio CD's with Fedora Core 1 Lanorien Fedora - Installation 1 04-01-2004 05:34 PM


All times are GMT -5. The time now is 10:19 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration