LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Laptop and Netbook (http://www.linuxquestions.org/questions/linux-laptop-and-netbook-25/)
-   -   No Slackware 13.137 GUI on my laptop (http://www.linuxquestions.org/questions/linux-laptop-and-netbook-25/no-slackware-13-137-gui-on-my-laptop-4175440166/)

FlexBuffChest92 12-05-2012 01:18 PM

No Slackware 13.137 GUI on my laptop
 
Hey guys,

I got a new laptop for school, I got it cheap because I will be doing loads of work to it, I go the HP ProBook 6565b and it's a good computer and totally capable of running Windows 7 in 64 bit and I cant use a GUI in Slackware 13.37 can someone possibly inform me as to why this could be?

Habitual 12-05-2012 01:23 PM

boot.
login
Code:

startx
Edit0:
Check out initdefault in /etc/inittab

Code:

# Default runlevel. (Do not set to 0 or 6)
id:4:initdefault:

Yours probably says id:3:initdefault:

3 is text mode or more accurately, console
4 is GUI'fied login

FlexBuffChest92 12-05-2012 01:25 PM

I tried that and it wouldn't work I couldnt get anything. It started to try to load the KDE but then it went back to console and I got error messages saying it was incapable of loading it. I don't see why this would be if it can run Windows 7 on 64 bit

Habitual 12-05-2012 01:32 PM

Quote:

...I don't see why this would be if it can run Windows 7 on 64 bit
First off, quit comparing Linux to Windows. :)
Linux is not Windows.

"incapable of loading it"... could be any number of things and is not very descriptive.

Topic says " No Slackware 13.137 GUI on my laptop". Is that 64 bit also?

Did you use a previous /home directory?
Can root startx?

markush 12-05-2012 02:29 PM

After installing Slackware your first step should be to create a user with adduser, for example
Code:

adduser justme
The adduser script will lead you through some settings, afterwards log in as the new user and type startx.

Markus

TobiSGD 12-06-2012 05:20 PM

The video device in the APU in that laptop is simply to new for the older Slackware 13.37.
Just install the proprietary drivers from AMD for the video device and it will work.


All times are GMT -5. The time now is 06:51 AM.