LinuxQuestions.org
LinuxAnswers - the LQ Linux tutorial section.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Laptop and Netbook
User Name
Password
Linux - Laptop and Netbook Having a problem installing or configuring Linux on your laptop? Need help running Linux on your netbook? This forum is for you. This forum is for any topics relating to Linux and either traditional laptops or netbooks (such as the Asus EEE PC, Everex CloudBook or MSI Wind).

Notices

Reply
 
Search this Thread
Old 11-26-2005, 04:36 PM   #1
rollo
Member
 
Registered: Apr 2004
Location: France
Distribution: Debian Sid (Kanotix)
Posts: 237

Rep: Reputation: 30
Unhappy New kernel installed, laptop won't power off


I've posted on this several times in the newbie forum, but it always draws a blank.

Basically, when booting from newer 2.6 kernels, my Compaq Armada responds differently to the shutdown -h or telinit 0 command. All services seem to terminate correctly, but the final power-down is audibly softer, and the machine seems to go into some kind of hibernate mode. It is then prone to wake up and start the boot process at random.

It seems to be a hardware conflict. So, what could the newer kernel have changed in a concrete sense? And where would I start to troubleshoot this? At the moment I am reduced to pulling out the machine's battery to prevent unwanted boot-ups...

Any help really really appreciated.

Rollo
 
Old 11-27-2005, 09:44 AM   #2
con
Member
 
Registered: Jul 2005
Location: Finland
Distribution: Slackware
Posts: 213

Rep: Reputation: 30
Only thing I can think of is, did you select support for apm/acpi? If so, then is apmd or acpid running?
 
Old 12-05-2005, 03:32 PM   #3
rollo
Member
 
Registered: Apr 2004
Location: France
Distribution: Debian Sid (Kanotix)
Posts: 237

Original Poster
Rep: Reputation: 30
Quote:
Originally Posted by con
Only thing I can think of is, did you select support for apm/acpi? If so, then is apmd or acpid running?
Thanks Con for that idea.

Yep, ACPI is activated as usual by the kernel, and works fine apart from this problem.

But killing the acpid process before doing a shutdown makes no difference to the nature of the shutdown. Why is this?
 
Old 12-05-2005, 05:31 PM   #4
biophysics
Member
 
Registered: Jan 2002
Location: Germany
Distribution: Kubuntu
Posts: 444

Rep: Reputation: 30
Can you post
$ uname -a

(it looks like you are running SUSE 9.1 - If I am not wrong there was a bug in that kernel that caused problem during shutting down in my laptop also. Why dont you try installing SUSE 10.0.

Last edited by biophysics; 12-05-2005 at 05:33 PM.
 
Old 12-06-2005, 06:37 PM   #5
rollo
Member
 
Registered: Apr 2004
Location: France
Distribution: Debian Sid (Kanotix)
Posts: 237

Original Poster
Rep: Reputation: 30
Thanks Bio for that.

Here's what I get with uname -a:

Quote:
Linux linux 2.6.12.3 #2 Sun Oct 16 18:22:50 CEST 2005 i686 i686 i386 GNU/Linux
And yep, I'm using Suse 9.1. What could be interesting is that this problem only occurs with separately compiled kernels. Shutdown is problem-free with the Suse-packaged kernel.

What setting could be being adjusted in the Suse-compiled kernel?
 
Old 12-07-2005, 01:41 AM   #6
win32sux
Guru
 
Registered: Jul 2003
Location: Los Angeles
Distribution: Ubuntu
Posts: 9,870

Rep: Reputation: 371Reputation: 371Reputation: 371Reputation: 371
i'd try compiling the new kernel using the same config file suse uses for their kernel... if that doesn't work either, then i'd suspect that they have applied some kinda special patch or something... big commercial gnu/linux distributors are known to do heavy patching of the kernel lots of times, so if you build a vanilla kernel (from kernel.org) some things will/might be different...

just my $0.02...
 
Old 12-07-2005, 02:38 AM   #7
kosh79
Member
 
Registered: Dec 2004
Location: Australia
Distribution: Debian sarge,Fedora Core 4 & 5, Mandrake 10.1,Knoppix,auditor
Posts: 42

Rep: Reputation: 15
i had same problem a while ago.
but then i reinstalled debian sarge and updated kernel and it fixed it self.
i think it happend coz i edited the modules from another prob.and it just over went it self.

so i had to hold down the ON button for a few secs or long till it shut off.
because it used to just hang.
 
Old 12-07-2005, 01:41 PM   #8
KimVette
Senior Member
 
Registered: Dec 2004
Location: Lee, NH
Distribution: OpenSUSE, CentOS, RHEL
Posts: 1,794

Rep: Reputation: 46
With some laptops you need to use the APM command to power down - there is a specific kernel menuconfig option to enable this call on ACPI laptops.

Power management options (ACPI, APM) --->
APM (Advanced Power Management) BIOS Support --->
[ ] Use real mode APM BIOS call to power off
 
Old 12-07-2005, 03:40 PM   #9
rollo
Member
 
Registered: Apr 2004
Location: France
Distribution: Debian Sid (Kanotix)
Posts: 237

Original Poster
Rep: Reputation: 30
Getting warm

Thanks guys for the ideas! Really appreciate it. Win32sux and Kosh, you're surely right about the causes of this. I would happily stick with the distro-built kernel. Only problem is, I need a recent kernel to get USB working on my laptop.

Quote:
Originally Posted by KimVette
With some laptops you need to use the APM command to power down - there is a specific kernel menuconfig option to enable this call on ACPI laptops.

Power management options (ACPI, APM) --->
APM (Advanced Power Management) BIOS Support --->
[ ] Use real mode APM BIOS call to power off
Kim, thanks so much for this tip. Hopefully this will be what I was looking for! Before I do the recompile, a couple of quick questions:

- Will checking this option cause APM to automatically override ACPI when shutdown is called? I thought you had to enable one or the other at boot time.

- Should I ignore the other options in this branch of the config tree? Specifically, any ideas about the option "Ignore USER SUSPEND"?

Thanks again.

Rollo
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
New kernel installed, system won't power off rollo Linux - Newbie 14 11-18-2005 06:20 PM
Laptop power button it-s Suse/Novell 4 03-31-2005 09:24 PM
Laptop does not power off! But it did before!! eyeliner Slackware 5 10-01-2004 07:33 AM
Laptop Battery power Ryan450 Linux - Laptop and Netbook 5 06-06-2004 07:31 PM
Laptop Power problems gsibble Linux - Hardware 2 12-30-2003 11:22 PM


All times are GMT -5. The time now is 12:59 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration