LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Laptop and Netbook (http://www.linuxquestions.org/questions/linux-laptop-and-netbook-25/)
-   -   Need sound on USB not speaker (http://www.linuxquestions.org/questions/linux-laptop-and-netbook-25/need-sound-on-usb-not-speaker-591476/)

dad 10-13-2007 06:16 AM

Need sound on USB not speaker
 
I have been trying to figure this out for a long time and have posted it a couple times. I have re-installed and something has changed so I will try again.
I have an Everex nc 1502 laptop with Debian Etch installed. I have install alsa drivers and they seem to work. I want to use my USB headphones because I live in a tent. Now Mplayer and Amarok will play through the headphones just fine.
However I can not get Totem or Flash9 to play through the headphones. They play through the speaker which I have to put my ear on the speaker to hear it.
I also had to add "esd" to startup at boot to get the USB sound to work, if that matters. Another note don't know if it means anything, but to get the headphones to be recognized by the system I had to configure Ekiga Softphone.



lspci -v shows.............

04:01.0 Audio device: VIA Technologies, Inc. VIA High Definition Audio Controller (rev 10)
Subsystem: Unknown device 1e40:1509
Flags: bus master, fast devsel, latency 0, IRQ 58
Memory at c9100000 (64-bit, non-prefetchable) [size=16K]
Capabilities: [50] Power Management version 2
Capabilities: [60] Message Signalled Interrupts: Mask- 64bit+ Queue=0/0 Enable-
Capabilities: [70] Express Unknown type IRQ 0


cat /proc/asound/cards shows............

0 [VT82xx ]: HDA-Intel - HDA VIA VT82xx
HDA VIA VT82xx at 0xc9100000 irq 58
1 [Headset ]: USB-Audio - Logitech USB Headset
Logitech Logitech USB Headset at usb-0000:00:10.0-2, full speed

Also lsmod | grep snd..........

snd_usb_audio 69024 0
snd_usb_lib 14976 1 snd_usb_audio
snd_hda_intel 17332 3
snd_hda_codec 137856 1 snd_hda_intel
snd_pcm_oss 38368 0
snd_mixer_oss 15200 1 snd_pcm_oss
snd_pcm 68676 5 snd_usb_audio,snd_hda_intel,snd_hda_codec,snd_pcm_oss
snd_page_alloc 9640 2 snd_hda_intel,snd_pcm
snd_seq_dummy 3844 0
snd_seq_oss 28768 0
snd_seq_midi 8192 0
snd_seq_midi_event 7008 2 snd_seq_oss,snd_seq_midi
snd_seq 45680 6 snd_seq_dummy,snd_seq_oss,snd_seq_midi,snd_seq_midi_event
snd_timer 20996 3 snd_pcm,snd_seq
snd_rawmidi 22560 2 snd_usb_lib,snd_seq_midi
snd_seq_device 7820 5 snd_seq_dummy,snd_seq_oss,snd_seq_midi,snd_seq,snd_rawmidi
snd_hwdep 8836 1 snd_usb_audio
snd 47012 16 snd_usb_audio,snd_hda_intel,snd_hda_codec,snd_pcm_oss,snd_mixer_oss,snd_pcm,snd_seq_oss,snd_seq,snd_ timer,snd_rawmidi,snd_seq_device,snd_hwdep
soundcore 9248 1 snd
usbcore 112644 6 snd_usb_audio,snd_usb_lib,usbhid,ehci_hcd,uhci_hcd



Hope this helps.....thanks

Fluxx 10-13-2007 12:52 PM

I have a notebook with a broken-down sound plug, therefore I use a USB-sound-device. It is loaded with the kernel module "snd-usb-audio".

To make it the default sound device I created a configuration file ".asoundrc" in my $HOME:

Code:

# <card #> is the wished default sound device

pcm.!default {
  type hw
  card 1
}

ctl.!default {
  type hw
  card 1
}

# <usb-sound> is my USB-sound-device
pcm.usb-sound {
  type hw
  card 1
}

ctl.usb-sound {
        type hw
        card 1
}

# <intern> is my broken internal sound chip
pcm.intern {
        type hw
        card 0
}

ctl.intern {
        type hw
        card 0
}

I think this could work in your case too ...

Fluxx.

dad 10-13-2007 02:09 PM

Thanks Fluxx,

I don't know what I'm suppose to use. I don't know whats working and whats not. My Mplayer and Amarok work fine its just Totem and flash9.0 that use the speaker. Its like Totem and Flash decided to do something stupid and neither one is configurable.

Alan

Fluxx 10-13-2007 02:15 PM

You might try this solution too ...

http://www.linuxquestions.org/questi...peaker-581463/

Fluxx.

dad 10-13-2007 11:53 PM

I don't have either one of those files or folders under /etc. Maybe its named something else?
The idea makes sence though. I'll have too dig around. thanx

Ok I think I found it under /etc/modprobe.d/sound. I added a line options snd-usb-audio=0 rebooted and had all sound to speaker. So I thought great I'll swap them around and rebooted. It went back to the way it was, half speaker half usb. So close!


All times are GMT -5. The time now is 01:14 PM.