LinuxQuestions.org
LinuxAnswers - the LQ Linux tutorial section.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Laptop and Netbook
User Name
Password
Linux - Laptop and Netbook Having a problem installing or configuring Linux on your laptop? Need help running Linux on your netbook? This forum is for you. This forum is for any topics relating to Linux and either traditional laptops or netbooks (such as the Asus EEE PC, Everex CloudBook or MSI Wind).

Notices

Reply
 
Search this Thread
Old 01-22-2013, 06:50 PM   #1
raksasas
LQ Newbie
 
Registered: Sep 2012
Posts: 20

Rep: Reputation: Disabled
Need help with a video issue


Hi,
How to I get into ubuntu and update the nvidea drivers (by command line)?

Background:
I have a Toshiba Qosmio X505-Q870 that has a NVIDIA GeForce GTS 360M video card in it.

I have attempted to install Ubuntu 12.04 & 12.10, Fedora 17 & 18, OpenSuse 12.1 & 12.2, Mint 14.1 and Gentoo 20121221. but all i get is a black screen the live environment (more like a black/white checker board screen)

I finally figured out that I get get into into the Ubuntu 12.10 by hitting any key when the keyboard + stick man show up. Followed by hitting f6 and turning on the "nomodeset" option. I then installed it to the drive...

But now. I am having the same problem black screen when it boots. I see the grub menu and i hit "e" to edit the boot but I have no clue what do do on the screen. I typed in "nomodeset" after "setparams 'Ubuntu'" but that did nothing to help....

Thanks,
jpr
 
Old 01-22-2013, 08:45 PM   #2
towheedm
Member
 
Registered: Sep 2011
Location: Trinidad & Tobago
Distribution: Debian Squeeze
Posts: 585

Rep: Reputation: 118Reputation: 118
nomodeset is a kernel command line option. You need to add it to the kernel command line.

When you press e to edit the GRUB menu item, add it to the line that begins with linux. It may be similar to:
Code:
linux /vmlinuz-2.6.35-22-generic root=UUID=a03e3bda-2b90-4bc5-97fa-8168b3691202 nomodeset
If that works and you boot into Ubuntu OK, you can then install the propriety drivers if you wish. If you stick with the Nouveau drivers, you will need to make this permanent, but try it first and see how it works. We can move from there.

Hope it helps.

Last edited by towheedm; 01-22-2013 at 08:46 PM.
 
Old 01-23-2013, 08:42 AM   #3
raksasas
LQ Newbie
 
Registered: Sep 2012
Posts: 20

Original Poster
Rep: Reputation: Disabled
Thank you, towheedm. I tried this first thing this morning and I can now see the desktop. I have spent a week trying to get a version of linux installed on this thing.
 
Old 01-29-2013, 03:01 PM   #4
raksasas
LQ Newbie
 
Registered: Sep 2012
Posts: 20

Original Poster
Rep: Reputation: Disabled
I have attempted to updated to the current nvidia drives but i guess it is a no go..

Quote:
sudo apt-get install linux-source
sudo apt-get install linux-headers-generic
sudo apt-get install nvidia-current-updates
but I just end up with a blank desktop.. All I can see is the background image and that is all.

Any ideas?

Thanks.
 
Old 01-30-2013, 10:29 PM   #5
towheedm
Member
 
Registered: Sep 2011
Location: Trinidad & Tobago
Distribution: Debian Squeeze
Posts: 585

Rep: Reputation: 118Reputation: 118
I think your best bet would be to install the driver from the Additional Drivers app in System Settings. This would select and install the correct driver for your card. DKMS will take care of blacklisting the Nouveau drivers and other settings.

If you must install it from the CLI, note these:
  • The command
    Code:
    sudo apt-get install linux-source
    downloads the source code of the latest kernel. You may instead want to install the nvidia-kernel-source package.
  • You should not install the generic kernel headers, unless of course you are running the generic kernel. If not, install the correct headers with:
    Code:
    sudo apt-get install linux-headers-$(uname -r)
  • Despite the above, simply running:
    Code:
    sudo apt-get install nvidia-current
    should install the correct current driver for your card together with all of the above.
  • If you still get the black screen, you must manually blacklist the Nouveau driver. Since you want to use the command line, create a blacklist file in /etc/modprobe.d with the following command:
    Code:
    echo -e "blacklist nouveau\noptions nouveau modeset=0" | sudo tee /etc/modprobe.d/nvidia-blacklist-nouveau.conf
  • You must now remove the nouveau driver from your initramfs file. Do this:
    Code:
    sudo update-initramfs -u
Reboot and see how it goes.

IMPORTANT: The above must be done from the VT after killing the xserver.

Last edited by towheedm; 01-30-2013 at 10:30 PM.
 
Old 02-04-2013, 07:51 AM   #6
raksasas
LQ Newbie
 
Registered: Sep 2012
Posts: 20

Original Poster
Rep: Reputation: Disabled
What a busy weekend. I have yet to give this ago.
 
Old 02-04-2013, 05:08 PM   #7
raksasas
LQ Newbie
 
Registered: Sep 2012
Posts: 20

Original Poster
Rep: Reputation: Disabled
towheedm are you talking about the searching for "additional drivers" in the GUI software center? If so.. I believe I might have tried that already.

I wiped the system and again installed using the "nomodeset" option. Also In grub I used the "nomodeset" option again after the install to get to the desktop... I then when into the software center and did a search for "additional drivers". It came up and selected install and followed with a reboot after it was done. the system booted to a black/white checkerboard screen. A bunch of text started scrolling the screen at which I walked away form it a bit irritated. I came back to find:

a message on the screen:
The system is running in Low-graphics mode

Your screen, graphics card, and input device settings could not be detected correctly. You will need to config these yourself.

I selected Okay

I then got prompted with a windows asking if I wanted to select Low-graphcis, configure.... and some other options. I selected Low-graphics and then the text started scrolling the screen and after a day still no desktop...

(I did this on Friday)
 
Old 02-07-2013, 02:23 PM   #8
raksasas
LQ Newbie
 
Registered: Sep 2012
Posts: 20

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by towheedm View Post
I think your best bet would be to install the driver from the Additional Drivers app in System Settings. This would select and install the correct driver for your card. DKMS will take care of blacklisting the Nouveau drivers and other settings.

If you must install it from the CLI, note these:
  • The command
    Code:
    sudo apt-get install linux-source
    downloads the source code of the latest kernel. You may instead want to install the nvidia-kernel-source package.
  • You should not install the generic kernel headers, unless of course you are running the generic kernel. If not, install the correct headers with:
    Code:
    sudo apt-get install linux-headers-$(uname -r)
  • Despite the above, simply running:
    Code:
    sudo apt-get install nvidia-current
    should install the correct current driver for your card together with all of the above.
  • If you still get the black screen, you must manually blacklist the Nouveau driver. Since you want to use the command line, create a blacklist file in /etc/modprobe.d with the following command:
    Code:
    echo -e "blacklist nouveau\noptions nouveau modeset=0" | sudo tee /etc/modprobe.d/nvidia-blacklist-nouveau.conf
  • You must now remove the nouveau driver from your initramfs file. Do this:
    Code:
    sudo update-initramfs -u
Reboot and see how it goes.

IMPORTANT: The above must be done from the VT after killing the xserver.
towheedm,
thank you so much. This looks like it worked. I wiped the drive again and installed Ubuntu 12.10 fresh again. I ran did what you provided and I am now able to use my laptop. (Good bye windows on this machine) I got a little worried at first when it was booting but then I got a quick flash of the "Nvidia" logo and then the log in screen. I logged in and got the desktop as it should be. I followed up by testing the HDMI port on it which works but not in mirror mode. I will take what I can since I do not plug anything in HDMI that often.

Thanks a bunch.

(Pardon my ignorance what do you mean by "VT"? I am not sure of all the linux terms yet)
 
Old 02-07-2013, 08:54 PM   #9
towheedm
Member
 
Registered: Sep 2011
Location: Trinidad & Tobago
Distribution: Debian Squeeze
Posts: 585

Rep: Reputation: 118Reputation: 118
VT = Virtual Console, ie: the Linux console, not to be confused with the xterm terminal you get in your desktop environment (Gnome, Unity, XFCE4 etc).

To access the console press <Ctrl> + <Alt> + <Fx>, where F1 is for the first, F2 the second etc. Note that X usually use VT7, so <Ctrl> + <Alt> + <F7> will get you back to your desktop environment if it's running.

It's strange that the Additional Drivers app did not blacklist the Nouveau drivers though. Probably a bug. I don't use Ubuntu, so can't say for sure.

Note though that the nvidia-current may only install the 2D drivers. If you need 3D, you will also need to install the GLX drivers.

I never install the driver from the repos, I always download the appropriate one for my FX5200 card from geforce.com and use that. That provides the option to install both the 2D and 3D drivers.

Glad it worked out for you in the end.

BTW: Since DKMS did not handle the install properly, you may need to repeat the above for each new kernel or kernel updates that you install.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Video Issue Novartum Linux - Software 2 02-21-2011 12:30 PM
Cannot install Ubuntu - Video issue (scrambled video) on install window ?? headshok2002 Ubuntu 2 06-03-2010 11:17 AM
Video/Driver Issue lisa86 Slackware 4 08-26-2008 03:06 AM
Video issue sgmr MEPIS 3 05-11-2008 06:21 AM
redhat 9 video issue justinbigelow Linux - Newbie 1 10-25-2003 03:50 PM


All times are GMT -5. The time now is 03:02 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration