LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Laptop and Netbook
User Name
Password
Linux - Laptop and Netbook Having a problem installing or configuring Linux on your laptop? Need help running Linux on your netbook? This forum is for you. This forum is for any topics relating to Linux and either traditional laptops or netbooks (such as the Asus EEE PC, Everex CloudBook or MSI Wind).

Notices



Reply
 
Search this Thread
Old 04-11-2011, 11:03 AM   #1
Hassan989
LQ Newbie
 
Registered: Mar 2011
Posts: 25

Rep: Reputation: 0
My Mic doesn't work on my toshiba


Hello everyone,

I recently installed skype on my rhel 6.0, 64 bit. But the problem is, my mic doesn't work. The sound comes out through the speakers of my Toshiba laptop even though my external mic is plugged into the mic ports. I can hear the other end (from the computer's speakers not from the head set of the mic) but the other end can't hear me. I went to system preference, sound, input and nothing is muted and when i talk through the mic the input level bar doesn't move. I typed arecord --list-devices and lsusb and i got the following results. Can anyone tells me what to do to get my mic works? Note that i use windows 7 on the othe partition and the mic just works fine. I searched the internet and i'm confused.Thank you.


[root@wi-tribe skype_static-2.2.0.25]# arecord --list-devices**** List of CAPTURE Hardware Devices ****
card 0: Intel [HDA Intel], device 0: CONEXANT Analog [CONEXANT Analog]
Subdevices: 1/1
Subdevice #0: subdevice #0
[root@wi-tribe skype_static-2.2.0.25]# lsusb
Bus 002 Device 004: ID 0bda:0158 Realtek Semiconductor Corp. USB 2.0 multicard reader
Bus 002 Device 003: ID 064e:a216 Suyin Corp.
Bus 002 Device 002: ID 8087:0020 Intel Corp. Integrated Rate Matching Hub
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 001 Device 002: ID 8087:0020 Intel Corp. Integrated Rate Matching Hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
[root@wi-tribe skype_static-2.2.0.25]#
 
Old 04-11-2011, 11:51 AM   #2
TB0ne
Guru
 
Registered: Jul 2003
Location: Birmingham, Alabama
Distribution: SuSE, RedHat, Slack,CentOS
Posts: 15,080

Rep: Reputation: 2713Reputation: 2713Reputation: 2713Reputation: 2713Reputation: 2713Reputation: 2713Reputation: 2713Reputation: 2713Reputation: 2713Reputation: 2713Reputation: 2713
Quote:
Originally Posted by Hassan989 View Post
Hello everyone,
I recently installed skype on my rhel 6.0, 64 bit. But the problem is, my mic doesn't work. The sound comes out through the speakers of my Toshiba laptop even though my external mic is plugged into the mic ports. I can hear the other end (from the computer's speakers not from the head set of the mic) but the other end can't hear me. I went to system preference, sound, input and nothing is muted and when i talk through the mic the input level bar doesn't move. I typed arecord --list-devices and lsusb and i got the following results. Can anyone tells me what to do to get my mic works? Note that i use windows 7 on the othe partition and the mic just works fine. I searched the internet and i'm confused.Thank you.


[root@wi-tribe skype_static-2.2.0.25]# arecord --list-devices**** List of CAPTURE Hardware Devices ****
card 0: Intel [HDA Intel], device 0: CONEXANT Analog [CONEXANT Analog]
Subdevices: 1/1
Subdevice #0: subdevice #0
[root@wi-tribe skype_static-2.2.0.25]# lsusb
Bus 002 Device 004: ID 0bda:0158 Realtek Semiconductor Corp. USB 2.0 multicard reader
Bus 002 Device 003: ID 064e:a216 Suyin Corp.
Bus 002 Device 002: ID 8087:0020 Intel Corp. Integrated Rate Matching Hub
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 001 Device 002: ID 8087:0020 Intel Corp. Integrated Rate Matching Hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
[root@wi-tribe skype_static-2.2.0.25]#
So I take it the other thread that you opened (where you said Skype wouldn't work), has been resolved, but you didn't mark it as SOLVED, or post the solution.

Run alsamixer, and check to see what's muted, and perhaps adjust the levels. Have you tried anything to record sound, outside of skype, like arecord? Are you using alsa or pulseaudio? And again, have you contacted RedHat support???? You're using RHEL, so you're paying for support, right? If not, you shouldn't be using it. Also, unless you have a genuine NEED for RHEL, a 'consumer grade' distro would be far better. Server distros are meant for SERVERS, not laptops or the like. Things like sound/mic/bluetooth aren't found on servers, so support in RHEL is spotty, and for good reason.
 
Old 04-11-2011, 12:46 PM   #3
Hassan989
LQ Newbie
 
Registered: Mar 2011
Posts: 25

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by TB0ne View Post
So I take it the other thread that you opened (where you said Skype wouldn't work), has been resolved, but you didn't mark it as SOLVED, or post the solution.

Run alsamixer, and check to see what's muted, and perhaps adjust the levels. Have you tried anything to record sound, outside of skype, like arecord? Are you using alsa or pulseaudio? And again, have you contacted RedHat support???? You're using RHEL, so you're paying for support, right? If not, you shouldn't be using it. Also, unless you have a genuine NEED for RHEL, a 'consumer grade' distro would be far better. Server distros are meant for SERVERS, not laptops or the like. Things like sound/mic/bluetooth aren't found on servers, so support in RHEL is spotty, and for good reason.
Oh yes the other problem(skype won't work) has been solved just yesterday. I was carried away by the new problem that's why i forgot to mark it solved, but i just did it.

Well first of all i am paying for a self support subscription so i have access to updates and packages through the red hat network. But i can not call them or e-mail them on any problem. The reason why i'm using rhel is because i want to be red hat certified i.e i want to take the exam to be a red hat engineer so i was advised to start with it.

Now my mic seems to be working because my friend called me and he could hear me clearly but i can't hear him. And the input volume bars on sound preference are now moving as i speak through the mic but i can't hear anything.
I typed alsamixer @ the terminal, and a window popped up and i selected my device(Intel HDA). S/PDIF is OFF, don't know what it is nor how to turn it on.Any help? thanks

oh i'm using pulseaudio

Last edited by Hassan989; 04-11-2011 at 12:48 PM.
 
Old 04-11-2011, 03:16 PM   #4
TB0ne
Guru
 
Registered: Jul 2003
Location: Birmingham, Alabama
Distribution: SuSE, RedHat, Slack,CentOS
Posts: 15,080

Rep: Reputation: 2713Reputation: 2713Reputation: 2713Reputation: 2713Reputation: 2713Reputation: 2713Reputation: 2713Reputation: 2713Reputation: 2713Reputation: 2713Reputation: 2713
Quote:
Originally Posted by Hassan989 View Post
Oh yes the other problem(skype won't work) has been solved just yesterday. I was carried away by the new problem that's why i forgot to mark it solved, but i just did it.

Well first of all i am paying for a self support subscription so i have access to updates and packages through the red hat network. But i can not call them or e-mail them on any problem. The reason why i'm using rhel is because i want to be red hat certified i.e i want to take the exam to be a red hat engineer so i was advised to start with it.

Now my mic seems to be working because my friend called me and he could hear me clearly but i can't hear him. And the input volume bars on sound preference are now moving as i speak through the mic but i can't hear anything.
I typed alsamixer @ the terminal, and a window popped up and i selected my device(Intel HDA). S/PDIF is OFF, don't know what it is nor how to turn it on.Any help? thanks

oh i'm using pulseaudio
Ok, so your mic is now working. Chances are, you've got the wrong output selected in Skype, or you've got a channel muted. Do you have ANY sound? Have you gone into the mixer to adjust the levels? Can you play ANYTHING and have it work?

What kind of hardware?
 
Old 04-11-2011, 05:22 PM   #5
Hassan989
LQ Newbie
 
Registered: Mar 2011
Posts: 25

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by TB0ne View Post
Ok, so your mic is now working. Chances are, you've got the wrong output selected in Skype, or you've got a channel muted. Do you have ANY sound? Have you gone into the mixer to adjust the levels? Can you play ANYTHING and have it work?

What kind of hardware?
Well skype sound options has PulseAudio server(local) set(that's the only thing there i.e u can't select other) on speakers, mic and ringing options. I don't have any sound except when i change the hardware(linux sound preferences) from Analog stero input to Analog stereo output. In this case i have sound coming out of the computer's speakers but not through my mic's headset. In this case also the mic is disabled so the volume bar doesn't move at all. So for me to get the mic to work i have to select Analog stero input as the hardware yet there is no output(no sound at all and pple at the other end can clearly hear me). I checked the alsaMixer and the card and chip are both pulseAudio eventhough i could find my HDA intel card when i press f6. Nothing appears to be muted except S/PDIF is off and there is no option to turn it on on the AlsaMixer window. It may be the problem. Is there any way to turn it on @ the terminal? or else where? any more suggestions? thanks.
 
Old 04-11-2011, 05:53 PM   #6
TB0ne
Guru
 
Registered: Jul 2003
Location: Birmingham, Alabama
Distribution: SuSE, RedHat, Slack,CentOS
Posts: 15,080

Rep: Reputation: 2713Reputation: 2713Reputation: 2713Reputation: 2713Reputation: 2713Reputation: 2713Reputation: 2713Reputation: 2713Reputation: 2713Reputation: 2713Reputation: 2713
Quote:
Originally Posted by Hassan989 View Post
Well skype sound options has PulseAudio server(local) set(that's the only thing there i.e u can't select other) on speakers, mic and ringing options. I don't have any sound except when i change the hardware(linux sound preferences) from Analog stero input to Analog stereo output. In this case i have sound coming out of the computer's speakers but not through my mic's headset. In this case also the mic is disabled so the volume bar doesn't move at all. So for me to get the mic to work i have to select Analog stero input as the hardware yet there is no output(no sound at all and pple at the other end can clearly hear me). I checked the alsaMixer and the card and chip are both pulseAudio eventhough i could find my HDA intel card when i press f6. Nothing appears to be muted except S/PDIF is off and there is no option to turn it on on the AlsaMixer window. It may be the problem. Is there any way to turn it on @ the terminal? or else where? any more suggestions? thanks.
Yes. Go into the mixer, click settings->audio setup, and click the devices you want to use for communications.
 
Old 04-11-2011, 07:20 PM   #7
Hassan989
LQ Newbie
 
Registered: Mar 2011
Posts: 25

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by TB0ne View Post
Yes. Go into the mixer, click settings->audio setup, and click the devices you want to use for communications.
I'm sorry to say that there is no any option in the mixer {settings->audio setup}. The mixer window appears inside the terminal and it is not a seperate window. The only options are f1=help, f2= system info, f3=playback, f4=capture, f5=all and f6= select sound(which i did). That's all
 
Old 04-11-2011, 08:54 PM   #8
TB0ne
Guru
 
Registered: Jul 2003
Location: Birmingham, Alabama
Distribution: SuSE, RedHat, Slack,CentOS
Posts: 15,080

Rep: Reputation: 2713Reputation: 2713Reputation: 2713Reputation: 2713Reputation: 2713Reputation: 2713Reputation: 2713Reputation: 2713Reputation: 2713Reputation: 2713Reputation: 2713
Quote:
Originally Posted by Hassan989 View Post
I'm sorry to say that there is no any option in the mixer {settings->audio setup}. The mixer window appears inside the terminal and it is not a seperate window. The only options are f1=help, f2= system info, f3=playback, f4=capture, f5=all and f6= select sound(which i did). That's all
Not in Alsamixer. You're using pulseaudio...alsa and it's tools don't enter into it. In your desktop environment, either KDE or Gnome, click the volume control/go into the mixer. Select it there.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
My inbuilt Mic doesn't work Hassan989 Linux - Software 2 04-11-2011 12:45 PM
[SOLVED] Problem with Toshiba Satellite L505D - key Fn+F8 doesnīt work (Wireless)... gialorga Linux - Laptop and Netbook 1 10-23-2010 08:36 AM
microphone problem mic is rear mic and when i rebooted after repair wont work adb0434 Linux - Newbie 2 10-02-2006 01:37 AM
sound problem - mic - toshiba laptop nickingb Linux - Hardware 1 09-13-2006 05:24 AM
vnc4server doesn`t work! tyranus Debian 4 06-02-2006 07:08 PM


All times are GMT -5. The time now is 08:57 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration