LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Laptop and Netbook
User Name
Password
Linux - Laptop and Netbook Having a problem installing or configuring Linux on your laptop? Need help running Linux on your netbook? This forum is for you. This forum is for any topics relating to Linux and either traditional laptops or netbooks (such as the Asus EEE PC, Everex CloudBook or MSI Wind).

Notices

Reply
 
Search this Thread
Old 04-21-2006, 11:07 AM   #31
phazon
Member
 
Registered: Apr 2006
Location: Wilmington, DE
Distribution: SolydXK, Knoppix
Posts: 125

Original Poster
Rep: Reputation: 18

Well, tell me this; (I have not spent enough time actually using linux to do regular things yet so I'm not sure) If while you are tooling along on a word processor in linux, or spread sheet, and you want to save, then must you always go into the terminal mode and do a

chmod file

to keep working?

By the way, I think I might have remembered the prosses wrong. I tried changing the mouse declaration or what ever it's called, and could not boot Kubunut again. I tried to get into the file structure and change xorg.conf but Knoppix, even though it had the # at the prompt did seem to grant me permission to "save-as" this file. When I do a

ls -l xorg.conf

I get a

-rwxrwxrwx

In response, but it still won't let me save an altered version of it....

So, I guess I am back to re-installing Kubuntu.

I was able, while in Kubuntu (before it would not boot), to add language to etc/fslap (I think thats the name) so as to mount my ntfs partitions. That worked out perfectly, and I felt like a power user for about 5 minutes.

Somehow, changing the

Section

xxxxxxxxxxxxxxx
xxxxxxxxxxxxx
xxxxxxxxxxxxx
xxxxxxxxxxxx

EndSection

for the mouse in etc/X11/xorg.conf chokes the system

I have a feeling that the etc/psaux file is not identicle between Knoppix and Kubuntu. So when it runs that applet to do the mouse, it needs the right wording in xorg.conf.

This begs the question; can I save the version of psaux from Knoppix to Kubuntu and make it work the way Knoppix does? hmmmmm
 
Old 04-21-2006, 12:41 PM   #32
camorri
Senior Member
 
Registered: Nov 2002
Location: Somewhere inside 9.9 million sq. km. Canada
Distribution: Slackware 14.0 + 14.1
Posts: 4,834

Rep: Reputation: 431Reputation: 431Reputation: 431Reputation: 431Reputation: 431
Quote:
you want to save, then must you always go into the terminal mode and do a

chmod file
That generally is not necessary. If you create a new file as a user, with a program like Open Office, the file you create will be set to your user as the owner, and you will have read and write permissions.

The only reason you needed to do that with xorg.conf was because its owner is root, most system files are, and as a user you didn't have write permission. If you do a su to root, then you can read and write the file. The essayist way is to open the application you want to edit the file with from within the konsole, after you do a su to root. The sequence looks like this;

1. Open konsole ( at this point it opens as user.
2. su ( press the enter key ) type the root password (press the enter key).
3. Do a cd to get to the directory where the file is you want to work on.
4. Type the name of the script or binary that launches the application you want to use.
5. Open the file, edit away, and save when done.

Step 4 is the only one that may give you a problem. One way to find out the name of the script, or binary is to look at the icon on the desktop for its properties. Or if it is in the start menu, open the menu to the application you want. Right click on the icon, and edit the item. There is a field called 'command' that field is the script or binary file name to launch the application.

I would suggest you try using something other than Open Office. BTW, OO opens from a konsole if you type 'oowrite' without the quotes.

If you have KDE as your desktop, you should have kate installed. It is a basic text editor. OO may add word processor type stuff to your plain text files you do not want there. It will also add file extension to the file. If it a system file, the boot process won't find the new file.

You need to edit xorg.conf and have it saved with that exact file name. Do not do a 'save as' That will cause the file to be saved, but with some other file name. The system will not file the changes.

Now, let me see if I can guide you a little. If I understand what you were trying to do, you booted the system with knoppix, a live CD and tried to change the file xorg.conf that Kubuntu created during the install.

In order to do that, you need to mount the partition where the Kubuntu installation is. After booting Knoppix, you should see a disk icon on your desktop for each partition on your hard drive. ( I'm assuming you have one HD ). You need to right click the one for your Kubuntu installation. My best guess is it will be hda1 if you have no other operating system installed, or hda5 if you have a single windoze partition. Find it, right click it, there should be an option 'mount' and click it. A little green arrow head will show up.

Now click that icon. Konqueror will start, and show you the files and directory structure on that partition. The F9 key will turn on and turn off a left side navigation bar. Turn it on. You can navigate by clicking the different folders.

From a Knoppix point of view, you have mounted this partition in path /mnt/hda5 ( if it is hda5 or hda1 if it is hda1 ). If you navigate to /mnt/hda5/etc/X11 that is where the Kubuntu xorg.conf file is you need to change.

Hope this helps...

Last edited by camorri; 04-21-2006 at 01:15 PM.
 
Old 04-21-2006, 07:05 PM   #33
phazon
Member
 
Registered: Apr 2006
Location: Wilmington, DE
Distribution: SolydXK, Knoppix
Posts: 125

Original Poster
Rep: Reputation: 18
Quote:
Originally Posted by camorri
From a Knoppix point of view, you have mounted this partition in path /mnt/hda5 ( if it is hda5 or hda1 if it is hda1 ). If you navigate to /mnt/hda5/etc/X11 that is where the Kubuntu xorg.conf file is you need to change.
Yes Knoppix puts them t

mnt/hdax

In my case, I have WinXp on hda1, then just a partiton for holding my windows files on hda5 (I learned the hard way after my operating system crahed to keep my files on a seperate drive or partition). The Linux partition is hda3 I have not creat4ed a seperat partition for my linux files only because I am totally commited to it yet. But I may end up re-formatting the partitions and making the whole drive Linux eventually.

Anyway, I was able to do all of what you suggested by using Konsole to get to

hda3/est/X11/xorg.conf

but while in Knoppix, if I types

chmod 777 xorg.conf

instead of just going back to the primpt (thus having changd the permissions) it says something like "changing permissions for "read only" file, and if I do a

ls -l xorg.conf

it show me

-rwxrwxrwx

But, I can not save the xorg.conf file when I have edited it using Kate.

Once I re-installed Kubuntu, I ws able to all of the same, but it does not give me the message after

chod 777 xorg.conf

and I am able to save (this time for modifications to my fstab file for moutningmy hard drives)

Conclusion, Knoppix does not seem to hold sway over hda3 even after ding

su

While in Knoppix, I am not asked for a password after doing

su

It simply goes to #


hmmmm
 
Old 04-22-2006, 05:46 AM   #34
camorri
Senior Member
 
Registered: Nov 2002
Location: Somewhere inside 9.9 million sq. km. Canada
Distribution: Slackware 14.0 + 14.1
Posts: 4,834

Rep: Reputation: 431Reputation: 431Reputation: 431Reputation: 431Reputation: 431
Quote:
it says something like "changing permissions for "read only" file,
This is because Knoppix has mounted the drive as read only.

The reason is simple enough. For saftey reasons, the creators of Knoppix decided it was best to mount drives read only, to help prevent accidental damage to files on some other operationg system.

To change this, after you boot Knoppix, and before you click the disk icon to mount the linux partition;

1. Open a konsole and su to root.

2.Navigate to /etc.

3. Open a file called fstab. This file is the file used by the system to mount file systems into the 'tree'.

Here are two lines from my fstab file, to give you some idea of what to expect.

Code:
/dev/hdb6 /mnt/pictures ext2 defaults 1 2
/dev/hda1 /mnt/win_c vfat umask=0,iocharset=iso8859-15,codepage=850 0 0
The first line is a linux partition, and the second is a windbloze partition. If we look a the first line, the 'dev/hdb6' is the hardware device of the partition, as linux knows it. The 'mnt/pictures' is the mount point in my file system. The 'ext2' is the type of file system on that partition. The rest of the line tells the os how to mount the partition.

On your machine you will see a flag in this field 'ro' This stands for read only. To mount as read write, edit the 'ro' to rw. Save and close the file.

4. Now mount the partition, and you will be able to save changes to the xorg.conf file.

Some cool stuff, in linux you can add partitions on the fly, just by editing the /etc/fstab file and then mounting the partition. You would have to boot the system in windoze to do the same task.

Add this skill to your kit bag...
 
Old 04-22-2006, 11:27 AM   #35
phazon
Member
 
Registered: Apr 2006
Location: Wilmington, DE
Distribution: SolydXK, Knoppix
Posts: 125

Original Poster
Rep: Reputation: 18
Quote:
Originally Posted by phazon
I had this idea, and it seems to have worked out. First of all, I found it interesting that after I had to re-install kubuntu (because I corrupted the xorg.conf file trying to get the machine to see my PS/2 mouse) I found that when I typed the following lines

/dev/hda1 /media/windows ntfs user,fmask=0111,dmask=0000 0 0
/dev/hda5 /media/windows ntfs user,fmask=0111,dmask=0000 0 0

into

etc/fstab

that when I closed it, my hard drives appeared in the desktop media folder. As if simply typing it and closing the editor was a command in it self. Odd.

Any way, so I found that if I used the Konsole to browse to the files in media, that only 1 of the 2 hard drives files were there. this meant that I could not give the

chmod 777 file

command to the files on the HDD I could not get to. Oddly enough, I could still see the files on each drive using the web browser or editor, I just cold not save to them without giving permission in the Konsole setting.


hmmm

so I tried this

First, while in the root directory, I did

mkdir /media/windows1

then

mkdir /media/windows2

then I modified

etc/fstab

by adding this

/dev/hda1 /media/windows1 ntfs user,fmask=0111,dmask=0000 0 0
/dev/hda5 /media/windows2 ntfs user,fmask=0111,dmask=0000 0 0

at first, when I closed it out, I again saw the images of the 2 extra hdd's magically appear in the media folder, but I could not see the files in them this time until I re-booted.

After re-booting, I was not only able to see the files using what ever browser or editor, but I was also able to browse to them using the Konsole. this is so cool

I feel like a power user!

I would definitely feel like one if I could figure out how Knoppix, and Damn Small Linux are able to make my PS/2 mouse work and do that for Kubuntu.

Cheers
The above is one of my own quotes form another thread I started on trying to see my partitions. As you may be able to tell after reading this, I have had sucess in moutning my partitions as rwx using the commands I added to fstab.

Now if only getting my mouse to work was as easy.

I have tried several differnt mods to xorg.conf including

Section "Pointer"
Protocol "IMPS/2"
Device "/dev/mouse"
ZAxisMapping 4 5
EndSection

and

Section "InputDevice"
Indentifier "Mouse"
Driver "mouse"
Option "Protocol" "imps/2"
Option "Dvice" "/dev/psaux"
Option "ZAxisMapping " "4 5"
Option "Buttons" "3"
EndSection

and, this is one is from XF86Config from Knoppix...

Section "pointer"
Protocol "PS/2"
Device "/dev/mouse"
Emulate3Buttons
Emulate3Timeout 70
EndSection

I suppose I will try this one next...

Section "InputDevice"
Indentifier "Configured Mouse"
Driver "mouse"
Option "Corepointer" "imps/2"
Option "Device" "/dev/inpout/mice"
Option "Protocol" "ExplorerPS/2"
Option "Emulate3Buttons" "false"
Option "Buttons" "7"
Optoin "ZAxisMapping" "6 7"
EndSection

Actually, I think the last one is what Kubunut is already using, I'll have to check.

Mouting my hard drvies was easy and worked like a charm, but every time I modified my xorg.conf file with one of the above, Kubuntu would no longer boot and gave me this message.

ubuntu login:[4294741.138000] cpufreq: change failed with new-state 1 and result 0

If you read through the differnet thing I tried above, you can see how some similar sentences are capitalized in one but not in another, or are in quotes in one but not in another.

I really think that the differences are due to the fact that xorg.conf or XF86Config are calling for applets that are specific to the Linux pacakge you are running; therefore, the Section, """"",EndSection command lines are not interchangable. You would have to have the whole set of applets, and those would have to be coordinating with everything else, so it gets into a can of worms rather quickly. I think the designers of Kubuntu would have to address this, or I would have to become a "C" programmer and reverse engineer or find the open source for the applets and "get busy".

I think that I have exhausted my abilities at this juncture unless someone comes up with another solution.

I will have to live with using only the touch pad for now until I find another iso to download that does what I want as far as mouting hard drives and using my PS/2 mouse, or uless I find a "patch" for the mouse problem with Kubuntu.

Cheers

Last edited by phazon; 04-22-2006 at 11:29 AM.
 
Old 04-22-2006, 06:10 PM   #36
phazon
Member
 
Registered: Apr 2006
Location: Wilmington, DE
Distribution: SolydXK, Knoppix
Posts: 125

Original Poster
Rep: Reputation: 18
Ok, someone turned me onto using nano at the recovery mode command prompt by typing

sudo nano /etc/X11/xorg.conf

Using nano in the recovery mode helped a lot. I had been trying to alter xorg.conf using Kate editor and saving etc. After using Kate, I was un-able to boot Kubuntu and had to re-install it. Using nano alowed me to change xorg.conf several times and restart to see what it did. Here is how my Kubuntu xorg.conf handles the mouse

Section "InputDevice"
Identifier "Configured Mouse"
Driver "mouse"
Option "CorePointer"
Option "Device" "/dev/input/mice"
Option "Protocol" "PS/2"
Option "Emulate3Buttons" "true"
Option "ZAxismapping" "4 5"
EndSection


I noticed that there is no character device called "mice" in /dev/input, but there is "mouse0" and "mouse1", so a tried changing "mice" to "mouse0" and re-starting, and at least I was able to get all the way to the desktop. There was no change in the behavior of the machine. Then I tried changing it to "mouse1", same result. Then I tried changing the whole line from /dev/input/mice" to "/dev/psaux". This made it so even using the touch pad made the pointer jump all over the screen in a very useless way.

Knoppix uses this

Section "Pointer"
Protocol "PS/2"
Device "dev/mouse"
Emulate3Buttons
Emulate3Timeout 70
EndSection

So I'm thinking that if Kubuntu is calling for character device "mice", but it does not exist, and "mouse0" and "mouse1" are probably worthless, how about dragging a copy "mouse" from Knoppix" into the folder for Kubuntu and calling for "mouse" instead of "mice" in Kubuntu. Problem is, I don't know how to create the proper permissions to do this. While in Knoppix it won't let me copy character device "mouse" to the Kubunu folders.

First: Am I on the right track?

Second: How do I copy character device "mouse" from knoppix to Kubuntu?
 
Old 04-25-2006, 11:17 AM   #37
phazon
Member
 
Registered: Apr 2006
Location: Wilmington, DE
Distribution: SolydXK, Knoppix
Posts: 125

Original Poster
Rep: Reputation: 18
OK,

I found this

https://wiki.kubuntu.com/SerialMouseHowto

on the Kubuntu pages. While this is for a serial port setting, I found that by adding this to xorg.conf, and exitting nano, my mouse buttons would cause the pointer to jump accross the screen. Useless reallyt, b ut far more life thtn it had out of the box. After re-booting, neither the touch pad nor the mouse would work at all. So I had to re-use the back up of xorg.conf~

Even though this didn't work, it points to the possibility that there is a port issue. It seems that Kubuntu has to b e told where to look and then all of the other option this, protocol that will work.

QUESTION; What does Linux call the PS/2 port?
 
Old 04-25-2006, 01:07 PM   #38
camorri
Senior Member
 
Registered: Nov 2002
Location: Somewhere inside 9.9 million sq. km. Canada
Distribution: Slackware 14.0 + 14.1
Posts: 4,834

Rep: Reputation: 431Reputation: 431Reputation: 431Reputation: 431Reputation: 431
Quote:
QUESTION; What does Linux call the PS/2 port?
Good question... Linux assigns a special file to each detected piece of hardware, and you will find them in the /dev directory. If you go there with konqueror, you will see the files. Some are easy to tell what they are, others are more difficult to tell.

I looked at my Ubuntu system which has a synaptic touch pad, and a 2 button wheel mouse, BTW, my wheel mouse is USB, not PS/2. My system has the following;

/dev/input/mice
/dev/input/mouse0
/dev/input/mouse1
/dev/psaux

From xorg.conf, here are the sections for the two mice.

Code:
Section "InputDevice"
        Identifier      "Configured Mouse"
        Driver          "mouse"
        Option          "CorePointer"
        Option          "Device"                "/dev/input/mice"
        Option          "Protocol"              "ImPS/2"
        Option          "Emulate3Buttons"       "true"
        Option          "ZAxisMapping"          "4 5"
EndSection

Section "InputDevice"
        Identifier      "Synaptics Touchpad"
        Driver          "synaptics"
        Option          "SendCoreEvents"        "true"
        Option          "Device"                "/dev/psaux"
        Option          "Protocol"              "auto-dev"
        Option          "HorizScrollDelta"      "0"
EndSection
If you look at the two sections, the USB mouse is first, it uses /dev/input/mice with protocol ImPS/2, and driver mouse.

The touchpad uses /dev/psaux protocol auto-dev and the synaptics driver.

I know you are using the PS/2 port. Could you post more info about the mouse? How many buttons 2 or 3 or more? Does it have a scroll wheel?
 
Old 04-25-2006, 04:16 PM   #39
phazon
Member
 
Registered: Apr 2006
Location: Wilmington, DE
Distribution: SolydXK, Knoppix
Posts: 125

Original Poster
Rep: Reputation: 18
This....

Section "InputDevice"
Identifier "Configured Mouse"
Driver "mouse"
Option "CorePointer"
Option "Device" "/dev/input/mice"
Option "Protocol" "ImPS/2"
Option "Emulate3Buttons" "true"
Option "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"
Identifier "Synaptics Touchpad"
Driver "synaptics"
Option "SendCoreEvents" "true"
Option "Device" "/dev/psaux"
Option "Protocol" "auto-dev"
Option "HorizScrollDelta" "0"
EndSection

Is identicle to mine. This does not make it work. Knoppix and DSL seem to be able to. There has to be something, somewhere else that we are missing. I am using a standard GE optical, 2 button, 1 wheel mouse. Plugged into the PS/2 port. I would have suspected a bad port, but Knoppix and DSL work fine. If I knew the name of the port, then this might work. I am thinking of plugging the mouse into the serial port and trying the other thing I posted last. Maybe that will work. If it does then I will stop fighting it. I would still like to solve this and post it for the world to know. Then maybe the next poor schlepp will have a better time of it.

Let me know if anything else occurs to you. Thanks for your help.
 
Old 04-26-2006, 11:34 AM   #40
phazon
Member
 
Registered: Apr 2006
Location: Wilmington, DE
Distribution: SolydXK, Knoppix
Posts: 125

Original Poster
Rep: Reputation: 18
Ummm...

Ok, feeling a little chagrin here. Just for the heck of it, I plugged in a good old fashioned 2 button, one wheel, roller ball mouse (not an optical mouse) and it works fine..........!

Now, I suffered under the assumption that optical mousses (mice?) processed the optical portion of the data within the mouse itself, and sent "roller ball" info down the wire to the PS/2 port; thus, looking like a roller ball mouse to the computer.

Apparently not. Whatever is going on, it has to do with the optical vs. roller ball equipment.

I am very happy that a standard roller ball will work, even though I would be much happier if an optical mouse would work.

It still begs the question:

Why can Knoppix and DSL do this and Kubuntu can't?

Do the designers of Kubuntu care?

If I find the answer to this it will be while using a roller ball mouse, but rest assured, I will post the solution here!

Thanks to all of those who responded. Perhaps this news has jogged the memory of someone who knows the riddle here. Feel free to contact me at

phazon1@hotmail.com if you have some information on this.

Last edited by phazon; 04-26-2006 at 11:35 AM.
 
Old 04-26-2006, 12:00 PM   #41
camorri
Senior Member
 
Registered: Nov 2002
Location: Somewhere inside 9.9 million sq. km. Canada
Distribution: Slackware 14.0 + 14.1
Posts: 4,834

Rep: Reputation: 431Reputation: 431Reputation: 431Reputation: 431Reputation: 431
Interesting stuff, I'm doing some research into the problem. I think I have some answers, and will post shortly...
 
Old 04-26-2006, 12:45 PM   #42
camorri
Senior Member
 
Registered: Nov 2002
Location: Somewhere inside 9.9 million sq. km. Canada
Distribution: Slackware 14.0 + 14.1
Posts: 4,834

Rep: Reputation: 431Reputation: 431Reputation: 431Reputation: 431Reputation: 431
I have done some testing on my Compac laptop, with Ubuntu Breezy. First, the touch pad works, and so does my mouse IF attached to USB. It does not work when plugged into PS/2 port, using a USB to PS/2 converter. So, I believe this is similar to your results. I did not try a straight PS/2 mouse, roller ball or PS/2 optical.

I booted my Knoppix 3.9 live CD, and it shows the same results as Ubuntu, USB mouse works, will not work plugged to PS/2 port.

I found some information on a known kernel issue, basically if you are running a 2.6.8 or later kernel, there are problems being worked on. Knoppix 3.9 is running kernel 2.6.11 and Ubuntu Breezy is running 2.6.12. BTW, if you want to know how to to determine the kernel, on a console type 'uname -r' (without the quotes) and it will tell you.

I also found threads for other distros sowing problems with the 2.6.x kernels. Patches are being worked on, but I would not suggest a noob try to install a patch. Never tried it myself.

It seems you have found a work around, using a roller ball PS/2 mouse.

I would suggest you may look at buying a USB optical mouse, I believe it will work without any hassel.

Quote:
Why can Knoppix and DSL do this and Kubuntu can't?
I think the answer here lies in what kernel version these other distros are running. Note, Knoppix 3.9 ( kernel 2.6.11 ) fails.

Quote:
Do the designers of Kubuntu care?
You bet they do. If you want to pursue this further, you would need to post to the Ubuntu Wiki in the bugzilla section. Be prepared to be asked to help with testing.
 
Old 04-26-2006, 08:55 PM   #43
phazon
Member
 
Registered: Apr 2006
Location: Wilmington, DE
Distribution: SolydXK, Knoppix
Posts: 125

Original Poster
Rep: Reputation: 18
So cool. I thank you for your intelligent responses. You have helped me learn loads in the short while I have been fooling around with this stuff. I think the mouse problem actually helped me in the long run. From what I can tell, Linux is far from being soccer-mom friendly (no offense soccer-moms; you rock!). I believe many Linux varsity users might not care, but when I first heard of Linux, it was presented as a hedge against the monopoly and suckiness of you-know-who. It has obviously grown to be more fun and productive than anything you-know-who could hope to attain, but I am afraid it will never send you-know-who packing if a friendlier version does not emerge.

Since I have a tinkering impulse, I dig it. I knew that it was high maintenance going into it. I have friends who still have a knee jerk reaction to the suggestion of using it, and I know it is because they are afraid they are going to starve.

Be that as it may. I love what I have seen so far and I plan on getting very much immersed in it.


CHEERS. I'll check back

Last edited by phazon; 05-07-2006 at 10:18 PM.
 
Old 04-27-2006, 08:59 AM   #44
camorri
Senior Member
 
Registered: Nov 2002
Location: Somewhere inside 9.9 million sq. km. Canada
Distribution: Slackware 14.0 + 14.1
Posts: 4,834

Rep: Reputation: 431Reputation: 431Reputation: 431Reputation: 431Reputation: 431
It was a pleasure to help. No dought, the learning curve is steep, and long. Once you have made it over the hump, you may well see your way clear to give windbloze the boot...

Linux is just like an indian tent: no Gates, no Windows and an Apache inside...
 
  


Reply

Tags
laptop, mouse


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
[Ubuntu] Problems setting Microsoft Intellimouse mouse and network pocetnik Linux - Software 0 11-25-2005 01:38 PM
transplant OO.o 2.0 beta from KNOPPIX to Ubuntu - is it possible? exit3219 Linux - Software 2 08-25-2005 04:48 AM
Knoppix can use my CDRW drive but ubuntu (installed) can't jaybee Linux - Hardware 2 02-17-2005 06:05 AM
5 button mouse problems in Ubuntu DownloadTHIS Linux - Hardware 1 02-08-2005 05:09 PM
SUSE, KNOPPIX, modem, mouse problems thedune Linux - Hardware 0 11-23-2003 06:57 AM


All times are GMT -5. The time now is 08:57 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration