LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Laptop and Netbook
User Name
Password
Linux - Laptop and Netbook Having a problem installing or configuring Linux on your laptop? Need help running Linux on your netbook? This forum is for you. This forum is for any topics relating to Linux and either traditional laptops or netbooks (such as the Asus EEE PC, Everex CloudBook or MSI Wind).

Notices

Reply
 
Search this Thread
Old 12-27-2007, 07:33 AM   #1
chewbo
LQ Newbie
 
Registered: Nov 2007
Posts: 14

Rep: Reputation: 0
mouse and touchpad


Hi.
I have an Acer 5051 and wonder how to get my mouse to work. The touchpad was no problem, but somehow the mouse. It is an USB mouse. I use Debian. How looks the xorg.conf An which is the right devce in /dev?

chewbo
 
Old 12-27-2007, 08:59 AM   #2
H_TeXMeX_H
Guru
 
Registered: Oct 2005
Location: $RANDOM
Distribution: slackware64
Posts: 12,928
Blog Entries: 2

Rep: Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269
Why not get xorg to auto-detect it, it might work better. Try running 'xorgcfg' as root.
 
Old 12-28-2007, 05:15 AM   #3
chewbo
LQ Newbie
 
Registered: Nov 2007
Posts: 14

Original Poster
Rep: Reputation: 0
There is no xorgcfg. And there is also no xorgconf when i try apt-cache search xorgconf.
 
Old 12-28-2007, 08:00 AM   #4
H_TeXMeX_H
Guru
 
Registered: Oct 2005
Location: $RANDOM
Distribution: slackware64
Posts: 12,928
Blog Entries: 2

Rep: Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269
That's very odd, because 'xorgcfg' is included with xserver itself. For the mouse section of '/etc/X11/xorg.conf' it should look something like:

Code:
Section "InputDevice"
    Identifier     "Mouse0"
    Driver         "mouse"
    Option         "Protocol" "auto"
    Option         "Device" "/dev/input/mice"
    Option         "ZAxisMapping" "4 5"
EndSection
But, "Mouse0" should match what you have up near the top of the file:

Code:
Section "ServerLayout"
    Identifier     "X.org Configured"
    Screen          0 "Screen0" 0 0
    InputDevice    "Mouse0" "CorePointer"
    InputDevice    "Keyboard0" "CoreKeyboard"
EndSection
Still, try to look for 'xorgcfg', it'll probably do a better job.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
how to configure touchpad mouse Ay-Karamba! Linux - Laptop and Netbook 17 12-13-2005 06:20 AM
usb mouse and touchpad hippy2981 Linux - Newbie 3 11-23-2004 03:28 AM
Touchpad mouse Mal495 Mandriva 1 05-23-2004 02:58 PM
Touchpad and USB mouse jb_za Linux - Laptop and Netbook 1 03-14-2004 05:17 PM
touchpad mouse + usb mouse on laptop guild Libranet 1 11-28-2003 09:42 AM


All times are GMT -5. The time now is 05:50 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration