LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Laptop and Netbook
User Name
Password
Linux - Laptop and Netbook Having a problem installing or configuring Linux on your laptop? Need help running Linux on your netbook? This forum is for you. This forum is for any topics relating to Linux and either traditional laptops or netbooks (such as the Asus EEE PC, Everex CloudBook or MSI Wind).

Notices

Reply
 
Search this Thread
Old 09-13-2010, 08:10 AM   #1
mad_one
LQ Newbie
 
Registered: Sep 2010
Location: Croatia
Distribution: mint 9
Posts: 6

Rep: Reputation: 0
mint 9 wireless acting weird


Hello everyone.

I've installed mint 9 yesterday on a hp 6820s. Everything went well but i am experiencing certain problems with my wireless. I tried searching the web and following some advice but they've only helped me partially.

I used Administration -> Hardware drivers to activate the Broadcom bcm4312 drivers. Right now it says the driver is active and currently in use. I also added new wireless connection via right click on the icon in lower right corner and clicking on Add...

It obviously works as it can find wireless networks including mine. When i try to connect to it it asks for the password. Then it keeps trying to connect (icon with spinning arrow around 2 dots in the tray) and asks me for password several times.

When it finally connects i tried opening google in firefox but with no luck. That goes for any site i try to open. It acts the same way as if i had no connection. "Server not found"


I am completely new to any kind of linux so go easy on me

Last edited by mad_one; 09-13-2010 at 08:12 AM.
 
Old 09-13-2010, 08:39 AM   #2
MrCode
Member
 
Registered: Aug 2009
Location: Oregon, USA
Distribution: Arch
Posts: 864
Blog Entries: 31

Rep: Reputation: 148Reputation: 148
Quote:
When it finally connects i tried opening google in firefox but with no luck. That goes for any site i try to open. It acts the same way as if i had no connection. "Server not found"
Have you tried pinging your router? You can try it by opening a Terminal window (should be found right in your main panel menu) and entering ping <IP address of router>, and stop it with Ctrl-C. If you can ping the router, but not the internet, you might just need to configure your DNS settings so that they point to your ISP's DNS servers (or OpenDNS).

Last edited by MrCode; 09-13-2010 at 08:41 AM.
 
Old 09-13-2010, 02:41 PM   #3
mad_one
LQ Newbie
 
Registered: Sep 2010
Location: Croatia
Distribution: mint 9
Posts: 6

Original Poster
Rep: Reputation: 0
I pinged it's ip (192.168.1.1) and got all replies. Can't ping any website, only via wired.
 
Old 09-13-2010, 03:03 PM   #4
MrCode
Member
 
Registered: Aug 2009
Location: Oregon, USA
Distribution: Arch
Posts: 864
Blog Entries: 31

Rep: Reputation: 148Reputation: 148
Does your system get its IP address via DHCP? It might be that it's getting the wrong (or simply no) DNS address. I would try going into NetworkManager's configuration settings (right-click your signal level icon and hit "Edit Connections..."), going to your wireless interface (should be wlan0), and hitting "Edit". From there, under the "IPv4 Settings" tab, change "Method" to Manual. Then put in the appropriate info. For example, "Address" should be the IP that you want to use for your machine (preferably something that is guaranteed not to be used by any other computers on the network), "Netmask" should be all 255s except the last digit (this is how it works for me at least), and "Gateway" should be the IP of your router (in your case, 192.168.1.1).

Is there any way of finding out your DNS server addresses manually? Perhaps you could connect to a wired interface temporarily and do cat /etc/resolv.conf from a terminal (this file contains the DNS resolution address(es) in use for the current session). If you can find this info (either via my method above or in some other way), you would put it into the "DNS servers" field in the configuration of your wireless interface.

Last edited by MrCode; 09-13-2010 at 03:04 PM.
 
Old 09-13-2010, 04:23 PM   #5
mad_one
LQ Newbie
 
Registered: Sep 2010
Location: Croatia
Distribution: mint 9
Posts: 6

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by MrCode View Post
From there, under the "IPv4 Settings" tab, change "Method" to Manual. Then put in the appropriate info. For example, "Address" should be the IP that you want to use for your machine (preferably something that is guaranteed not to be used by any other computers on the network), "Netmask" should be all 255s except the last digit (this is how it works for me at least), and "Gateway" should be the IP of your router (in your case, 192.168.1.1).

Perhaps you could connect to a wired interface temporarily and do cat /etc/resolv.conf from a terminal (this file contains the DNS resolution address(es) in use for the current session). If you can find this info (either via my method above or in some other way), you would put it into the "DNS servers" field in the configuration of your wireless interface.
I tried switching it to manual, this is what i typed in:
192.168.1.3, 255.255.255.0, 192.168.1.1

Tried cat /etc/resolv.conf and the response was 192.168.1.1 only. Thats what i put in the "DNS servers". Also tried without it.

While the method was set to Manual it kept trying to connect over and over again and asking me for the password to the network every minute or so. After 4-5 password queries it said "disconnected".

EDIT: I found a typo in the MTU field
I corrected it but nothing changed.

Last edited by mad_one; 09-13-2010 at 04:36 PM.
 
Old 09-14-2010, 06:15 AM   #6
mad_one
LQ Newbie
 
Registered: Sep 2010
Location: Croatia
Distribution: mint 9
Posts: 6

Original Poster
Rep: Reputation: 0
Ok what the f...? I just turned on my laptop and wireless worked like a charm the moment OS was booted and ready. I set it back to
automatic (DHCP) last night. The only difference from other times when it didnt work is that i turned the laptop on without lan cable being connected to it. Weird...

Hope it works from now on. Thank you for trying MrCode
 
Old 09-14-2010, 06:20 AM   #7
Coburn64
LQ Newbie
 
Registered: Jul 2009
Location: Australia
Distribution: Debian GNU/Linux 6.0 Squeeze
Posts: 27

Rep: Reputation: 16
I was going to suggest maybe updating your kernel. My ASUS Laptop has a wireless chip in it that causes system crashes (Kernel OOPS) and when I updated the kernel, that issue was gone.
 
Old 09-14-2010, 06:59 AM   #8
mad_one
LQ Newbie
 
Registered: Sep 2010
Location: Croatia
Distribution: mint 9
Posts: 6

Original Poster
Rep: Reputation: 0
Thank you for the suggestion. Hopefully it will continue to work
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
OS acting weird MTK358 Linux - Newbie 5 01-07-2010 06:08 PM
apache acting weird Red Squirrel Linux - Software 2 08-19-2005 09:47 PM
Networkcard is acting weird Rolby Linux - Hardware 2 06-26-2004 02:45 PM
cdrom acting weird Vindane Slackware 5 05-30-2004 01:53 AM
Radeon acting weird... r_jensen11 Linux - Hardware 9 05-09-2004 02:41 AM


All times are GMT -5. The time now is 10:37 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration