LinuxQuestions.org
Did you know LQ has a Linux Hardware Compatibility List?
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Laptop and Netbook
User Name
Password
Linux - Laptop and Netbook Having a problem installing or configuring Linux on your laptop? Need help running Linux on your netbook? This forum is for you. This forum is for any topics relating to Linux and either traditional laptops or netbooks (such as the Asus EEE PC, Everex CloudBook or MSI Wind).

Notices

Reply
 
Search this Thread
Old 12-23-2007, 06:20 PM   #1
about36ninjas
LQ Newbie
 
Registered: Dec 2007
Distribution: Mandriva 2008.0 (w/ 2007.1 non-free)
Posts: 13

Rep: Reputation: 0
Mandriva (HP zv5420) volume keys control master mono, NOT MASTER!


Alright, it's really a simple problem, but it's annoying me. The volume controls just won't use the master channel.. they always use master mono (which doesn't really do anything for my box).

Here's what I know:

scancodes set correctly
keycodes set correctly
keysyms set correctly
--USING KMIX!!!--
hotkeys are set for master
no hotkeys are set for master mono
BIOS has absolutely zero options for controlling the keys

I have mandriva 2008.0, just installed. I had 2007.0 which did exactly the same thing. I'm using kernel ... 2.6.22.something. Doesn't matter. Any ideas on how to fix this?

So where do you guys think the hotkey is being intercepted?
 
Old 12-24-2007, 01:48 AM   #2
about36ninjas
LQ Newbie
 
Registered: Dec 2007
Distribution: Mandriva 2008.0 (w/ 2007.1 non-free)
Posts: 13

Original Poster
Rep: Reputation: 0
UPDATE: keys are not recognized by kde anymore... and I have no idea why. Need help!!
 
Old 12-24-2007, 12:15 PM   #3
Agentvenom
Member
 
Registered: Sep 2005
Distribution: PCLinuxOS 2007 / Suse 10.3
Posts: 228

Rep: Reputation: 30
Have you set your keyboard layout to reflect HP? If you haven't, first go into Kcontrol and edit the keyboard layout to be "HP Pavillion ZT11XX". This will enable use of the multimedia keys. Then, try the volume controls. If they aren't what you want, I would say open KMix and configure the shortcuts. But, I've never had a problem after setting up the keyboard to reflect the HP layout. Let me know if that helps at all...
 
Old 12-24-2007, 06:44 PM   #4
about36ninjas
LQ Newbie
 
Registered: Dec 2007
Distribution: Mandriva 2008.0 (w/ 2007.1 non-free)
Posts: 13

Original Poster
Rep: Reputation: 0
The most simple answer is usually the correct one. THANK YOU! Works perfectly... I hadn't had the ZT driver configured... I was using some multimedia thing. Works fine. THANK YOU. SERIOUSLY.
 
Old 12-25-2007, 11:12 AM   #5
Agentvenom
Member
 
Registered: Sep 2005
Distribution: PCLinuxOS 2007 / Suse 10.3
Posts: 228

Rep: Reputation: 30
Quote:
Originally Posted by about36ninjas View Post
The most simple answer is usually the correct one. THANK YOU! Works perfectly... I hadn't had the ZT driver configured... I was using some multimedia thing. Works fine. THANK YOU. SERIOUSLY.
You're welcome!
 
Old 12-25-2007, 09:04 PM   #6
about36ninjas
LQ Newbie
 
Registered: Dec 2007
Distribution: Mandriva 2008.0 (w/ 2007.1 non-free)
Posts: 13

Original Poster
Rep: Reputation: 0
Aaaand We're Back!

yep, issue's back. I had run kmix as root, which doesn't have the problem - but I had to reinstall... now running kmix as root has no keys working, while running kmix as my normal user has the keys working for master mono, again. It's got to be a setting in my user profile... but where? what?
 
Old 12-25-2007, 09:44 PM   #7
about36ninjas
LQ Newbie
 
Registered: Dec 2007
Distribution: Mandriva 2008.0 (w/ 2007.1 non-free)
Posts: 13

Original Poster
Rep: Reputation: 0
Fixed!

Okay, here's what I had to do:

Map the keys in /etc/X11/Xmodmap. Doesn't matter what name I gave them, as long as they're mapped. After I did that everything worked fine.... weird.
Also, using the ZT11XX driver was needed. Now I know at least.
 
Old 12-26-2007, 02:11 PM   #8
about36ninjas
LQ Newbie
 
Registered: Dec 2007
Distribution: Mandriva 2008.0 (w/ 2007.1 non-free)
Posts: 13

Original Poster
Rep: Reputation: 0
and it's broken.

and I restart.. and it's broken again. I give up.
 
Old 12-27-2007, 09:26 AM   #9
Agentvenom
Member
 
Registered: Sep 2005
Distribution: PCLinuxOS 2007 / Suse 10.3
Posts: 228

Rep: Reputation: 30
Quote:
Originally Posted by about36ninjas View Post
and I restart.. and it's broken again. I give up.
I did it the "hacky" way once.

You can create a .Xmodmap in your /home/username folder with the proper mappings in it. Then, I copied /etc/X11/xinit/xinitrc (which is a script) to /home/username/.kde/Autostart (I'm pretty sure that's right!) and edited the script to reflect my /home/username/.Xmodmap file. Restart X. Then, when it runs the Autostart stuff, it will execute the script and use the .Xmodmap from your home folder and make those keys mapped! It's worth a shot!!!

Last edited by Agentvenom; 12-27-2007 at 09:27 AM.
 
Old 12-27-2007, 02:33 PM   #10
about36ninjas
LQ Newbie
 
Registered: Dec 2007
Distribution: Mandriva 2008.0 (w/ 2007.1 non-free)
Posts: 13

Original Poster
Rep: Reputation: 0
Smile

It turns out, KDE was mapping those keys to some crazy hotkey function in the control panel. I have no idea why, but that was overriding all my functions for those keys. I erased the hotkeys for volume in khotkeys... remapped them to kmix's DCOP functions... and then restarted X (PS I already tried the hacky way :P). It now works, and I now know how to make hotkeys in KDE. All is well!!
 
Old 12-30-2007, 12:59 AM   #11
Agentvenom
Member
 
Registered: Sep 2005
Distribution: PCLinuxOS 2007 / Suse 10.3
Posts: 228

Rep: Reputation: 30
Quote:
Originally Posted by about36ninjas View Post
It turns out, KDE was mapping those keys to some crazy hotkey function in the control panel. I have no idea why, but that was overriding all my functions for those keys. I erased the hotkeys for volume in khotkeys... remapped them to kmix's DCOP functions... and then restarted X (PS I already tried the hacky way :P). It now works, and I now know how to make hotkeys in KDE. All is well!!
Great! Glad you're up and running....again! :P
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Master Volume Control Doesn't work, only PCM does jpneron Suse/Novell 3 11-11-2008 08:53 AM
Configuring master volume control for Intel ICH5 Alsa liquidfu22 Linux - Hardware 0 03-09-2007 12:56 PM
Master Volume Control Issue dingledoink Ubuntu 0 09-23-2005 01:34 PM
Creating a True master volume control slider Boffy Programming 4 09-09-2004 03:53 PM
master volume control for both front and rear? zarathustra674 Mandriva 1 12-05-2003 06:03 PM


All times are GMT -5. The time now is 05:50 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration